]> git.pld-linux.org Git - packages/zchunk.git/blob - zchunk.spec
4b206fa584f44f44dcfddafa5ce0a21445ecb5ba
[packages/zchunk.git] / zchunk.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library for generating easy-to-delta files
6 Summary(pl.UTF-8):      Biblioteka do generowania plików pozwalających na łatwe generowanie różnic
7 Name:           zchunk
8 Version:        1.1.9
9 Release:        2
10 License:        BSD
11 Group:          Applications/File
12 #Source0Download: https://github.com/zchunk/zchunk/releases
13 Source0:        https://github.com/zchunk/zchunk/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  b75c16c9393434dff27a497390cc82a0
15 URL:            https://github.com/zchunk/zchunk
16 BuildRequires:  curl-devel
17 BuildRequires:  gcc >= 5:3.2
18 BuildRequires:  meson >= 0.44.0
19 BuildRequires:  ninja >= 1.5
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.736
23 BuildRequires:  zstd-devel
24 Requires:       %{name}-libs = %{version}-%{release}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 zchunk is a compressed file format that splits the file into
29 independent chunks. This allows you to only download changed chunks
30 when downloading a new version of the file, and also makes zchunk
31 files efficient over rsync.
32
33 zchunk files are protected with strong checksums to verify that the
34 file you downloaded is, in fact, the file you wanted.
35
36 %description -l pl.UTF-8
37 zchunk to format skompresowanych plików dzielący plik na niezależne
38 części. Pozwala to pobierać tylko zmienione części przy ściąganiu
39 nowej wersji pliku oraz czyni format wydajnym dla rsynca.
40
41 Plik zchunk są chronione silnymi sumami kontrolnymi w celu
42 weryfikacji, czy pobrany plik jest faktycznie tym, którym miał być.
43
44 %package libs
45 Summary:        Shared zck library
46 Summary(pl.UTF-8):      Biblioteka współdzielona zck
47 Group:          Libraries
48
49 %description libs
50 zchunk is a compressed file format that splits the file into
51 independent chunks. This allows you to only download changed chunks
52 when downloading a new version of the file, and also makes zchunk
53 files efficient over rsync.
54
55 zchunk files are protected with strong checksums to verify that the
56 file you downloaded is, in fact, the file you wanted.
57
58 This package contains shared library.
59
60 %description libs -l pl.UTF-8
61 zchunk to format skompresowanych plików dzielący plik na niezależne
62 części. Pozwala to pobierać tylko zmienione części przy ściąganiu
63 nowej wersji pliku oraz czyni format wydajnym dla rsynca.
64
65 Plik zchunk są chronione silnymi sumami kontrolnymi w celu
66 weryfikacji, czy pobrany plik jest faktycznie tym, którym miał być.
67
68 Ten pakiet zawiera bibliotekę współdzieloną.
69
70 %package devel
71 Summary:        Header files for zck library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki zck
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       openssl-devel
76 Requires:       zstd-devel
77
78 %description devel
79 Header files for zck library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki zck.
83
84 %package static
85 Summary:        Static zck library
86 Summary(pl.UTF-8):      Statyczna biblioteka zck
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static zck library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka zck.
95
96 %prep
97 %setup -q
98
99 %build
100 %meson build \
101         %{!?with_static_libs:--default-library=shared}
102
103 %ninja_build -C build
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %ninja_install -C build
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   libs -p /sbin/ldconfig
114 %postun libs -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc LICENSE README.md
119 %attr(755,root,root) %{_bindir}/unzck
120 %attr(755,root,root) %{_bindir}/zck
121 %attr(755,root,root) %{_bindir}/zck_delta_size
122 %attr(755,root,root) %{_bindir}/zck_gen_zdict
123 %attr(755,root,root) %{_bindir}/zck_read_header
124 # R: curl
125 %attr(755,root,root) %{_bindir}/zckdl
126 %{_mandir}/man1/unzck.1*
127 %{_mandir}/man1/zck.1*
128 %{_mandir}/man1/zck_delta_size.1*
129 %{_mandir}/man1/zck_gen_zdict.1*
130 %{_mandir}/man1/zck_read_header.1*
131 %{_mandir}/man1/zckdl.1*
132
133 %files libs
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libzck.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libzck.so.1
137
138 %files devel
139 %defattr(644,root,root,755)
140 %doc zchunk_format.txt
141 %attr(755,root,root) %{_libdir}/libzck.so
142 %{_includedir}/zck.h
143 %{_pkgconfigdir}/zck.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libzck.a
149 %endif
This page took 0.063216 seconds and 2 git commands to generate.