]> git.pld-linux.org Git - packages/zathura.git/blob - zathura.spec
correct bash-completion epoch
[packages/zathura.git] / zathura.spec
1 Summary:        A vi-like PDF reader
2 Summary(hu.UTF-8):      Egy vi-szerű PDF olvasó
3 Summary(pl.UTF-8):      Czytnik PDF podobny do vi
4 Name:           zathura
5 Version:        0.5.1
6 Release:        1
7 License:        BSD-like
8 Group:          Applications/Text
9 Source0:        https://git.pwmt.org/pwmt/zathura/-/archive/%{version}/zathura-%{version}.tar.gz
10 # Source0-md5:  ebff8233b2e588def137a33a632b1c91
11 Source1:        config.txt
12 URL:            http://pwmt.org/projects/zathura
13 BuildRequires:  cairo-devel
14 # C11
15 BuildRequires:  gcc >= 6:4.7
16 BuildRequires:  girara-devel >= 0.3.7
17 BuildRequires:  glib2-devel >= 1:2.50.0
18 BuildRequires:  gtk+3-devel >= 3.22
19 BuildRequires:  intltool
20 BuildRequires:  libmagic-devel
21 BuildRequires:  libseccomp-devel
22 BuildRequires:  meson >= 0.56
23 BuildRequires:  ninja
24 BuildRequires:  pkgconfig
25 BuildRequires:  python-docutils
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  sqlite3-devel >= 3.5.9
30 BuildRequires:  synctex-devel >= 1.19
31 Requires(post,postun):  gtk-update-icon-cache
32 Requires:       girara >= 0.3.7
33 Requires:       glib2 >= 1:2.50.0
34 Requires:       gtk+3 >= 3.22
35 Requires:       hicolor-icon-theme
36 Requires:       sqlite3-libs >= 3.5.9
37 Requires:       synctex >= 1.19
38 Suggests:       zathura-pdf-poppler
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define fishdir %{_datadir}/fish/vendor_completions.d
42
43 %description
44 zathura is a highly customizable and functional PDF viewer based on
45 the poppler rendering library and the GTK+ toolkit. The idea behind
46 zathura is an application that provides a minimalistic and space
47 saving interface as well as an easy usage that mainly focuses on
48 keyboard interaction.
49
50 %description -l hu.UTF-8
51 zathura egy magas szinten konfigurálható és funkcionális PDF olvasó a
52 poppler és GTK+ könyvtárako alapulva. A zathura célja, hogy egy olyan
53 alkalmazás legyen, amely minimalista és terület-takarékos felületet
54 biztosítson, amennyire lehet, és könnyen lehessen használni, főleg
55 billentyűzet segítségével.
56
57 %description -l pl.UTF-8
58 zathura jest wysoko konfigurowalnym i funkcjonalnym czytnikiem PDF
59 opartym na bibliotece renderującej poppler i zestawie narzędziowym
60 GTK+. zathura jest aplikacją, która udostępnia minimalistyczny i nie
61 zajmujący dużo miejsca interfejs, który jednocześnie jest prosty w
62 użyciu. Interfejs skupia się głównie na interakcji klawiaturowej.
63
64 %package devel
65 Summary:        Header files for zathura
66 Summary(pl.UTF-8):      Pliki nagłówkowe aplikacji zathura
67 Group:          Development/Libraries
68 # doesn't require base
69 Requires:       girara-devel >= 0.3.7
70
71 %description devel
72 Header files for zathura.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe aplikacji zathura.
76
77 %package -n bash-completion-zathura
78 Summary:        Bash completion for zathura command line
79 Summary(pl.UTF-8):      Bashowe dopełnianie linii poleceń programu zathura
80 Group:          Applications/Shells
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       bash-completion >= 1:2.0
83 BuildArch:      noarch
84
85 %description -n bash-completion-zathura
86 Bash completion for zathura command line.
87
88 %description -n bash-completion-zathura -l pl.UTF-8
89 Bashowe dopełnianie linii poleceń programu zathura.
90
91 %package -n fish-completion-zathura
92 Summary:        fish-completion for zathura
93 Summary(pl.UTF-8):      Uzupełnianie nazw w fish dla zathura
94 Group:          Applications/Shells
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       fish
97 BuildArch:      noarch
98
99 %description -n fish-completion-zathura
100 fish-completion for zathura.
101
102 %description -n fish-completion-zathura -l pl.UTF-8
103 Pakiet ten dostarcza uzupełnianie nazw w fish dla zathura.
104
105 %package -n zsh-completion-zathura
106 Summary:        ZSH completion for zathura command line
107 Summary(pl.UTF-8):      Dopełnianie linii poleceń programu zathura dla powłoki ZSH
108 Group:          Applications/Shells
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       zsh
111 BuildArch:      noarch
112
113 %description -n zsh-completion-zathura
114 ZSH completion for zathura command line.
115
116 %description -n zsh-completion-zathura -l pl.UTF-8
117 Dopełnianie linii poleceń programu zathura dla powłoki ZSH.
118
119 %prep
120 %setup -q
121 cp %{SOURCE1} config.txt
122
123 %build
124 %meson build
125
126 %ninja_build -C build
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
132
133 %ninja_install -C build
134
135 %{__mv} $RPM_BUILD_ROOT%{_localedir}/id_ID $RPM_BUILD_ROOT%{_localedir}/id
136 %{__mv} $RPM_BUILD_ROOT%{_localedir}/no $RPM_BUILD_ROOT%{_localedir}/nb
137 %{__mv} $RPM_BUILD_ROOT%{_localedir}/ta_IN $RPM_BUILD_ROOT%{_localedir}/ta
138 %{__mv} $RPM_BUILD_ROOT%{_localedir}/uk_UA $RPM_BUILD_ROOT%{_localedir}/uk
139
140 %find_lang %{name}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 %update_icon_cache hicolor
147
148 %postun
149 %update_icon_cache hicolor
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc LICENSE README.md config.txt
154 %attr(755,root,root) %{_bindir}/zathura
155 %{_desktopdir}/org.pwmt.zathura.desktop
156 %{_datadir}/metainfo/org.pwmt.zathura.appdata.xml
157 %{_datadir}/dbus-1/interfaces/org.pwmt.zathura.xml
158 %{_iconsdir}/hicolor/scalable/apps/org.pwmt.zathura.svg
159 %{_mandir}/man1/zathura.1*
160 %{_mandir}/man5/zathurarc.5*
161 %dir %{_libdir}/zathura
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{_includedir}/zathura
166 %{_pkgconfigdir}/zathura.pc
167
168 %files -n bash-completion-zathura
169 %defattr(644,root,root,755)
170 %{bash_compdir}/zathura
171
172 %files -n fish-completion-zathura
173 %defattr(644,root,root,755)
174 %{fishdir}/zathura.fish
175
176 %files -n zsh-completion-zathura
177 %defattr(644,root,root,755)
178 %{zsh_compdir}/_zathura
This page took 0.067759 seconds and 3 git commands to generate.