]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
d0e5d482903afbd91bceab6c1e90f62926cc7868
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 # - unpackaged files:
4 #   /lib/systemd/system/zabbix_java.service
5 #   /usr/bin/zabbix_js
6 #   /var/lib/zabbix/zabbix.db
7 #
8 # Conditional build:
9 %bcond_without  pgsql   # enable PostgreSQL support
10 %bcond_without  sqlite3 # enable sqlite3 support
11 %bcond_without  mysql   # enable MySQL support
12 %bcond_without  java    # disable java support
13 %bcond_without  agent2  # disable bulding of Go based agent2
14
15 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
16 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
17
18 %ifnarch %{go_arches}
19 %undefine       with_agent2
20 %endif
21
22 %define         php_min_version 7.2.5
23 Summary:        Zabbix - network monitoring software
24 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
25 Name:           zabbix
26 Version:        5.4.3
27 Release:        3
28 License:        GPL v2+
29 Group:          Networking/Utilities
30 # https://www.zabbix.com/download_sources
31 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/5.4/%{name}-%{version}.tar.gz
32 # Source0-md5:  5dccb536c164e45c7d5c1a5a9d64be43
33 Source100:      go-vendor.tar.xz
34 # Source100-md5:        61f2ee9647280765b622a5e1e8cdfbba
35 Source1:        %{name}-apache.conf
36 Source2:        %{name}_server.service
37 Source3:        %{name}_agentd.service
38 Source4:        %{name}_proxy.service
39 Source5:        %{name}_java.service
40 Source6:        %{name}.tmpfiles
41 Source7:        %{name}_agentd.init
42 Source8:        %{name}_agent2.init
43 %if 0
44 cd src/go/
45 go mod vendor
46 tar -caf ~/go-vendor.tar.xz -C ../../ src/go/vendor
47 %endif
48 Patch0:         config.patch
49 Patch1:         sqlite3_dbname.patch
50 Patch2:         always_compile_ipc.patch
51 Patch3:         go-destdir.patch
52 Patch4:         go-vendor.patch
53 URL:            https://www.zabbix.com/
54 BuildRequires:  OpenIPMI-devel
55 BuildRequires:  autoconf
56 BuildRequires:  automake >= 1:1.15
57 BuildRequires:  curl-devel
58 BuildRequires:  iksemel-devel
59 %{?with_java:BuildRequires:     jdk}
60 BuildRequires:  rpm-build >= 4.6
61 %{?with_java:BuildRequires:     rpm-pld-macros-javaprov}
62 %{?with_agent2:BuildRequires:   golang >= 1.13}
63 BuildRequires:  libevent-devel
64 BuildRequires:  libssh2-devel
65 BuildRequires:  libtool
66 BuildRequires:  libxml2-devel
67 %{?with_mysql:BuildRequires:    mysql-devel}
68 BuildRequires:  net-snmp-devel
69 BuildRequires:  openldap-devel >= 2.4.6
70 BuildRequires:  openssl-devel >= 0.9.7d
71 BuildRequires:  pcre-devel
72 %{?with_pgsql:BuildRequires:    postgresql-devel}
73 BuildRequires:  rpmbuild(macros) >= 2.009
74 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  unixODBC-devel
77 BuildRequires:  xz
78 BuildRequires:  zlib-devel
79 Requires:       %{name}-agentd = %{version}-%{release}
80 Requires:       %{name}-frontend-php = %{version}-%{release}
81 Requires:       %{name}-server = %{version}-%{release}
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _sysconfdir     /etc/%{name}
85 %define         _appdir         %{_datadir}/%{name}
86 %define         _webapps        /etc/webapps
87 %define         _webapp         %{name}
88
89 %description
90 Zabbix is software that monitors numerous parameters of a network and
91 the servers on that network. It is a useful tool for monitoring the
92 health and integrity of servers. Zabbix uses a flexible notification
93 mechanism that allows users to configure email based alerts for
94 virtually any event. All monitored parameters are stored in a
95 database. Zabbix offers excellent reporting and data visualisation
96 features based on the stored data. Zabbix supports both polling and
97 trapping. All Zabbix reports and statistics, as well as configuration
98 parameters, are accessed through a web-based front end.
99
100 %description -l pl.UTF-8
101 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
102 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
103 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
104 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
105 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
106 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
107 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
108 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
109 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
110
111 %package common
112 Summary:        Common files for Zabbix monitoring software
113 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
114 Group:          Networking/Utilities
115 Requires(postun):       /usr/sbin/groupdel
116 Requires(postun):       /usr/sbin/userdel
117 Requires(pre):  /bin/id
118 Requires(pre):  /usr/bin/getgid
119 Requires(pre):  /usr/sbin/groupadd
120 Requires(pre):  /usr/sbin/useradd
121 Provides:       group(zabbix)
122 Provides:       user(zabbix)
123
124 %description common
125 Common files for Zabbix monitoring software.
126
127 %description common -l pl.UTF-8
128 Wspólne pliki dla oprogramowania monitorującego Zabbix.
129
130 %package agentd
131 Summary:        Zabbix Agent
132 Summary(pl.UTF-8):      Agenta Zabbiksa
133 Group:          Networking/Utilities
134 Requires:       %{name}-common = %{version}-%{release}
135 Requires:       systemd-units >= 38
136 Obsoletes:      zabbix-agent-inetd
137 Obsoletes:      zabbix-agent-standalone
138 Requires(post,preun):   /sbin/chkconfig
139 Requires:       rc-scripts
140
141 %description agentd
142 Zabbix agent collects data from the local system for a Zabbix server.
143
144 %description agentd -l pl.UTF-8
145 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
146
147 %package agent2
148 Summary:        Zabbix Agent 2
149 Group:          Networking/Utilities
150 URL:            https://www.zabbix.com/documentation/current/manual/concepts/agent2
151 Requires:       %{name}-common = %{version}-%{release}
152 Requires(post,preun):   /sbin/chkconfig
153 Requires:       rc-scripts
154
155 %description agent2
156 Zabbix agent 2 is a new generation of Zabbix agent and may be used in
157 place of Zabbix agent.
158
159 Zabbix agent 2 has been developed to:
160 - reduce the number of TCP connections
161 - have greater check concurrency
162 - be easily extendible with plugins.
163
164 A plugin should be able to:
165 - provide trivial checks consisting of only a few simple lines of code
166 - provide complex checks consisting of long-running scripts and
167   standalone data gathering with periodic sending back of the data
168 - be a drop-in replacement for Zabbix agent (in that it supports all
169   the previous functionality)
170
171 Passive checks work similarly to Zabbix agent. Active checks support
172 scheduled/flexible intervals and check concurrency within one active
173 server.
174
175 %package frontend-php
176 Summary:        PHP frontend for Zabbix
177 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
178 Group:          Applications/WWW
179 Requires:       php(bcmath)
180 Requires:       php(core) >= %{php_min_version}
181 Requires:       php(ctype)
182 Requires:       php(gd)
183 Requires:       php(gettext)
184 Requires:       php(json)
185 Requires:       php(mbstring)
186 Requires:       php(pcre)
187 Requires:       php(session)
188 Requires:       php(sockets)
189 Requires:       php(xml)
190 Requires:       php(xmlreader)
191 Requires:       php(xmlwriter)
192 Requires:       webapps
193 Requires:       webserver(alias)
194 Requires:       webserver(indexfile)
195 Requires:       webserver(php)
196 Suggests:       php(mysql)
197 Suggests:       php(pgsql)
198 Suggests:       php(sqlite3)
199 # used with sqlite3
200 Suggests:       php(sysvsem)
201 BuildArch:      noarch
202
203 %description frontend-php
204 This package provides web based (PHP) frontend for Zabbix.
205
206 %description frontend-php -l pl.UTF-8
207 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
208
209 %package get
210 Summary:        Program retrieving data from Zabbix agent
211 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
212 Group:          Networking/Utilities
213
214 %description get
215 This package provides a program retrieving data from Zabbix agent.
216
217 %description get -l pl.UTF-8
218 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
219
220 %package proxy
221 Summary:        Zabbix proxy
222 Summary(pl.UTF-8):      Proxy do Zabbiksa
223 Group:          Networking/Utilities
224 Requires:       %{name}-common = %{version}-%{release}
225 Requires:       systemd-units >= 38
226 Requires:       zabbix-proxy(db) = %{version}-%{release}
227
228 %description proxy
229 This package provides the Zabbix proxy.
230
231 %description proxy -l pl.UTF-8
232 Ten pakiet zawiera proxy Zabbix.
233
234 %package proxy-mysql
235 Summary:        MySQL support for Zabbix proxy
236 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
237 Group:          Networking/Utilities
238 Provides:       %{name}-proxy(db) = %{version}-%{release}
239 Obsoletes:      zabbix-proxy-postgresql
240 Obsoletes:      zabbix-proxy-sqlite3
241
242 %description proxy-mysql
243 This package provides the Zabbix proxy binary with MySQL support.
244
245 %description proxy-mysql -l pl.UTF-8
246 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
247
248 %package proxy-postgresql
249 Summary:        PostgreSQL support for Zabbix proxy
250 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
251 Group:          Networking/Utilities
252 Provides:       %{name}-proxy(db) = %{version}-%{release}
253 Obsoletes:      zabbix-proxy-mysql
254 Obsoletes:      zabbix-proxy-sqlite3
255
256 %description proxy-postgresql
257 This package provides the Zabbix proxy binary with PostgreSQL support.
258
259 %description proxy-postgresql -l pl.UTF-8
260 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
261
262 %package proxy-sqlite3
263 Summary:        SQLite 3 support for Zabbix proxy
264 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
265 Group:          Networking/Utilities
266 Provides:       %{name}-proxy(db) = %{version}-%{release}
267 Obsoletes:      zabbix-proxy-mysql
268 Obsoletes:      zabbix-proxy-postgresql
269
270 %description proxy-sqlite3
271 This package provides the Zabbix proxy binary with SQLite 3 support.
272
273 %description proxy-sqlite3 -l pl.UTF-8
274 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
275
276 %package sender
277 Summary:        Zabbix sender
278 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
279 Group:          Networking/Utilities
280
281 %description sender
282 This package provides the Zabbix sender.
283
284 %description sender -l pl.UTF-8
285 Ten pakiet zawiera program zawiadamiający Zabbiksa.
286
287 %package server
288 Summary:        Zabbix server
289 Summary(pl.UTF-8):      Serwer Zabbiksa
290 Group:          Networking/Utilities
291 Requires:       %{name}-common = %{version}-%{release}
292 Requires:       %{name}-server(db) = %{version}-%{release}
293 Requires:       systemd-units >= 38
294 Obsoletes:      zabbix-suckerd
295 Obsoletes:      zabbix-trapper-inetd
296 Obsoletes:      zabbix-trapper-standalone
297
298 %description server
299 This package provides the Zabbix server.
300
301 %description server -l pl.UTF-8
302 Ten pakiet zawiera serwer Zabbiksa.
303
304 %package server-mysql
305 Summary:        MySQL support for Zabbix server
306 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
307 Group:          Networking/Utilities
308 Provides:       %{name}-server(db) = %{version}-%{release}
309 Obsoletes:      zabbix-server-postgresql
310 Obsoletes:      zabbix-server-sqlite3
311
312 %description server-mysql
313 This package provides the Zabbix server binary for use with MySQL
314 database.
315
316 %description server-mysql -l pl.UTF-8
317 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
318
319 %package server-postgresql
320 Summary:        PostgreSQL support for Zabbix server
321 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
322 Group:          Networking/Utilities
323 Provides:       %{name}-server(db) = %{version}-%{release}
324 Obsoletes:      zabbix-server-mysql
325 Obsoletes:      zabbix-server-sqlite3
326
327 %description server-postgresql
328 This package provides the Zabbix server binary for use with PostgreSQL
329 database.
330
331 %description server-postgresql -l pl.UTF-8
332 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
333
334 %package java
335 Summary:        Zabbix Java Gateway
336 Group:          Networking/Utilities
337 Requires:       %{name}-common = %{version}-%{release}
338 Requires:       systemd-units >= 38
339
340 %description java
341 This package provides the Zabbix Java Gateway.
342
343 %prep
344 %setup -q -a100
345 %patch0 -p1
346 %patch1 -p1
347 %patch2 -p1
348 %patch3 -p1
349 %patch4 -p1
350
351 %build
352 %{__libtoolize}
353 %{__aclocal} -I m4
354 %{__autoconf}
355 %{__autoheader}
356 %{__automake}
357
358 configure() {
359         %configure \
360         --enable-dependency-tracking \
361         --enable-agent \
362         %{__enable_disable agent2} \
363         --enable-ipv6 \
364         %{__enable_disable java} \
365         --with-ldap \
366         --with-libcurl \
367         --with-libevent \
368         --with-libpcre \
369         --with-libxml2 \
370         --with-net-snmp \
371         --with-openipmi \
372         --with-openssl \
373         --with-ssh2 \
374         --with-unixodbc \
375         "$@"
376 }
377
378 configure \
379         --disable-server \
380         --disable-proxy
381
382 %{__make}
383
384 for database in %{databases} ; do
385         if [ "$database" = "sqlite3" ] ; then
386                 enable_server=""
387         else
388                 enable_server="--enable-server"
389         fi
390         configure \
391                 --with-$database \
392                 $enable_server \
393                 --enable-proxy
394
395         %{__make}
396
397         if [ "$enable_server" ] ; then
398                 %{__make} install \
399                         -C src/zabbix_server \
400                         DESTDIR=$PWD/install-${database}
401         fi
402
403         %{__make} install \
404                 -C src/zabbix_proxy \
405                 DESTDIR=$PWD/install-${database}
406 done
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 install -d \
411         $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_agent2.conf.d,/etc/webapps/%{_webapp}} \
412         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_appdir}/frontends/php} \
413         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
414
415 %{__make} install \
416         DESTDIR=$RPM_BUILD_ROOT \
417         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
418
419 for database in %{databases} ; do
420         if [ "$database" != "sqlite3" ] ; then
421                 cp -p install-$database/%{_sbindir}/zabbix_server \
422                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
423         fi
424         cp -p install-$database/%{_sbindir}/zabbix_proxy \
425                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
426 done
427
428 if [ -n "$database" ] ; then
429         ln -sf zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
430         ln -sf zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
431 fi
432
433 %if %{with sqlite3}
434 install -d $RPM_BUILD_ROOT/var/lib/zabbix
435 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
436 %endif
437
438 cp -r ui/* $RPM_BUILD_ROOT%{_appdir}/frontends/php
439
440 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
441 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
442
443 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
444 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
445 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
446 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
447 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
448 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
449
450 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
451
452 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
453 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/frontend,%{_appdir}/frontends/php/conf}
454 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
455
456 %if %{with java}
457 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
458 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_java.conf,%{_datadir}/zabbix_java/settings.sh}
459 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
460 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback.xml,%{_datadir}/zabbix_java/lib/logback.xml}
461 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
462 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback-console.xml,%{_datadir}/zabbix_java/lib/logback-console.xml}
463
464 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
465 #!/bin/sh
466
467 exec %{_datadir}/zabbix_java/startup.sh "$@"
468 EOF
469
470 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
471 #!/bin/sh
472
473 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
474 EOF
475 %endif
476
477 %clean
478 rm -rf $RPM_BUILD_ROOT
479
480 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
481 %webapp_register apache %{_webapp}
482
483 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
484 %webapp_unregister apache %{_webapp}
485
486 %triggerin frontend-php -- apache < 2.2.0, apache-base
487 %webapp_register httpd %{_webapp}
488
489 %triggerun frontend-php -- apache < 2.2.0, apache-base
490 %webapp_unregister httpd %{_webapp}
491
492 %pre common
493 %groupadd -g 111 zabbix
494 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
495 %addusertogroup -q zabbix proc
496
497 %postun common
498 if [ "$1" = "0" ]; then
499         %userremove zabbix
500         %groupremove zabbix
501 fi
502
503 %post server-mysql
504 if [ "$1" = 1 ]; then
505         %banner -e %{name}-server <<-EOF
506         You should create database for Zabbix.
507
508         Running these should be fine in most cases:
509         mysqladmin create zabbix
510         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
511         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
512         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
513 EOF
514 fi
515 ln -sf zabbix_server-mysql %{_sbindir}/zabbix_server || :
516
517 %post server-postgresql
518 if [ "$1" = 1 ]; then
519         %banner -e %{name}-server <<-EOF
520         You should create database for Zabbix.
521
522         Running these should be fine in most cases:
523
524         createuser zabbix
525         createdb -O zabbix zabbix
526         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
527         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
528         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
529 EOF
530 fi
531 ln -sf zabbix_server-postgresql %{_sbindir}/zabbix_server || :
532
533 %post server
534 %systemd_post zabbix_server.service
535
536 %preun server
537 %systemd_preun zabbix_server.service
538
539 %postun server
540 if [ "$1" = "0" ]; then
541         if [ -L %{_sbindir}/zabbix_server ] ; then
542                 rm -f %{_sbindir}/zabbix_server || :
543         fi
544 fi
545 %systemd_reload
546
547 %post agentd
548 /sbin/chkconfig --add zabbix_agentd
549 %service zabbix_agentd restart
550 %systemd_post zabbix_agentd.service
551
552 %preun agentd
553 if [ "$1" = "0" ]; then
554         %service -q zabbix_agentd stop
555         /sbin/chkconfig --del zabbix_agentd
556 fi
557 %systemd_preun zabbix_agentd.service
558
559 %postun agentd
560 %systemd_reload
561
562 %post agent2
563 /sbin/chkconfig --add zabbix_agent2
564 %service zabbix_agent2 restart
565
566 %preun agent2
567 if [ "$1" = "0" ]; then
568         %service -q zabbix_agent2 stop
569         /sbin/chkconfig --del zabbix_agent2
570 fi
571
572 %post proxy-mysql
573 ln -sf zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
574
575 %post proxy-postgresql
576 ln -sf zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
577
578 %post proxy-sqlite3
579 ln -sf zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
580
581 %post proxy
582 %systemd_post zabbix_proxy.service
583
584 %preun proxy
585 %systemd_preun zabbix_proxy.service
586
587 %postun proxy
588 %systemd_reload
589
590 %post java
591 %systemd_post zabbix_java.service
592
593 %preun java
594 %systemd_preun zabbix_java.service
595
596 %postun java
597 %systemd_reload
598
599 %files
600 %defattr(644,root,root,755)
601 %doc AUTHORS ChangeLog README
602
603 %files common
604 %defattr(644,root,root,755)
605 %doc AUTHORS ChangeLog README
606 %attr(751,root,zabbix) %dir %{_sysconfdir}
607 %attr(751,root,http) %dir %{_sysconfdir}/frontend
608 %dir %{_appdir}
609 %dir %{_appdir}/frontends
610 %dir %attr(770,root,zabbix) /var/run/zabbix
611 %dir %attr(775,root,zabbix) /var/log/zabbix
612 %{systemdtmpfilesdir}/zabbix.conf
613
614 %files agentd
615 %defattr(644,root,root,755)
616 %doc conf/zabbix_agentd/*.conf
617 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
618 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
619 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
620 %attr(755,root,root) %{_sbindir}/zabbix_agentd
621 %{_mandir}/man8/zabbix_agentd*
622 %{systemdunitdir}/zabbix_agentd.service
623
624 %if %{with agent2}
625 %files agent2
626 %defattr(644,root,root,755)
627 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
628 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.conf.d
629 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
630 %attr(755,root,root) %{_sbindir}/zabbix_agent2
631 %{_mandir}/man8/zabbix_agent2.8*
632 %endif
633
634 %files frontend-php
635 %defattr(644,root,root,755)
636 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
637 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
638 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
639 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
640 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
641 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
642 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
643 %{_appdir}/frontends/php
644
645 %files get
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_bindir}/zabbix_get
648 %{_mandir}/man1/zabbix_get*
649
650 %if %{any_database}
651 %files proxy
652 %defattr(644,root,root,755)
653 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
654 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
655 %ghost %{_sbindir}/zabbix_proxy
656 %{_mandir}/man8/zabbix_proxy*
657 %{systemdunitdir}/zabbix_proxy.service
658 %endif
659
660 %if %{with mysql}
661 %files proxy-mysql
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
664 %endif
665
666 %if %{with pgsql}
667 %files proxy-postgresql
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
670 %endif
671
672 %if %{with sqlite3}
673 %files proxy-sqlite3
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
676 %endif
677
678 %files sender
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_bindir}/zabbix_sender
681 %{_mandir}/man1/zabbix_sender*
682
683 %if %{any_database}
684 %files server
685 %defattr(644,root,root,755)
686 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
687 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
688 %ghost %{_sbindir}/zabbix_server
689 %{_mandir}/man8/zabbix_server*
690 %{systemdunitdir}/zabbix_server.service
691 %endif
692
693 %if %{with mysql}
694 %files server-mysql
695 %defattr(644,root,root,755)
696 %doc database/mysql/*.sql
697 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
698 %endif
699
700 %if %{with pgsql}
701 %files server-postgresql
702 %defattr(644,root,root,755)
703 %doc database/postgresql/*.sql
704 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
705 %endif
706
707 %if %{with java}
708 %files java
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_sbindir}/zabbix_java-start
711 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
712 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
713 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
714 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
715 %dir %{_datadir}/zabbix_java
716 %{_datadir}/zabbix_java/bin
717 %{_datadir}/zabbix_java/lib
718 %{_datadir}/zabbix_java/settings.sh
719 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
720 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
721 %{systemdunitdir}/zabbix_java.service
722 %endif
This page took 0.087646 seconds and 2 git commands to generate.