]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
switch to %use_default_jdk
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 # - unpackaged files:
4 #   /lib/systemd/system/zabbix_java.service
5 #   /usr/bin/zabbix_js
6 #   /var/lib/zabbix/zabbix.db
7 #
8 # Conditional build:
9 %bcond_without  pgsql   # enable PostgreSQL support
10 %bcond_without  sqlite3 # enable sqlite3 support
11 %bcond_without  mysql   # enable MySQL support
12 %bcond_without  java    # disable java support
13 %bcond_without  agent2  # disable bulding of Go based agent2
14
15 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
16 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
17
18 %ifnarch %{go_arches}
19 %undefine       with_agent2
20 %endif
21
22 %{?with_java:%{?use_default_jdk}}
23
24 %define         php_min_version 7.2.5
25 Summary:        Zabbix - network monitoring software
26 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
27 Name:           zabbix
28 Version:        5.4.3
29 Release:        3
30 License:        GPL v2+
31 Group:          Networking/Utilities
32 # https://www.zabbix.com/download_sources
33 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/5.4/%{name}-%{version}.tar.gz
34 # Source0-md5:  5dccb536c164e45c7d5c1a5a9d64be43
35 Source100:      go-vendor.tar.xz
36 # Source100-md5:        61f2ee9647280765b622a5e1e8cdfbba
37 Source1:        %{name}-apache.conf
38 Source2:        %{name}_server.service
39 Source3:        %{name}_agentd.service
40 Source4:        %{name}_proxy.service
41 Source5:        %{name}_java.service
42 Source6:        %{name}.tmpfiles
43 Source7:        %{name}_agentd.init
44 Source8:        %{name}_agent2.init
45 %if 0
46 cd src/go/
47 go mod vendor
48 tar -caf ~/go-vendor.tar.xz -C ../../ src/go/vendor
49 %endif
50 Patch0:         config.patch
51 Patch1:         sqlite3_dbname.patch
52 Patch2:         always_compile_ipc.patch
53 Patch3:         go-destdir.patch
54 Patch4:         go-vendor.patch
55 URL:            https://www.zabbix.com/
56 BuildRequires:  OpenIPMI-devel
57 BuildRequires:  autoconf
58 BuildRequires:  automake >= 1:1.15
59 BuildRequires:  curl-devel
60 BuildRequires:  iksemel-devel
61 %{?with_java:%{?use_jdk:%buildrequires_jdk}%{!?use_jdk:BuildRequires:   jdk}}
62 BuildRequires:  rpm-build >= 4.6
63 %{?with_java:BuildRequires:     rpm-pld-macros-javaprov}
64 %{?with_agent2:BuildRequires:   golang >= 1.13}
65 BuildRequires:  libevent-devel
66 BuildRequires:  libssh2-devel
67 BuildRequires:  libtool
68 BuildRequires:  libxml2-devel
69 %{?with_mysql:BuildRequires:    mysql-devel}
70 BuildRequires:  net-snmp-devel
71 BuildRequires:  openldap-devel >= 2.4.6
72 BuildRequires:  openssl-devel >= 0.9.7d
73 BuildRequires:  pcre-devel
74 %{?with_pgsql:BuildRequires:    postgresql-devel}
75 BuildRequires:  rpmbuild(macros) >= 2.021
76 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
77 BuildRequires:  tar >= 1:1.22
78 BuildRequires:  unixODBC-devel
79 BuildRequires:  xz
80 BuildRequires:  zlib-devel
81 Requires:       %{name}-agentd = %{version}-%{release}
82 Requires:       %{name}-frontend-php = %{version}-%{release}
83 Requires:       %{name}-server = %{version}-%{release}
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _sysconfdir     /etc/%{name}
87 %define         _appdir         %{_datadir}/%{name}
88 %define         _webapps        /etc/webapps
89 %define         _webapp         %{name}
90
91 %description
92 Zabbix is software that monitors numerous parameters of a network and
93 the servers on that network. It is a useful tool for monitoring the
94 health and integrity of servers. Zabbix uses a flexible notification
95 mechanism that allows users to configure email based alerts for
96 virtually any event. All monitored parameters are stored in a
97 database. Zabbix offers excellent reporting and data visualisation
98 features based on the stored data. Zabbix supports both polling and
99 trapping. All Zabbix reports and statistics, as well as configuration
100 parameters, are accessed through a web-based front end.
101
102 %description -l pl.UTF-8
103 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
104 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
105 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
106 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
107 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
108 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
109 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
110 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
111 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
112
113 %package common
114 Summary:        Common files for Zabbix monitoring software
115 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
116 Group:          Networking/Utilities
117 Requires(postun):       /usr/sbin/groupdel
118 Requires(postun):       /usr/sbin/userdel
119 Requires(pre):  /bin/id
120 Requires(pre):  /usr/bin/getgid
121 Requires(pre):  /usr/sbin/groupadd
122 Requires(pre):  /usr/sbin/useradd
123 Provides:       group(zabbix)
124 Provides:       user(zabbix)
125
126 %description common
127 Common files for Zabbix monitoring software.
128
129 %description common -l pl.UTF-8
130 Wspólne pliki dla oprogramowania monitorującego Zabbix.
131
132 %package agentd
133 Summary:        Zabbix Agent
134 Summary(pl.UTF-8):      Agenta Zabbiksa
135 Group:          Networking/Utilities
136 Requires:       %{name}-common = %{version}-%{release}
137 Requires:       systemd-units >= 38
138 Obsoletes:      zabbix-agent-inetd
139 Obsoletes:      zabbix-agent-standalone
140 Requires(post,preun):   /sbin/chkconfig
141 Requires:       rc-scripts
142
143 %description agentd
144 Zabbix agent collects data from the local system for a Zabbix server.
145
146 %description agentd -l pl.UTF-8
147 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
148
149 %package agent2
150 Summary:        Zabbix Agent 2
151 Group:          Networking/Utilities
152 URL:            https://www.zabbix.com/documentation/current/manual/concepts/agent2
153 Requires:       %{name}-common = %{version}-%{release}
154 Requires(post,preun):   /sbin/chkconfig
155 Requires:       rc-scripts
156
157 %description agent2
158 Zabbix agent 2 is a new generation of Zabbix agent and may be used in
159 place of Zabbix agent.
160
161 Zabbix agent 2 has been developed to:
162 - reduce the number of TCP connections
163 - have greater check concurrency
164 - be easily extendible with plugins.
165
166 A plugin should be able to:
167 - provide trivial checks consisting of only a few simple lines of code
168 - provide complex checks consisting of long-running scripts and
169   standalone data gathering with periodic sending back of the data
170 - be a drop-in replacement for Zabbix agent (in that it supports all
171   the previous functionality)
172
173 Passive checks work similarly to Zabbix agent. Active checks support
174 scheduled/flexible intervals and check concurrency within one active
175 server.
176
177 %package frontend-php
178 Summary:        PHP frontend for Zabbix
179 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
180 Group:          Applications/WWW
181 Requires:       php(bcmath)
182 Requires:       php(core) >= %{php_min_version}
183 Requires:       php(ctype)
184 Requires:       php(gd)
185 Requires:       php(gettext)
186 Requires:       php(json)
187 Requires:       php(mbstring)
188 Requires:       php(pcre)
189 Requires:       php(session)
190 Requires:       php(sockets)
191 Requires:       php(xml)
192 Requires:       php(xmlreader)
193 Requires:       php(xmlwriter)
194 Requires:       webapps
195 Requires:       webserver(alias)
196 Requires:       webserver(indexfile)
197 Requires:       webserver(php)
198 Suggests:       php(mysql)
199 Suggests:       php(pgsql)
200 Suggests:       php(sqlite3)
201 # used with sqlite3
202 Suggests:       php(sysvsem)
203 BuildArch:      noarch
204
205 %description frontend-php
206 This package provides web based (PHP) frontend for Zabbix.
207
208 %description frontend-php -l pl.UTF-8
209 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
210
211 %package get
212 Summary:        Program retrieving data from Zabbix agent
213 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
214 Group:          Networking/Utilities
215
216 %description get
217 This package provides a program retrieving data from Zabbix agent.
218
219 %description get -l pl.UTF-8
220 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
221
222 %package proxy
223 Summary:        Zabbix proxy
224 Summary(pl.UTF-8):      Proxy do Zabbiksa
225 Group:          Networking/Utilities
226 Requires:       %{name}-common = %{version}-%{release}
227 Requires:       systemd-units >= 38
228 Requires:       zabbix-proxy(db) = %{version}-%{release}
229
230 %description proxy
231 This package provides the Zabbix proxy.
232
233 %description proxy -l pl.UTF-8
234 Ten pakiet zawiera proxy Zabbix.
235
236 %package proxy-mysql
237 Summary:        MySQL support for Zabbix proxy
238 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
239 Group:          Networking/Utilities
240 Provides:       %{name}-proxy(db) = %{version}-%{release}
241 Obsoletes:      zabbix-proxy-postgresql
242 Obsoletes:      zabbix-proxy-sqlite3
243
244 %description proxy-mysql
245 This package provides the Zabbix proxy binary with MySQL support.
246
247 %description proxy-mysql -l pl.UTF-8
248 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
249
250 %package proxy-postgresql
251 Summary:        PostgreSQL support for Zabbix proxy
252 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
253 Group:          Networking/Utilities
254 Provides:       %{name}-proxy(db) = %{version}-%{release}
255 Obsoletes:      zabbix-proxy-mysql
256 Obsoletes:      zabbix-proxy-sqlite3
257
258 %description proxy-postgresql
259 This package provides the Zabbix proxy binary with PostgreSQL support.
260
261 %description proxy-postgresql -l pl.UTF-8
262 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
263
264 %package proxy-sqlite3
265 Summary:        SQLite 3 support for Zabbix proxy
266 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
267 Group:          Networking/Utilities
268 Provides:       %{name}-proxy(db) = %{version}-%{release}
269 Obsoletes:      zabbix-proxy-mysql
270 Obsoletes:      zabbix-proxy-postgresql
271
272 %description proxy-sqlite3
273 This package provides the Zabbix proxy binary with SQLite 3 support.
274
275 %description proxy-sqlite3 -l pl.UTF-8
276 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
277
278 %package sender
279 Summary:        Zabbix sender
280 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
281 Group:          Networking/Utilities
282
283 %description sender
284 This package provides the Zabbix sender.
285
286 %description sender -l pl.UTF-8
287 Ten pakiet zawiera program zawiadamiający Zabbiksa.
288
289 %package server
290 Summary:        Zabbix server
291 Summary(pl.UTF-8):      Serwer Zabbiksa
292 Group:          Networking/Utilities
293 Requires:       %{name}-common = %{version}-%{release}
294 Requires:       %{name}-server(db) = %{version}-%{release}
295 Requires:       systemd-units >= 38
296 Obsoletes:      zabbix-suckerd
297 Obsoletes:      zabbix-trapper-inetd
298 Obsoletes:      zabbix-trapper-standalone
299
300 %description server
301 This package provides the Zabbix server.
302
303 %description server -l pl.UTF-8
304 Ten pakiet zawiera serwer Zabbiksa.
305
306 %package server-mysql
307 Summary:        MySQL support for Zabbix server
308 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
309 Group:          Networking/Utilities
310 Provides:       %{name}-server(db) = %{version}-%{release}
311 Obsoletes:      zabbix-server-postgresql
312 Obsoletes:      zabbix-server-sqlite3
313
314 %description server-mysql
315 This package provides the Zabbix server binary for use with MySQL
316 database.
317
318 %description server-mysql -l pl.UTF-8
319 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
320
321 %package server-postgresql
322 Summary:        PostgreSQL support for Zabbix server
323 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
324 Group:          Networking/Utilities
325 Provides:       %{name}-server(db) = %{version}-%{release}
326 Obsoletes:      zabbix-server-mysql
327 Obsoletes:      zabbix-server-sqlite3
328
329 %description server-postgresql
330 This package provides the Zabbix server binary for use with PostgreSQL
331 database.
332
333 %description server-postgresql -l pl.UTF-8
334 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
335
336 %package java
337 Summary:        Zabbix Java Gateway
338 Group:          Networking/Utilities
339 Requires:       %{name}-common = %{version}-%{release}
340 Requires:       systemd-units >= 38
341
342 %description java
343 This package provides the Zabbix Java Gateway.
344
345 %prep
346 %setup -q -a100
347 %patch0 -p1
348 %patch1 -p1
349 %patch2 -p1
350 %patch3 -p1
351 %patch4 -p1
352
353 %build
354 %{__libtoolize}
355 %{__aclocal} -I m4
356 %{__autoconf}
357 %{__autoheader}
358 %{__automake}
359
360 configure() {
361         %configure \
362         %{?with_java:ac_cv_prog_JAVAC=%{java_home}/bin/javac} \
363         %{?with_java:ac_cv_prog_JAR=%{java_home}/bin/jar} \
364         --enable-dependency-tracking \
365         --enable-agent \
366         %{__enable_disable agent2} \
367         --enable-ipv6 \
368         %{__enable_disable java} \
369         --with-ldap \
370         --with-libcurl \
371         --with-libevent \
372         --with-libpcre \
373         --with-libxml2 \
374         --with-net-snmp \
375         --with-openipmi \
376         --with-openssl \
377         --with-ssh2 \
378         --with-unixodbc \
379         "$@"
380 }
381
382 configure \
383         --disable-server \
384         --disable-proxy
385
386 %{__make}
387
388 for database in %{databases} ; do
389         if [ "$database" = "sqlite3" ] ; then
390                 enable_server=""
391         else
392                 enable_server="--enable-server"
393         fi
394         configure \
395                 --with-$database \
396                 $enable_server \
397                 --enable-proxy
398
399         %{__make}
400
401         if [ "$enable_server" ] ; then
402                 %{__make} install \
403                         -C src/zabbix_server \
404                         DESTDIR=$PWD/install-${database}
405         fi
406
407         %{__make} install \
408                 -C src/zabbix_proxy \
409                 DESTDIR=$PWD/install-${database}
410 done
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d \
415         $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_agent2.conf.d,/etc/webapps/%{_webapp}} \
416         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_appdir}/frontends/php} \
417         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
418
419 %{__make} install \
420         DESTDIR=$RPM_BUILD_ROOT \
421         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
422
423 for database in %{databases} ; do
424         if [ "$database" != "sqlite3" ] ; then
425                 cp -p install-$database/%{_sbindir}/zabbix_server \
426                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
427         fi
428         cp -p install-$database/%{_sbindir}/zabbix_proxy \
429                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
430 done
431
432 if [ -n "$database" ] ; then
433         ln -sf zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
434         ln -sf zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
435 fi
436
437 %if %{with sqlite3}
438 install -d $RPM_BUILD_ROOT/var/lib/zabbix
439 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
440 %endif
441
442 cp -r ui/* $RPM_BUILD_ROOT%{_appdir}/frontends/php
443
444 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
445 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
446
447 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
448 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
449 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
450 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
451 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
452 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
453
454 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
455
456 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
457 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/frontend,%{_appdir}/frontends/php/conf}
458 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
459
460 %if %{with java}
461 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
462 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_java.conf,%{_datadir}/zabbix_java/settings.sh}
463 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
464 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback.xml,%{_datadir}/zabbix_java/lib/logback.xml}
465 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
466 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback-console.xml,%{_datadir}/zabbix_java/lib/logback-console.xml}
467
468 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
469 #!/bin/sh
470
471 exec %{_datadir}/zabbix_java/startup.sh "$@"
472 EOF
473
474 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
475 #!/bin/sh
476
477 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
478 EOF
479 %endif
480
481 %clean
482 rm -rf $RPM_BUILD_ROOT
483
484 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
485 %webapp_register apache %{_webapp}
486
487 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
488 %webapp_unregister apache %{_webapp}
489
490 %triggerin frontend-php -- apache < 2.2.0, apache-base
491 %webapp_register httpd %{_webapp}
492
493 %triggerun frontend-php -- apache < 2.2.0, apache-base
494 %webapp_unregister httpd %{_webapp}
495
496 %pre common
497 %groupadd -g 111 zabbix
498 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
499 %addusertogroup -q zabbix proc
500
501 %postun common
502 if [ "$1" = "0" ]; then
503         %userremove zabbix
504         %groupremove zabbix
505 fi
506
507 %post server-mysql
508 if [ "$1" = 1 ]; then
509         %banner -e %{name}-server <<-EOF
510         You should create database for Zabbix.
511
512         Running these should be fine in most cases:
513         mysqladmin create zabbix
514         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
515         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
516         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
517 EOF
518 fi
519 ln -sf zabbix_server-mysql %{_sbindir}/zabbix_server || :
520
521 %post server-postgresql
522 if [ "$1" = 1 ]; then
523         %banner -e %{name}-server <<-EOF
524         You should create database for Zabbix.
525
526         Running these should be fine in most cases:
527
528         createuser zabbix
529         createdb -O zabbix zabbix
530         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
531         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
532         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
533 EOF
534 fi
535 ln -sf zabbix_server-postgresql %{_sbindir}/zabbix_server || :
536
537 %post server
538 %systemd_post zabbix_server.service
539
540 %preun server
541 %systemd_preun zabbix_server.service
542
543 %postun server
544 if [ "$1" = "0" ]; then
545         if [ -L %{_sbindir}/zabbix_server ] ; then
546                 rm -f %{_sbindir}/zabbix_server || :
547         fi
548 fi
549 %systemd_reload
550
551 %post agentd
552 /sbin/chkconfig --add zabbix_agentd
553 %service zabbix_agentd restart
554 %systemd_post zabbix_agentd.service
555
556 %preun agentd
557 if [ "$1" = "0" ]; then
558         %service -q zabbix_agentd stop
559         /sbin/chkconfig --del zabbix_agentd
560 fi
561 %systemd_preun zabbix_agentd.service
562
563 %postun agentd
564 %systemd_reload
565
566 %post agent2
567 /sbin/chkconfig --add zabbix_agent2
568 %service zabbix_agent2 restart
569
570 %preun agent2
571 if [ "$1" = "0" ]; then
572         %service -q zabbix_agent2 stop
573         /sbin/chkconfig --del zabbix_agent2
574 fi
575
576 %post proxy-mysql
577 ln -sf zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
578
579 %post proxy-postgresql
580 ln -sf zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
581
582 %post proxy-sqlite3
583 ln -sf zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
584
585 %post proxy
586 %systemd_post zabbix_proxy.service
587
588 %preun proxy
589 %systemd_preun zabbix_proxy.service
590
591 %postun proxy
592 %systemd_reload
593
594 %post java
595 %systemd_post zabbix_java.service
596
597 %preun java
598 %systemd_preun zabbix_java.service
599
600 %postun java
601 %systemd_reload
602
603 %files
604 %defattr(644,root,root,755)
605 %doc AUTHORS ChangeLog README
606
607 %files common
608 %defattr(644,root,root,755)
609 %doc AUTHORS ChangeLog README
610 %attr(751,root,zabbix) %dir %{_sysconfdir}
611 %attr(751,root,http) %dir %{_sysconfdir}/frontend
612 %dir %{_appdir}
613 %dir %{_appdir}/frontends
614 %dir %attr(770,root,zabbix) /var/run/zabbix
615 %dir %attr(775,root,zabbix) /var/log/zabbix
616 %{systemdtmpfilesdir}/zabbix.conf
617
618 %files agentd
619 %defattr(644,root,root,755)
620 %doc conf/zabbix_agentd/*.conf
621 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
622 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
623 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
624 %attr(755,root,root) %{_sbindir}/zabbix_agentd
625 %{_mandir}/man8/zabbix_agentd*
626 %{systemdunitdir}/zabbix_agentd.service
627
628 %if %{with agent2}
629 %files agent2
630 %defattr(644,root,root,755)
631 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
632 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.conf.d
633 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
634 %attr(755,root,root) %{_sbindir}/zabbix_agent2
635 %{_mandir}/man8/zabbix_agent2.8*
636 %endif
637
638 %files frontend-php
639 %defattr(644,root,root,755)
640 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
641 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
642 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
643 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
644 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
645 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
646 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
647 %{_appdir}/frontends/php
648
649 %files get
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_bindir}/zabbix_get
652 %{_mandir}/man1/zabbix_get*
653
654 %if %{any_database}
655 %files proxy
656 %defattr(644,root,root,755)
657 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
658 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
659 %ghost %{_sbindir}/zabbix_proxy
660 %{_mandir}/man8/zabbix_proxy*
661 %{systemdunitdir}/zabbix_proxy.service
662 %endif
663
664 %if %{with mysql}
665 %files proxy-mysql
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
668 %endif
669
670 %if %{with pgsql}
671 %files proxy-postgresql
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
674 %endif
675
676 %if %{with sqlite3}
677 %files proxy-sqlite3
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
680 %endif
681
682 %files sender
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_bindir}/zabbix_sender
685 %{_mandir}/man1/zabbix_sender*
686
687 %if %{any_database}
688 %files server
689 %defattr(644,root,root,755)
690 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
691 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
692 %ghost %{_sbindir}/zabbix_server
693 %{_mandir}/man8/zabbix_server*
694 %{systemdunitdir}/zabbix_server.service
695 %endif
696
697 %if %{with mysql}
698 %files server-mysql
699 %defattr(644,root,root,755)
700 %doc database/mysql/*.sql
701 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
702 %endif
703
704 %if %{with pgsql}
705 %files server-postgresql
706 %defattr(644,root,root,755)
707 %doc database/postgresql/*.sql
708 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
709 %endif
710
711 %if %{with java}
712 %files java
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_sbindir}/zabbix_java-start
715 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
716 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
717 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
718 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
719 %dir %{_datadir}/zabbix_java
720 %{_datadir}/zabbix_java/bin
721 %{_datadir}/zabbix_java/lib
722 %{_datadir}/zabbix_java/settings.sh
723 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
724 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
725 %{systemdunitdir}/zabbix_java.service
726 %endif
This page took 0.148032 seconds and 3 git commands to generate.