]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
5475a6213e9ef569ea807ac4643c33b4209556fb
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 # - unpackaged files:
4 #   /lib/systemd/system/zabbix_java.service
5 #   /usr/bin/zabbix_js
6 #   /var/lib/zabbix/zabbix.db
7 #
8 # Conditional build:
9 %bcond_without  pgsql   # enable PostgreSQL support
10 %bcond_without  sqlite3 # enable sqlite3 support
11 %bcond_without  mysql   # enable MySQL support
12 %bcond_without  java    # disable java support
13 %bcond_without  agent2  # disable bulding of Go based agent2
14
15 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
16 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
17
18 %ifnarch %{ix86} %{x8664}
19 %undefine       with_agent2
20 %endif
21
22 %define         php_min_version 7.2.5
23 Summary:        Zabbix - network monitoring software
24 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
25 Name:           zabbix
26 Version:        5.4.3
27 Release:        0.8
28 License:        GPL v2+
29 Group:          Networking/Utilities
30 # https://www.zabbix.com/download_sources
31 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/5.4/%{name}-%{version}.tar.gz
32 # Source0-md5:  5dccb536c164e45c7d5c1a5a9d64be43
33 Source100:      go-vendor.tar.xz
34 # Source100-md5:        61f2ee9647280765b622a5e1e8cdfbba
35 Source1:        %{name}-apache.conf
36 Source2:        %{name}_server.service
37 Source3:        %{name}_agentd.service
38 Source4:        %{name}_proxy.service
39 Source5:        %{name}_java.service
40 Source6:        %{name}.tmpfiles
41 Source7:        %{name}_agentd.init
42 Source8:        %{name}_agent2.init
43 %if 0
44 cd src/go/
45 go mod vendor
46 tar -caf ~/go-vendor.tar.xz -C ../../ src/go/vendor
47 %endif
48 Patch0:         config.patch
49 Patch1:         sqlite3_dbname.patch
50 Patch2:         always_compile_ipc.patch
51 Patch3:         go-destdir.patch
52 Patch4:         go-vendor.patch
53 URL:            https://www.zabbix.com/
54 BuildRequires:  OpenIPMI-devel
55 BuildRequires:  autoconf
56 BuildRequires:  automake >= 1:1.15
57 BuildRequires:  curl-devel
58 BuildRequires:  iksemel-devel
59 %{?with_java:BuildRequires:     jdk}
60 %{?with_java:BuildRequires:     rpm-pld-macros-javaprov}
61 %{?with_agent2:BuildRequires:   golang >= 1.13}
62 BuildRequires:  libevent-devel
63 BuildRequires:  libssh2-devel
64 BuildRequires:  libtool
65 BuildRequires:  libxml2-devel
66 %{?with_mysql:BuildRequires:    mysql-devel}
67 BuildRequires:  net-snmp-devel
68 BuildRequires:  openldap-devel >= 2.4.6
69 BuildRequires:  openssl-devel >= 0.9.7d
70 BuildRequires:  pcre-devel
71 %{?with_pgsql:BuildRequires:    postgresql-devel}
72 BuildRequires:  rpmbuild(macros) >= 1.671
73 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
74 BuildRequires:  unixODBC-devel
75 BuildRequires:  zlib-devel
76 Requires:       %{name}-agentd = %{version}-%{release}
77 Requires:       %{name}-frontend-php = %{version}-%{release}
78 Requires:       %{name}-server = %{version}-%{release}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _sysconfdir     /etc/%{name}
82 %define         _appdir         %{_datadir}/%{name}
83 %define         _webapps        /etc/webapps
84 %define         _webapp         %{name}
85
86 %description
87 Zabbix is software that monitors numerous parameters of a network and
88 the servers on that network. It is a useful tool for monitoring the
89 health and integrity of servers. Zabbix uses a flexible notification
90 mechanism that allows users to configure email based alerts for
91 virtually any event. All monitored parameters are stored in a
92 database. Zabbix offers excellent reporting and data visualisation
93 features based on the stored data. Zabbix supports both polling and
94 trapping. All Zabbix reports and statistics, as well as configuration
95 parameters, are accessed through a web-based front end.
96
97 %description -l pl.UTF-8
98 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
99 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
100 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
101 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
102 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
103 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
104 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
105 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
106 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
107
108 %package common
109 Summary:        Common files for Zabbix monitoring software
110 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
111 Group:          Networking/Utilities
112 Requires(postun):       /usr/sbin/groupdel
113 Requires(postun):       /usr/sbin/userdel
114 Requires(pre):  /bin/id
115 Requires(pre):  /usr/bin/getgid
116 Requires(pre):  /usr/sbin/groupadd
117 Requires(pre):  /usr/sbin/useradd
118 Provides:       group(zabbix)
119 Provides:       user(zabbix)
120
121 %description common
122 Common files for Zabbix monitoring software.
123
124 %description common -l pl.UTF-8
125 Wspólne pliki dla oprogramowania monitorującego Zabbix.
126
127 %package agentd
128 Summary:        Zabbix Agent
129 Summary(pl.UTF-8):      Agenta Zabbiksa
130 Group:          Networking/Utilities
131 Requires:       %{name}-common = %{version}-%{release}
132 Requires:       systemd-units >= 38
133 Obsoletes:      zabbix-agent-inetd
134 Obsoletes:      zabbix-agent-standalone
135 Requires(post,preun):   /sbin/chkconfig
136 Requires:       rc-scripts
137
138 %description agentd
139 Zabbix agent collects data from the local system for a Zabbix server.
140
141 %description agentd -l pl.UTF-8
142 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
143
144 %package agent2
145 Summary:        Zabbix Agent 2
146 Group:          Networking/Utilities
147 URL:            https://www.zabbix.com/documentation/current/manual/concepts/agent2
148 Requires:       %{name}-common = %{version}-%{release}
149 Requires(post,preun):   /sbin/chkconfig
150 Requires:       rc-scripts
151
152 %description agent2
153 Zabbix agent 2 is a new generation of Zabbix agent and may be used in
154 place of Zabbix agent.
155
156 Zabbix agent 2 has been developed to:
157 - reduce the number of TCP connections
158 - have greater check concurrency
159 - be easily extendible with plugins.
160
161 A plugin should be able to:
162 - provide trivial checks consisting of only a few simple lines of code
163 - provide complex checks consisting of long-running scripts and
164   standalone data gathering with periodic sending back of the data
165 - be a drop-in replacement for Zabbix agent (in that it supports all
166   the previous functionality)
167
168 Passive checks work similarly to Zabbix agent. Active checks support
169 scheduled/flexible intervals and check concurrency within one active
170 server.
171
172 %package frontend-php
173 Summary:        PHP frontend for Zabbix
174 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
175 Group:          Applications/WWW
176 Requires:       php(bcmath)
177 Requires:       php(core) >= %{php_min_version}
178 Requires:       php(ctype)
179 Requires:       php(gd)
180 Requires:       php(gettext)
181 Requires:       php(json)
182 Requires:       php(mbstring)
183 Requires:       php(pcre)
184 Requires:       php(session)
185 Requires:       php(sockets)
186 Requires:       php(xml)
187 Requires:       php(xmlreader)
188 Requires:       php(xmlwriter)
189 Requires:       webapps
190 Requires:       webserver(alias)
191 Requires:       webserver(indexfile)
192 Requires:       webserver(php)
193 Suggests:       php(mysql)
194 Suggests:       php(pgsql)
195 Suggests:       php(sqlite3)
196 # used with sqlite3
197 Suggests:       php(sysvsem)
198 BuildArch:      noarch
199
200 %description frontend-php
201 This package provides web based (PHP) frontend for Zabbix.
202
203 %description frontend-php -l pl.UTF-8
204 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
205
206 %package get
207 Summary:        Program retrieving data from Zabbix agent
208 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
209 Group:          Networking/Utilities
210
211 %description get
212 This package provides a program retrieving data from Zabbix agent.
213
214 %description get -l pl.UTF-8
215 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
216
217 %package proxy
218 Summary:        Zabbix proxy
219 Summary(pl.UTF-8):      Proxy do Zabbiksa
220 Group:          Networking/Utilities
221 Requires:       %{name}-common = %{version}-%{release}
222 Requires:       systemd-units >= 38
223 Requires:       zabbix-proxy(db) = %{version}-%{release}
224
225 %description proxy
226 This package provides the Zabbix proxy.
227
228 %description proxy -l pl.UTF-8
229 Ten pakiet zawiera proxy Zabbix.
230
231 %package proxy-mysql
232 Summary:        MySQL support for Zabbix proxy
233 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
234 Group:          Networking/Utilities
235 Provides:       %{name}-proxy(db) = %{version}-%{release}
236 Obsoletes:      zabbix-proxy-postgresql
237 Obsoletes:      zabbix-proxy-sqlite3
238
239 %description proxy-mysql
240 This package provides the Zabbix proxy binary with MySQL support.
241
242 %description proxy-mysql -l pl.UTF-8
243 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
244
245 %package proxy-postgresql
246 Summary:        PostgreSQL support for Zabbix proxy
247 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
248 Group:          Networking/Utilities
249 Provides:       %{name}-proxy(db) = %{version}-%{release}
250 Obsoletes:      zabbix-proxy-mysql
251 Obsoletes:      zabbix-proxy-sqlite3
252
253 %description proxy-postgresql
254 This package provides the Zabbix proxy binary with PostgreSQL support.
255
256 %description proxy-postgresql -l pl.UTF-8
257 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
258
259 %package proxy-sqlite3
260 Summary:        SQLite 3 support for Zabbix proxy
261 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
262 Group:          Networking/Utilities
263 Provides:       %{name}-proxy(db) = %{version}-%{release}
264 Obsoletes:      zabbix-proxy-mysql
265 Obsoletes:      zabbix-proxy-postgresql
266
267 %description proxy-sqlite3
268 This package provides the Zabbix proxy binary with SQLite 3 support.
269
270 %description proxy-sqlite3 -l pl.UTF-8
271 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
272
273 %package sender
274 Summary:        Zabbix sender
275 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
276 Group:          Networking/Utilities
277
278 %description sender
279 This package provides the Zabbix sender.
280
281 %description sender -l pl.UTF-8
282 Ten pakiet zawiera program zawiadamiający Zabbiksa.
283
284 %package server
285 Summary:        Zabbix server
286 Summary(pl.UTF-8):      Serwer Zabbiksa
287 Group:          Networking/Utilities
288 Requires:       %{name}-common = %{version}-%{release}
289 Requires:       %{name}-server(db) = %{version}-%{release}
290 Requires:       systemd-units >= 38
291 Obsoletes:      zabbix-suckerd
292 Obsoletes:      zabbix-trapper-inetd
293 Obsoletes:      zabbix-trapper-standalone
294
295 %description server
296 This package provides the Zabbix server.
297
298 %description server -l pl.UTF-8
299 Ten pakiet zawiera serwer Zabbiksa.
300
301 %package server-mysql
302 Summary:        MySQL support for Zabbix server
303 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
304 Group:          Networking/Utilities
305 Provides:       %{name}-server(db) = %{version}-%{release}
306 Obsoletes:      zabbix-server-postgresql
307 Obsoletes:      zabbix-server-sqlite3
308
309 %description server-mysql
310 This package provides the Zabbix server binary for use with MySQL
311 database.
312
313 %description server-mysql -l pl.UTF-8
314 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
315
316 %package server-postgresql
317 Summary:        PostgreSQL support for Zabbix server
318 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
319 Group:          Networking/Utilities
320 Provides:       %{name}-server(db) = %{version}-%{release}
321 Obsoletes:      zabbix-server-mysql
322 Obsoletes:      zabbix-server-sqlite3
323
324 %description server-postgresql
325 This package provides the Zabbix server binary for use with PostgreSQL
326 database.
327
328 %description server-postgresql -l pl.UTF-8
329 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
330
331 %package java
332 Summary:        Zabbix Java Gateway
333 Group:          Networking/Utilities
334 Requires:       %{name}-common = %{version}-%{release}
335 Requires:       systemd-units >= 38
336
337 %description java
338 This package provides the Zabbix Java Gateway.
339
340 %prep
341 %setup -q -a100
342 %patch0 -p1
343 %patch1 -p1
344 %patch2 -p1
345 %patch3 -p1
346 %patch4 -p1
347
348 %build
349 %{__libtoolize}
350 %{__aclocal} -I m4
351 %{__autoconf}
352 %{__autoheader}
353 %{__automake}
354
355 configure() {
356         %configure \
357         --enable-dependency-tracking \
358         --enable-agent \
359         %{__enable_disable agent2} \
360         --enable-ipv6 \
361         %{__enable_disable java} \
362         --with-ldap \
363         --with-libcurl \
364         --with-libevent \
365         --with-libpcre \
366         --with-libxml2 \
367         --with-net-snmp \
368         --with-openipmi \
369         --with-openssl \
370         --with-ssh2 \
371         --with-unixodbc \
372         "$@"
373 }
374
375 configure \
376         --disable-server \
377         --disable-proxy
378
379 %{__make}
380
381 for database in %{databases} ; do
382         if [ "$database" = "sqlite3" ] ; then
383                 enable_server=""
384         else
385                 enable_server="--enable-server"
386         fi
387         configure \
388                 --with-$database \
389                 $enable_server \
390                 --enable-proxy
391
392         %{__make}
393
394         if [ "$enable_server" ] ; then
395                 %{__make} install \
396                         -C src/zabbix_server \
397                         DESTDIR=$PWD/install-${database}
398         fi
399
400         %{__make} install \
401                 -C src/zabbix_proxy \
402                 DESTDIR=$PWD/install-${database}
403 done
404
405 %install
406 rm -rf $RPM_BUILD_ROOT
407 install -d \
408         $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_agent2.conf.d,/etc/webapps/%{_webapp}} \
409         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_appdir}/frontends/php} \
410         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
411
412 %{__make} install \
413         DESTDIR=$RPM_BUILD_ROOT \
414         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
415
416 for database in %{databases} ; do
417         if [ "$database" != "sqlite3" ] ; then
418                 cp -p install-$database/%{_sbindir}/zabbix_server \
419                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
420         fi
421         cp -p install-$database/%{_sbindir}/zabbix_proxy \
422                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
423 done
424
425 if [ -n "$database" ] ; then
426         ln -sf zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
427         ln -sf zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
428 fi
429
430 %if %{with sqlite3}
431 install -d $RPM_BUILD_ROOT/var/lib/zabbix
432 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
433 %endif
434
435 cp -r ui/* $RPM_BUILD_ROOT%{_appdir}/frontends/php
436
437 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
438 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
439
440 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
441 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
442 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
443 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
444 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
445 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
446
447 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
448
449 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
450 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/frontend,%{_appdir}/frontends/php/conf}
451 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
452
453 %if %{with java}
454 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
455 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_java.conf,%{_datadir}/zabbix_java/settings.sh}
456 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
457 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback.xml,%{_datadir}/zabbix_java/lib/logback.xml}
458 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
459 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback-console.xml,%{_datadir}/zabbix_java/lib/logback-console.xml}
460
461 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
462 #!/bin/sh
463
464 exec %{_datadir}/zabbix_java/startup.sh "$@"
465 EOF
466
467 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
468 #!/bin/sh
469
470 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
471 EOF
472 %endif
473
474 %clean
475 rm -rf $RPM_BUILD_ROOT
476
477 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
478 %webapp_register apache %{_webapp}
479
480 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
481 %webapp_unregister apache %{_webapp}
482
483 %triggerin frontend-php -- apache < 2.2.0, apache-base
484 %webapp_register httpd %{_webapp}
485
486 %triggerun frontend-php -- apache < 2.2.0, apache-base
487 %webapp_unregister httpd %{_webapp}
488
489 %pre common
490 %groupadd -g 111 zabbix
491 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
492 %addusertogroup -q zabbix proc
493
494 %postun common
495 if [ "$1" = "0" ]; then
496         %userremove zabbix
497         %groupremove zabbix
498 fi
499
500 %post server-mysql
501 if [ "$1" = 1 ]; then
502         %banner -e %{name}-server <<-EOF
503         You should create database for Zabbix.
504
505         Running these should be fine in most cases:
506         mysqladmin create zabbix
507         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
508         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
509         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
510 EOF
511 fi
512 ln -sf zabbix_server-mysql %{_sbindir}/zabbix_server || :
513
514 %post server-postgresql
515 if [ "$1" = 1 ]; then
516         %banner -e %{name}-server <<-EOF
517         You should create database for Zabbix.
518
519         Running these should be fine in most cases:
520
521         createuser zabbix
522         createdb -O zabbix zabbix
523         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
524         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
525         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
526 EOF
527 fi
528 ln -sf zabbix_server-postgresql %{_sbindir}/zabbix_server || :
529
530 %post server
531 %systemd_post zabbix_server.service
532
533 %preun server
534 %systemd_preun zabbix_server.service
535
536 %postun server
537 if [ "$1" = "0" ]; then
538         if [ -L %{_sbindir}/zabbix_server ] ; then
539                 rm -f %{_sbindir}/zabbix_server || :
540         fi
541 fi
542 %systemd_reload
543
544 %post agentd
545 /sbin/chkconfig --add zabbix_agentd
546 %service zabbix_agentd restart
547 %systemd_post zabbix_agentd.service
548
549 %preun agentd
550 if [ "$1" = "0" ]; then
551         %service -q zabbix_agentd stop
552         /sbin/chkconfig --del zabbix_agentd
553 fi
554 %systemd_preun zabbix_agentd.service
555
556 %postun agentd
557 %systemd_reload
558
559 %post agent2
560 /sbin/chkconfig --add zabbix_agent2
561 %service zabbix_agent2 restart
562
563 %preun agent2
564 if [ "$1" = "0" ]; then
565         %service -q zabbix_agent2 stop
566         /sbin/chkconfig --del zabbix_agent2
567 fi
568
569 %post proxy-mysql
570 ln -sf zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
571
572 %post proxy-postgresql
573 ln -sf zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
574
575 %post proxy-sqlite3
576 ln -sf zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
577
578 %post proxy
579 %systemd_post zabbix_proxy.service
580
581 %preun proxy
582 %systemd_preun zabbix_proxy.service
583
584 %postun proxy
585 %systemd_reload
586
587 %post java
588 %systemd_post zabbix_java.service
589
590 %preun java
591 %systemd_preun zabbix_java.service
592
593 %postun java
594 %systemd_reload
595
596 %files
597 %defattr(644,root,root,755)
598 %doc AUTHORS ChangeLog README
599
600 %files common
601 %defattr(644,root,root,755)
602 %doc AUTHORS ChangeLog README
603 %attr(751,root,zabbix) %dir %{_sysconfdir}
604 %attr(751,root,http) %dir %{_sysconfdir}/frontend
605 %dir %{_appdir}
606 %dir %{_appdir}/frontends
607 %dir %attr(770,root,zabbix) /var/run/zabbix
608 %dir %attr(775,root,zabbix) /var/log/zabbix
609 %{systemdtmpfilesdir}/zabbix.conf
610
611 %files agentd
612 %defattr(644,root,root,755)
613 %doc conf/zabbix_agentd/*.conf
614 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
615 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
616 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
617 %attr(755,root,root) %{_sbindir}/zabbix_agentd
618 %{_mandir}/man8/zabbix_agentd*
619 %{systemdunitdir}/zabbix_agentd.service
620
621 %if %{with agent2}
622 %files agent2
623 %defattr(644,root,root,755)
624 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
625 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.conf.d
626 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
627 %attr(755,root,root) %{_sbindir}/zabbix_agent2
628 %{_mandir}/man8/zabbix_agent2.8*
629 %endif
630
631 %files frontend-php
632 %defattr(644,root,root,755)
633 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
634 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
635 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
636 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
637 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
638 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
639 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
640 %{_appdir}/frontends/php
641
642 %files get
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_bindir}/zabbix_get
645 %{_mandir}/man1/zabbix_get*
646
647 %if %{any_database}
648 %files proxy
649 %defattr(644,root,root,755)
650 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
651 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
652 %ghost %{_sbindir}/zabbix_proxy
653 %{_mandir}/man8/zabbix_proxy*
654 %{systemdunitdir}/zabbix_proxy.service
655 %endif
656
657 %if %{with mysql}
658 %files proxy-mysql
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
661 %endif
662
663 %if %{with pgsql}
664 %files proxy-postgresql
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
667 %endif
668
669 %if %{with sqlite3}
670 %files proxy-sqlite3
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
673 %endif
674
675 %files sender
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_bindir}/zabbix_sender
678 %{_mandir}/man1/zabbix_sender*
679
680 %if %{any_database}
681 %files server
682 %defattr(644,root,root,755)
683 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
684 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
685 %ghost %{_sbindir}/zabbix_server
686 %{_mandir}/man8/zabbix_server*
687 %{systemdunitdir}/zabbix_server.service
688 %endif
689
690 %if %{with mysql}
691 %files server-mysql
692 %defattr(644,root,root,755)
693 %doc database/mysql/*.sql
694 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
695 %endif
696
697 %if %{with pgsql}
698 %files server-postgresql
699 %defattr(644,root,root,755)
700 %doc database/postgresql/*.sql
701 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
702 %endif
703
704 %if %{with java}
705 %files java
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_sbindir}/zabbix_java-start
708 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
709 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
710 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
711 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
712 %dir %{_datadir}/zabbix_java
713 %{_datadir}/zabbix_java/bin
714 %{_datadir}/zabbix_java/lib
715 %{_datadir}/zabbix_java/settings.sh
716 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
717 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
718 %{systemdunitdir}/zabbix_java.service
719 %endif
This page took 0.088506 seconds and 2 git commands to generate.