]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
4e7f022e8c880a7d4f25873878c5c5d754cb6e4d
[packages/zabbix.git] / zabbix.spec
1 #
2 # Conditional build:
3 %bcond_with pgsql       # enable postgresql support (by default use mysql)
4
5 %define _beta   beta10
6 Summary:        zabbix - network monitoring software
7 Summary(pl):    zabbix - oprogramowanie do monitorowania sieci
8 Name:           zabbix
9 Version:        1.0
10 Release:        0.%{_beta}.0.1
11 License:        GPL v2+
12 Group:          Networking/Admin
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
14 # Source0-md5:  6d1fd1c4e8166ceffa730060583d4014
15 Source1:        %{name}-agent.inetd
16 Source2:        %{name}-trapper.inetd
17 URL:            http://zabbix.sourceforge.net/
18 %{!?with_pgsql:BuildRequires:   mysql-devel}
19 %{?with_pgsql:BuildRequires:    postgresql-devel}
20 BuildRequires:  net-snmp-devel
21 BuildRequires:  openssl-devel >= 0.9.7c
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define _sysconfdir     /etc/%{name}
25
26 %description
27 zabbix is software that monitors numerous parameters of a network and
28 the servers on that network. zabbix is a useful tool for monitoring
29 the health and integrity of servers. zabbix uses a flexible
30 notification mechanism that allows users to configure email based
31 alerts for virtually any event. All monitored parameters are stored in
32 a database. zabbix offers excellent reporting and data visualisation
33 features based on the stored data. zabbix supports both polling and
34 trapping. All zabbix reports and statistics, as well as configuration
35 parameters, are accessed through a web-based front end.
36
37 %description -l pl
38 zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
39 serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
40 dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
41 powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
42 poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
43 parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
44 przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
45 zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
46 wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
47 interfejs oparty o WWW.
48
49 %package frontend-php
50 Summary:        PHP frontend for zabbix
51 Summary(pl):    Interfejs PHP dla zabbiksa
52 Group:          Networking/Admin
53 Requires:       apache
54 Requires:       php
55
56 %description frontend-php
57 This package provides web based (PHP) frontend for zabbix.
58
59 %description frontend-php -l pl
60 Ten pakiet dostarcza napisany w PHP frontend dla zabbiksa.
61
62 %package agent-inetd
63 Summary:        inetd agent for zabbix
64 Summary(pl):    Wersja inetd agenta zabbiksa
65 Group:          Networking/Admin
66 Requires:       %{name}
67 Requires:       inetdaemon
68 Obsoletes:      %{name}-agent-standalone
69
70 %description agent-inetd
71 This package provides inetd version of zabbix agent.
72
73 %description agent-inetd -l pl
74 Ten pakiet dostarcza agenta zabbiksa dla inetd.
75
76 %package agent-standalone
77 Summary:        Standalone agent for zabbix
78 Summary(pl):    Wersja wolnostoj±ca agenta zabbiksa
79 Group:          Networking/Admin
80 Requires:       %{name}
81 Obsoletes:      %{name}-agent-inetd
82
83 %description agent-standalone
84 This package provides standalone version of zabbix agent.
85
86 %description agent-standalone -l pl
87 Ten pakiet dostarcza wolnostoj±cej wersji agenta zabbiksa.
88
89 %package suckerd
90 Summary:        sucker daemon for zabbix
91 Group:          Networking/Admin
92 Requires:       %{name}
93 %{!?with_pgsql:Requires:        mysql}
94 %{?with_pgsql:Requires: postgresql}
95
96 %description suckerd
97 This package provides the sucker daemon for zabbix.
98
99 %package trapper-inetd
100 Summary:        inetd trapper for zabbix
101 Summary(pl):    Wersja inetd programu pu³apkuj±cego zabbiksa
102 Group:          Networking/Admin
103 Requires:       %{name}
104 Requires:       inetdaemon
105 Obsoletes:      %{name}-trapper-standalone
106
107 %description trapper-inetd
108 This package provides inetd version of zabbix trapper.
109
110 %package trapper-standalone
111 Summary:        Standalone trapper for zabbix
112 Summary(pl):    Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
113 Group:          Networking/Admin
114 Requires:       %{name}
115 Obsoletes:      %{name}-trapper-inetd
116
117 %description trapper-standalone
118 This package provides standalone version of zabbix trapper.
119
120 %package sender
121 Summary:        zabbix's sender
122 Summary(pl):    Program zawiadamiaj±cy zabbiksa
123 Group:          Networking/Admin
124
125 %description sender
126 This package provides the zabbix sender.
127
128 %prep
129 %setup -q -n %{name}-%{version}%{_beta}
130
131 %build
132 rm -f missing
133 %{__aclocal}
134 %{__autoconf}
135 %configure \
136         %{!?with_pgsql:--with-mysql} \
137         %{?with_pgsql:--with-pgsql} \
138         --with-net-snmp
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd,%{_sbindir},/home/services/html/zabbix}
145
146 install bin/zabbix_* $RPM_BUILD_ROOT%{_sbindir}
147 install misc/conf/* $RPM_BUILD_ROOT%{_sysconfdir}
148 cp -r frontends/php/* $RPM_BUILD_ROOT/home/services/html/zabbix
149
150 install %SOURCE1 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-agent
151 install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-trapper
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %pre
157 if [ -z "`/usr/bin/getgid zabbix`" ]; then
158         /usr/sbin/groupadd zabbix
159 fi
160 if [ -z "`/bin/id -u zabbix 2>/dev/null`" ]; then
161         /usr/sbin/useradd -d / -g zabbix -c "Zabbix User" -s /bin/false zabbix
162 fi
163
164 %postun
165 if [ "$1" = "0" ]; then
166         /usr/sbin/userdel zabbix
167         /usr/sbin/groupdel zabbix
168 fi
169
170 %post agent-inetd
171 if [ -f /var/lock/subsys/rc-inetd ]; then
172         /etc/rc.d/init.d/rc-inetd reload
173 else
174         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
175 fi
176
177 %postun agent-inetd
178 if [ -f /var/lock/subsys/rc-inetd ]; then
179         /etc/rc.d/init.d/rc-inetd reload
180 fi
181
182 %post trapper-inetd
183 if [ -f /var/lock/subsys/rc-inetd ]; then
184         /etc/rc.d/init.d/rc-inetd reload
185 else
186         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
187 fi
188
189 %postun trapper-inetd
190 if [ -f /var/lock/subsys/rc-inetd ]; then
191         /etc/rc.d/init.d/rc-inetd reload
192 fi
193
194 %files
195 %defattr(644,root,root,755)
196 %doc doc/manual.pdf AUTHORS ChangeLog FAQ TODO create bin/ZabbixW32.exe
197 %attr(750,root,zabbix) %dir %{_sysconfdir}
198
199 %files frontend-php
200 %defattr(644,root,root,755)
201 /home/services/html/zabbix
202
203 %files agent-inetd
204 %defattr(644,root,root,755)
205 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent.conf
206 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-agent
207 %attr(755,root,root) %{_sbindir}/zabbix_agent
208
209 %files agent-standalone
210 %defattr(644,root,root,755)
211 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
212 %attr(755,root,root) %{_sbindir}/zabbix_agentd
213
214 %files suckerd
215 %defattr(644,root,root,755)
216 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_suckerd.conf
217 %attr(755,root,root) %{_sbindir}/zabbix_suckerd
218
219 %files trapper-inetd
220 %defattr(644,root,root,755)
221 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapper.conf
222 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-trapper
223 %attr(755,root,root) %{_sbindir}/zabbix_trapper
224
225 %files trapper-standalone
226 %defattr(644,root,root,755)
227 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapperd.conf
228 %attr(755,root,root) %{_sbindir}/zabbix_trapperd
229
230 %files sender
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_sbindir}/zabbix_sender
This page took 0.067229 seconds and 2 git commands to generate.