]> git.pld-linux.org Git - packages/yumex.git/blob - yumex.spec
- updated gettext BR
[packages/yumex.git] / yumex.spec
1 Summary:        YumExtender - a graphical frontend to yum
2 Summary(pl.UTF-8):      YumExtender - graficzny interfejs dla yuma
3 Name:           yumex
4 Version:        2.0.5
5 Release:        3
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://www.yum-extender.org/dnl/yumex/source/%{name}-%{version}.tar.gz
9 # Source0-md5:  57686187efb6abe645b416f4b63d9c37
10 Source1:        %{name}-gtk.desktop
11 Source2:        %{name}-kde.desktop
12 Patch0:         %{name}-yum-config.patch
13 Patch1:         %{name}-missingok.patch
14 Patch2:         %{name}-obsoletes.patch
15 URL:            http://www.yum-extender.org/
16 BuildRequires:  gettext-tools
17 BuildRequires:  intltool
18 BuildRequires:  python
19 BuildRequires:  python-modules
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.234
22 Requires:       python-pygtk-glade
23 Requires:       yum
24 Suggests:       gksu
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 YumExtender - a graphical frontend to yum.
30
31 %description -l pl.UTF-8
32 YumExtender - graficzny interfejs dla yuma.
33
34 %prep
35 %setup -q
36 %patch0 -p1
37 %patch1 -p1
38 %patch2 -p1
39
40 cat << 'EOF' > misc/yumex
41 #!/bin/sh
42 #
43 # Run yumex main python program.
44 #
45 exec %{__python} %{_datadir}/yumex/yumex.pyc ${1:+"$@"}
46 EOF
47
48 %build
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT \
56         PYLIBDIR=%{py_sitescriptdir}/..
57
58 mv -f $RPM_BUILD_ROOT{%{_datadir}/yumex,%{_bindir}}/yumex
59 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/yumex.desktop
60 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/yumex-kde.desktop
61
62 rm -f $RPM_BUILD_ROOT%{_datadir}/yumex/COPYING
63 %py_postclean %{_datadir}/yumex
64
65 %find_lang %{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files -f %{name}.lang
71 %defattr(644,root,root,755)
72 %doc COPYING ChangeLog
73 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yumex.conf
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yumex.profiles.conf
75 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/yumex
76 %config(noreplace) %verify(not md5 mtime size) /etc/security/console.apps/yumex
77 %attr(755,root,root) %{_bindir}/yumex
78 %dir %{py_sitescriptdir}/yumgui
79 %{py_sitescriptdir}/*/*.py[co]
80 %{_desktopdir}/*.desktop
81 %dir %{_datadir}/yumex
82 %{_datadir}/yumex/*.py[co]
83 %{_datadir}/yumex/*.glade
84 %{_pixmapsdir}/yumex
This page took 0.054732 seconds and 3 git commands to generate.