]> git.pld-linux.org Git - packages/yubikey-manager.git/blob - yubikey-manager.spec
f59570b22ef30676fe0d810a1594816b278a2d9e
[packages/yubikey-manager.git] / yubikey-manager.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # unit tests (broken as of 0.7.0)
4
5 Summary:        Tool for managing your YubiKey configuration
6 Summary(pl.UTF-8):      Narzędzie do zarządzania urządzeniami YubiKey
7 Name:           yubikey-manager
8 Version:        1.0.1
9 Release:        1
10 License:        BSD
11 Group:          Applications/System
12 Source0:        https://developers.yubico.com/yubikey-manager/Releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  ba04a0e70099de3c098156d0761f79c2
14 URL:            https://developers.yubico.com/yubikey-manager/
15 BuildRequires:  python-modules
16 BuildRequires:  python-setuptools
17 %if %{with tests}
18 BuildRequires:  python-fido2
19 BuildRequires:  python-mock
20 BuildRequires:  python-pyscard
21 BuildRequires:  python-pyusb
22 %endif
23 Requires:       python-click
24 Requires:       python-cryptography
25 Requires:       python-enum34
26 Requires:       python-fido2
27 Requires:       python-pyOpenSSL
28 Requires:       python-pyscard
29 Requires:       python-pyusb
30 Requires:       python-six
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Python library and command line tool for configuring a YubiKey.
36
37 %description
38 Pythonowa biblioteka i narzędzie linii poleceń do konfiguracji
39 urządzeń YubiKey.
40
41 %prep
42 %setup -q
43
44 # integration tests, require device
45 %{__rm} -r test/on_yubikey
46
47 %build
48 %py_build
49
50 %if %{with tests}
51 %{__python} -m unittest discover -s test
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %py_install
58
59 %py_postclean
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc COPYING NEWS README.adoc
67 %attr(755,root,root) %{_bindir}/ykman
68 %{py_sitescriptdir}/ykman
69 %{py_sitescriptdir}/yubikey_manager-%{version}-py*.egg-info
This page took 0.073283 seconds and 2 git commands to generate.