]> git.pld-linux.org Git - packages/ympd.git/blob - ympd.spec
required cmake version
[packages/ympd.git] / ympd.spec
1 Summary:        Standalone MPD Web GUI written in C
2 Name:           ympd
3 Version:        1.3.0
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications
7 Source0:        https://github.com/notandy/ympd/archive/v%{version}/%{name}-%{version}.zip
8 # Source0-md5:  89d339ee9b243bc02aef38baa8f5a823
9 Source1:        %{name}.service
10 Source2:        %{name}.sysconfig
11 Patch0:         %{name}-link.patch
12 URL:            http://www.ympd.org
13 BuildRequires:  cmake >= 2.6
14 BuildRequires:  libmpdclient-devel
15 BuildRequires:  openssl-devel
16 BuildRequires:  rpmbuild(macros) >= 2.011
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Standalone MPD Web GUI written in C, utilizing Websockets and
21 Bootstrap/JS.
22
23 %prep
24 %setup -q
25 %patch0 -p1
26
27 %build
28 install -d build
29 cd build
30 %cmake ..
31
32 %{__make}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 %{__make} -C build install \
38         DESTDIR=$RPM_BUILD_ROOT
39
40 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
41 install -D %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 %systemd_post %{name}.service
48
49 %preun
50 %systemd_preun %{name}.service
51
52 %postun
53 %systemd_reload
54
55 %files
56 %defattr(644,root,root,755)
57 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
58 %attr(755,root,root) %{_bindir}/ympd
59 %{systemdunitdir}/%{name}.service
60 %{_mandir}/man1/ympd.1*
This page took 0.083234 seconds and 3 git commands to generate.