]> git.pld-linux.org Git - packages/yarn.git/blob - yarn.spec
d9ce3e6d27f14da676f1ab4d73a2603e2d42a973
[packages/yarn.git] / yarn.spec
1 Summary:        Fast, reliable, and secure node dependency management"
2 Name:           yarn
3 Version:        0.23.2
4 Release:        1
5 License:        BSD
6 Group:          Development/Tools
7 Source0:        https://github.com/yarnpkg/yarn/releases/download/v%{version}/%{name}-v%{version}.tar.gz
8 # Source0-md5:  8c40f98256c9f14234e6afb04af910b0
9 URL:            https://yarnpkg.com/
10 BuildRequires:  rpmbuild(macros) >= 1.634
11 BuildRequires:  sed >= 4.0
12 Requires:       nodejs >= 4.0
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Fast, reliable, and secure dependency management. Yarn: Fast,
18 reliable, and secure dependency management.
19
20 Fast: Yarn caches every package it downloads so it never needs to
21 again. It also parallelizes operations to maximize resource
22 utilization so install times are faster than ever.
23
24 Reliable: Using a detailed, but concise, lockfile format, and a
25 deterministic algorithm for installs, Yarn is able to guarantee that
26 an install that worked on one system will work exactly the same way on
27 any other system.
28
29 Secure: Yarn uses checksums to verify the integrity of every installed
30 package before its code is executed.
31
32 %prep
33 %setup -qc
34 mv dist/* .
35
36 %{__rm} bin/node-gyp-bin/*.cmd
37 %{__rm} bin/*.cmd
38 %{__rm} bin/yarn
39 %{__rm} bin/yarnpkg
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{nodejs_libdir}/%{name},%{_bindir}}
44
45 cp -a lib lib-legacy bin node_modules package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{name}
46 ln -s %{nodejs_libdir}/%{name}/bin/%{name}.js $RPM_BUILD_ROOT%{_bindir}/%{name}
47 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/yarnpkg
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README.md LICENSE
55 %attr(755,root,root) %{_bindir}/yarn
56 %attr(755,root,root) %{_bindir}/yarnpkg
57 %defattr(-,root,root,-)
58 %{nodejs_libdir}/%{name}
This page took 0.048246 seconds and 3 git commands to generate.