]> git.pld-linux.org Git - packages/xpm.git/blob - xpm.spec
add templates dir
[packages/xpm.git] / xpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Cross package maker. DEB/RPM generation or conversion
6 Name:           xpm
7 Version:        1.3.3.6
8 Release:        0.2
9 License:        MIT-like
10 Group:          Development/Languages
11 Source0:        http://fossil.include-once.org/xpm/tarball/%{name}-%{version}.tar.gz?uuid=v%{version}&/%{name}-%{version}.tar.gz
12 # Source0-md5:  f73ececfa6725965fc41d4e11ea85992
13 Patch0: templates.patch
14 URL:            http://fossil.include-once.org/xpm/
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-insist < 0.1
20 BuildRequires:  ruby-insist >= 0.0.5
21 BuildRequires:  ruby-pry
22 BuildRequires:  ruby-rspec < 3.1
23 BuildRequires:  ruby-rspec >= 3.0.0
24 BuildRequires:  ruby-stud
25 %endif
26 Requires:       ruby-arr-pm < 0.1
27 Requires:       ruby-arr-pm >= 0.0.9
28 Requires:       ruby-backports >= 2.6.2
29 Requires:       ruby-cabin >= 0.6.0
30 Requires:       ruby-childprocess
31 Requires:       ruby-clamp < 1
32 Requires:       ruby-clamp >= 0.6
33 Requires:       ruby-ffi
34 Requires:       ruby-json >= 1.7.7
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 fpm greatly simplifies distribution package generation. xpm is a
40 feature-oriented branch of fpm.
41
42 It creates or converts between:
43 - Debian deb
44 - RedHat rpm
45 - Node npm
46 - OSX pkg
47 - Ruby gem
48 - Solaris packages, plain zip or tar archives, and a few more...
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
54
55 # cleanup backups after patching
56 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
61 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
62 cp -a templates $RPM_BUILD_ROOT%{ruby_vendorlibdir}/fpm
63 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README.md CHANGELIST CODE_OF_CONDUCT.md CONTRIBUTORS NOTES.md LICENSE
71 %attr(755,root,root) %{_bindir}/xpm
72 %{ruby_vendorlibdir}/fpm.rb
73 %{ruby_vendorlibdir}/fpm
This page took 0.064336 seconds and 3 git commands to generate.