]> git.pld-linux.org Git - packages/xpm.git/blob - xpm.spec
a546d661ba8cde57576662f6f04fb0b2aced39b4
[packages/xpm.git] / xpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Cross package maker. DEB/RPM generation or conversion
6 Name:           xpm
7 Version:        1.3.3.6
8 Release:        0.1
9 License:        MIT-like
10 Group:          Development/Languages
11 Source0:        http://fossil.include-once.org/xpm/tarball/%{name}-%{version}.tar.gz?uuid=v%{version}&/%{name}-%{version}.tar.gz
12 # Source0-md5:  f73ececfa6725965fc41d4e11ea85992
13 URL:            http://fossil.include-once.org/xpm/
14 BuildRequires:  rpm-rubyprov
15 BuildRequires:  rpmbuild(macros) >= 1.656
16 BuildRequires:  sed >= 4.0
17 %if %{with tests}
18 BuildRequires:  ruby-insist < 0.1
19 BuildRequires:  ruby-insist >= 0.0.5
20 BuildRequires:  ruby-pry
21 BuildRequires:  ruby-rspec < 3.1
22 BuildRequires:  ruby-rspec >= 3.0.0
23 BuildRequires:  ruby-stud
24 %endif
25 Requires:       ruby-arr-pm < 0.1
26 Requires:       ruby-arr-pm >= 0.0.9
27 Requires:       ruby-backports >= 2.6.2
28 Requires:       ruby-cabin >= 0.6.0
29 Requires:       ruby-childprocess
30 Requires:       ruby-clamp < 1
31 Requires:       ruby-clamp >= 0.6
32 Requires:       ruby-ffi
33 Requires:       ruby-json >= 1.7.7
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 fpm greatly simplifies distribution package generation. xpm is a
39 feature-oriented branch of fpm.
40
41 It creates or converts between:
42 - Debian deb
43 - RedHat rpm
44 - Node npm
45 - OSX pkg
46 - Ruby gem
47 - Solaris packages, plain zip or tar archives, and a few more...
48
49 %prep
50 %setup -q
51 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
56 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
57 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README.md CHANGELIST CODE_OF_CONDUCT.md CONTRIBUTORS NOTES.md LICENSE
65 %attr(755,root,root) %{_bindir}/xpm
66 %{ruby_vendorlibdir}/fpm.rb
67 %{ruby_vendorlibdir}/fpm
This page took 0.045468 seconds and 2 git commands to generate.