]> git.pld-linux.org Git - packages/xpdf.git/blob - xpdf.spec
- release 3 (by relup.sh)
[packages/xpdf.git] / xpdf.spec
1 #
2 # TODO:
3 #       - separate subpackage with /etc/xpdfrc file; pdftotext
4 #         from xpdf-tools or poppler-progs can use language
5 #         support files but don't require entire xpdf
6 #
7 # Conditional build:
8 %bcond_with     protections     # protections against fair use (printing and copying)
9 %bcond_without  x               # X-based browser
10
11 Summary:        Portable Document Format (PDF) file viewer
12 Summary(es.UTF-8):      Visualizador de archivos PDF
13 Summary(ja.UTF-8):      X Window System での PDF ファイルヴューア
14 Summary(pl.UTF-8):      Przeglądarka plików w formacie PDF
15 Summary(pt_BR.UTF-8):   Visualizador de arquivos PDF
16 Summary(ru.UTF-8):      Программа для просмотра PDF файлов
17 Summary(uk.UTF-8):      Програма для перегляду PDF файлів
18 Name:           xpdf
19 Version:        4.00
20 Release:        3
21 License:        GPL v2 or GPL v3
22 Group:          Applications/Publishing
23 Source0:        http://www.xpdfreader.com/dl/%{name}-%{version}.tar.gz
24 # Source0-md5:  80c8ce77acf1d36de93cecb82bd64a0f
25 Source1:        %{name}.desktop
26 Source2:        %{name}.png
27 Source3:        %{name}rc
28 Patch0:         %{name}-remove_protections.patch
29 Patch1:         %{name}-fontdirs.patch
30 URL:            http://www.xpdfreader.com/
31 BuildRequires:  cmake >= 2.8.8
32 BuildRequires:  freetype-devel >= 2.1.0
33 BuildRequires:  libpaper-devel
34 BuildRequires:  libpng-devel
35 BuildRequires:  libstdc++-devel
36 %{?with_x:BuildRequires:        QtCore-devel}
37 %{?with_x:BuildRequires:        QtGui-devel}
38 %{?with_x:BuildRequires:        qt4-qmake}
39 BuildRequires:  rpmbuild(macros) >= 1.596
40 Requires:       desktop-file-utils
41 Suggests:       ghostscript-fonts-std
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         specflags_ia32   -fomit-frame-pointer
45
46 %description
47 Xpdf is an X Window System based viewer for Portable Document Format
48 (PDF) files. PDF files are sometimes called Acrobat files, after Adobe
49 Acrobat (Adobe's PDF viewer). Xpdf is a small and efficient program
50 which uses standard X fonts.
51 %{!?with_protections:This version ignores protections for both: printing and copying.}
52
53 %description -l es.UTF-8
54 Xpdf es un visor de archivos PDF (Portable Document Format). (Estos
55 son algunas veces llamados de archivos 'Acrobat', nombre del software
56 PDF del Adobe. Xpdf fue proyectado para ser pequeño y eficiente. Usa
57 fuentes padrón X.
58
59 %description -l ja.UTF-8
60 xpdf は Portable Document Format (PDF) ファイルの X Window System
61 上での ヴューアです。PDF ファイルは Adobe Acrobat (Adobe の PDF
62 ヴューア) にちなんで、 時々 Acrobat ファイルと呼ばれます。xpdf
63 は小さく、標準的な X のフォントを 使う効果的なプログラムです。 PDF
64 ファイルのヴューアが必要ならば、xpdf
65 パッケージをインストールしましょう。
66
67 %description -l pl.UTF-8
68 Xpdf jest przeglądarką plików zapisanych w formacie PDF (Portable
69 Document Format). Xpdf jest zaprojektowany tak, by być małym i
70 wydajnym programem. Używa fontów z zasobów X Window.
71 %{!?with_protections:Ta wersja ignoruje blokady zarówno drukowania jak i kopiowania.}
72
73 %description -l pt_BR.UTF-8
74 Xpdf é um visualizador de arquivos PDF (Portable Document Format).
75 (Estes são algumas vezes chamados de arquivos 'Acrobat', nome do
76 software PDF da Adobe. Xpdf foi projetado para ser pequeno e
77 eficiente. Ele usa fontes padrão X.
78
79 %description -l ru.UTF-8
80 Xpdf - это программа для просмотра файлов в формате Portable Document
81 Format (PDF). Она быстрая и эффективная и использует стандартные
82 шрифты X Window.
83
84 %description -l uk.UTF-8
85 Xpdf - це програма для перегляду файлів в форматі Portable Document
86 Format (PDF). Вона швидка й ефективна та використовує стандартні
87 шрифти X Window.
88
89 %package tools
90 Summary:        Set of tools for viewing information and converting PDF files
91 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
92 Group:          Applications/Publishing
93 Provides:       pdftops
94 Obsoletes:      pdftohtml-pdftops
95
96 %description tools
97 Set of utilities for displaying information about PDF-files (pdfinfo,
98 pdffonts, pdfimages) and converting them (pdftopbm, pdftops,
99 pdftotext).
100
101 %description tools -l pl.UTF-8
102 Zestaw programów do wyświetlania informacji o plikach PDF (pdfinfo,
103 pdffonts, pdfimages) i konwertowania ich do innych formatów (pdftopbm,
104 pdftops, pdftotext).
105
106 %prep
107 %setup -q
108 %{!?with_protections:%patch0 -p1}
109 %patch1 -p1
110 sed -e 's|DESTINATION man/|DESTINATION share/man/|g' -i xpdf{,-qt}/CMakeLists.txt
111
112 %build
113 %cmake . \
114         -DA4_PAPER=ON \
115         -DSPLASH_CMYK=ON \
116         -DOPI_SUPPORT=ON \
117         -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets=1 \
118         -DCMAKE_CXX_FLAGS="%{rpmcxxflags}" \
119         -DCMAKE_EXE_LINKER_FLAGS="-lpaper %{rpmldflags}"
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_desktopdir},%{_pixmapsdir},%{_datadir}/xpdf}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
131 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
132 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 %update_desktop_database
139
140 %postun
141 %update_desktop_database
142
143 %if %{with x}
144 %files
145 %defattr(644,root,root,755)
146 %doc ANNOUNCE CHANGES README
147 %attr(755,root,root) %{_bindir}/xpdf
148 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/xpdfrc
149 %{_datadir}/xpdf
150 %{_mandir}/man1/xpdf.1*
151 %{_mandir}/man5/xpdfrc.5*
152 %{_desktopdir}/xpdf.desktop
153 %{_pixmapsdir}/xpdf.png
154 %endif
155
156 %files tools
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/pdfdetach
159 %attr(755,root,root) %{_bindir}/pdffonts
160 %attr(755,root,root) %{_bindir}/pdfimages
161 %attr(755,root,root) %{_bindir}/pdfinfo
162 %attr(755,root,root) %{_bindir}/pdftohtml
163 %attr(755,root,root) %{_bindir}/pdftopng
164 %attr(755,root,root) %{_bindir}/pdftoppm
165 %attr(755,root,root) %{_bindir}/pdftops
166 %attr(755,root,root) %{_bindir}/pdftotext
167 %{_mandir}/man1/pdfdetach.1*
168 %{_mandir}/man1/pdffonts.1*
169 %{_mandir}/man1/pdfimages.1*
170 %{_mandir}/man1/pdfinfo.1*
171 %{_mandir}/man1/pdftohtml.1*
172 %{_mandir}/man1/pdftopng.1*
173 %{_mandir}/man1/pdftoppm.1*
174 %{_mandir}/man1/pdftops.1*
175 %{_mandir}/man1/pdftotext.1*
This page took 0.081546 seconds and 3 git commands to generate.