]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- BR: fop
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_without  record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       4.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        8.0
16 %define xorg_xserver_server_xinput_abi          11.0
17
18 %define         rel     1
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.9.0
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  ba1173998a5a4216fd7b40eded96697e
28 Source1:        10-quirks.conf
29 Source2:        xserver.pamd
30 Patch0:         %{name}-xwrapper.patch
31 Patch1:         %{name}-pic-libxf86config.patch
32 Patch2:         %{name}-fb-size.patch
33 Patch3:         %{name}-less-acpi-brokenness.patch
34 Patch4:         %{name}-builtin-SHA1.patch
35 URL:            http://xorg.freedesktop.org/
36 BuildRequires:  Mesa-libGL-devel >= 7.8.1
37 # for glx headers
38 BuildRequires:  OpenGL-GLX-devel
39 BuildRequires:  autoconf >= 2.57
40 BuildRequires:  automake
41 BuildRequires:  cpp
42 #BuildRequires: doxygen >= 1.6.1
43 %if %{with hal} || %{with dbus}
44 BuildRequires:  dbus-devel >= 1.0
45 %endif
46 # Note: fop is invoked by xmlto. It is not a dependency of xmlto, because it is
47 # quite rare usecase, and it is very "havy" dependency (requires Java, %post
48 # scripts execytes long time). So we need to add it here.
49 BuildRequires:  fop
50 %{?with_hal:BuildRequires:      hal-devel}
51 BuildRequires:  libdrm-devel >= 2.4.5
52 BuildRequires:  libtool
53 BuildRequires:  ncurses-devel
54 BuildRequires:  pam-devel
55 BuildRequires:  perl-base
56 BuildRequires:  pixman-devel >= 0.16.0
57 BuildRequires:  pkgconfig >= 1:0.19
58 BuildRequires:  udev-devel >= 1:143
59 BuildRequires:  xmlto >= 0.0.20
60 BuildRequires:  xorg-app-mkfontscale
61 BuildRequires:  xorg-font-font-util >= 1.1
62 BuildRequires:  xorg-lib-libX11-devel
63 BuildRequires:  xorg-lib-libXau-devel
64 BuildRequires:  xorg-lib-libXaw-devel
65 BuildRequires:  xorg-lib-libXdamage-devel
66 BuildRequires:  xorg-lib-libXdmcp-devel
67 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
68 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
69 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
70 BuildRequires:  xorg-lib-libXmu-devel
71 BuildRequires:  xorg-lib-libXpm-devel
72 BuildRequires:  xorg-lib-libXrender-devel
73 BuildRequires:  xorg-lib-libXres-devel
74 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
75 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
76 BuildRequires:  xorg-lib-libXv-devel
77 BuildRequires:  xorg-lib-libXxf86dga-devel
78 BuildRequires:  xorg-lib-libXxf86misc-devel
79 BuildRequires:  xorg-lib-libXxf86vm-devel
80 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
81 BuildRequires:  xorg-lib-libfontenc-devel
82 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
83 BuildRequires:  xorg-lib-libxkbfile-devel
84 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
85 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
86 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
87 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
88 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
89 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
90 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.3}
91 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
92 BuildRequires:  xorg-proto-fontcacheproto-devel
93 BuildRequires:  xorg-proto-fontsproto-devel
94 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
95 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
96 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
97 BuildRequires:  xorg-proto-printproto-devel
98 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
99 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
100 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
101 BuildRequires:  xorg-proto-resourceproto-devel
102 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
103 BuildRequires:  xorg-proto-videoproto-devel
104 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
105 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
106 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
107 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
108 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
109 BuildRequires:  xorg-proto-xf86miscproto-devel
110 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
111 BuildRequires:  xorg-proto-xineramaproto-devel
112 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
113 BuildRequires:  xorg-sgml-doctools >= 1.5
114 BuildRequires:  xorg-util-util-macros >= 1.10
115 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
116 #BR: xcalibrateproto, tslib (for KDRIVE only)
117 Requires(triggerpostun):        sed >= 4.0
118 Requires:       pixman >= 0.16.0
119 Requires:       xkeyboard-config
120 # for rgb.txt
121 Requires:       xorg-app-rgb >= 0.99.3
122 Requires:       xorg-app-xkbcomp
123 %{?with_hal:Suggests:   dbus >= 1.0}
124 %{?with_hal:Suggests:   hal}
125 Suggests:       udev-acl
126 %{?with_udev:Suggests:  udev-core >= 1:143}
127 Suggests:       xorg-driver-input-evdev
128 # xserver requires fixed and cursor fonts
129 Requires:       xorg-font-font-alias
130 Requires:       xorg-font-font-cursor-misc
131 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
132 Suggests:       xkeyboard-config
133 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
134 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
135 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
136 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
137 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
138 Obsoletes:      X11-Xserver < 1:7.0.0
139 Obsoletes:      X11-driver-i2c < 1:7.0.0
140 Obsoletes:      X11-modules < 1:7.0.0
141 Obsoletes:      X11-setup < 1:7.0.0
142 Obsoletes:      XFree86-Xserver < 1:7.0.0
143 Obsoletes:      XFree86-modules < 1:7.0.0
144 Obsoletes:      XFree86-setup < 1:7.0.0
145 Obsoletes:      Xserver
146 Obsoletes:      xorg-xserver-server-xorgcfg
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 # avoid self-dependencies on included modules
150 %define         _noautoreq      libscanpci.so libxf1bpp.so
151
152 %description
153 Xorg server is a generally used X server which uses display hardware.
154 It requires proper driver for your display hardware.
155
156 %description -l pl.UTF-8
157 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
158 graficznej. Do działania wymaga odpowiedniego sterownika.
159
160 %package -n xorg-xserver-Xdmx
161 Summary:        Xdmx - distributed multi-head X server
162 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
163 Group:          X11/Servers
164
165 %description -n xorg-xserver-Xdmx
166 Xdmx - distributed multi-head X server.
167
168 %description -n xorg-xserver-Xdmx -l pl.UTF-8
169 Xdmx - rozproszony, wielomonitorowy serwer X.
170
171 %package -n xorg-xserver-Xnest
172 Summary:        Xnest - nested X server
173 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
174 Group:          X11/Servers
175 Obsoletes:      X11-Xnest < 1:7.0.0
176 Obsoletes:      XFree86-Xnest < 1:7.0.0
177 Obsoletes:      Xserver-Xnest
178
179 %description -n xorg-xserver-Xnest
180 Xnest is an X Window System server which runs in an X window. Xnest is
181 a 'nested' window server, actually a client of the real X server,
182 which manages windows and graphics requests for Xnest, while Xnest
183 manages the windows and graphics requests for its own clients.
184
185 %description -n xorg-xserver-Xnest -l pl.UTF-8
186 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
187 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
188 serwer X dla własnych klientów.
189
190 %description -n xorg-xserver-Xnest -l ru.UTF-8
191 Xnest - это сервер X Window System, который работает в окне X. На
192 самом деле это клиент реального X-сервера, который управляет окнами и
193 графическими запросами для Xnest в то время, как Xnest управляет
194 окнами и графическими запросами для своих собственных клиентов.
195
196 %description -n xorg-xserver-Xnest -l uk.UTF-8
197 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
198 клієнт реального X-сервера, який керує вікнами та графічними запитами
199 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
200 своїх власних клієнтів.
201
202 %package -n xorg-xserver-Xephyr
203 Summary:        Xephyr - nested X server
204 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
205 Group:          X11/Servers
206 Requires:       pixman >= 0.15.0
207
208 %description -n xorg-xserver-Xephyr
209 Xephyr is a a kdrive server that outputs to a window on a pre-existing
210 'host' X display. Think Xnest but with support for modern extensions
211 like composite, damage and randr.
212
213 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
214 the host X server, Xephyr is a real X server which uses the host X
215 server window as "framebuffer" via fast SHM XImages.
216
217 It also has support for 'visually' debugging what the server is
218 painting.
219
220 %description -n xorg-xserver-Xephyr -l pl.UTF-8
221 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
222 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
223 wspólczesnych rozszerzeń jak composite, damage i randr.
224
225 %package -n xorg-xserver-Xfbdev
226 Summary:        Xfbdev - Linux framebuffer device X server
227 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
228 Group:          X11/Servers
229
230 %description -n xorg-xserver-Xfbdev
231 Xfbdev is a Linux framebuffer device X server based on the kdrive X
232 server.
233
234 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
235 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
236
237 %package -n xorg-xserver-Xvfb
238 Summary:        Xvfb - virtual framebuffer X server
239 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
240 Group:          X11/Servers
241 # requires fixed and cursor fonts
242 Requires:       xorg-font-font-alias
243 Requires:       xorg-font-font-cursor-misc
244 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
245 Obsoletes:      X11-Xvfb < 1:7.0.0
246 Obsoletes:      XFree86-Xvfb < 1:7.0.0
247
248 %description -n xorg-xserver-Xvfb
249 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
250 capable of running on machines with no display hardware and no
251 physical input devices. Xvfb emulates a dumb framebuffer using virtual
252 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
253 display. Xvfb is normally used for testing servers. Using Xvfb, the
254 mfb or cfb code for any depth can be exercised without using real
255 hardware that supports the desired depths. Xvfb has also been used to
256 test X clients against unusual depths and screen configurations, to do
257 batch processing with Xvfb as a background rendering engine, to do
258 load testing, to help with porting an X server to a new platform, and
259 to provide an unobtrusive way of running applications which really
260 don't need an X server but insist on having one.
261
262 %description -n xorg-xserver-Xvfb -l pl.UTF-8
263 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
264 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
265 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
266 używany do testowania serwerów X, może też być używany do testowania
267 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
268 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
269 serwera X, ale odmawiają uruchomienia bez niego.
270
271 %package devel
272 Summary:        Header files for X.org server
273 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
274 Group:          X11/Development/Libraries
275 Requires:       libdrm-devel >= 2.4.5
276 Requires:       pixman-devel >= 0.16.0
277 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
278 Requires:       xorg-lib-libxkbfile-devel
279 Requires:       xorg-proto-dri2proto-devel >= 2.3
280 Requires:       xorg-proto-fontsproto-devel
281 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
282 Requires:       xorg-proto-kbproto-devel >= 1.0.3
283 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
284 Requires:       xorg-proto-renderproto-devel >= 0.11
285 Requires:       xorg-proto-videoproto-devel
286 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
287 Requires:       xorg-proto-xproto-devel >= 7.0.17
288 Obsoletes:      X11-Xserver-devel < 1:7.0.0
289 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
290
291 %description devel
292 Header files for X.org server.
293
294 %description devel -l pl.UTF-8
295 Pliki nagłówkowe dla serwera X.org.
296
297 %package -n xorg-xserver-libdri
298 Summary:        DRI extension library for X.org server
299 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
300 Group:          X11/Servers
301 Requires:       %{name} = %{version}-%{release}
302 Provides:       xorg-xserver-module(dri)
303 %if %{without multigl}
304 Conflicts:      xorg-driver-video-fglrx
305 Conflicts:      xorg-driver-video-nvidia
306 %endif
307
308 %description -n xorg-xserver-libdri
309 DRI extension library for X.org server.
310
311 %description -n xorg-xserver-libdri -l pl.UTF-8
312 Biblioteka rozszerzenia DRI dla serwera X.org.
313
314 %package -n xorg-xserver-libglx
315 Summary:        GLX extension library for X.org server
316 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
317 Group:          X11/Servers
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       xorg-xserver-libdri = %{version}-%{release}
320 # Mesa version glapi tables in glx/ dir come from
321 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
322 Provides:       xorg-xserver-module(glx)
323 Obsoletes:      X11-OpenGL-core < 1:7.0.0
324 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
325 %if %{without multigl}
326 Conflicts:      xorg-driver-video-fglrx
327 Conflicts:      xorg-driver-video-nvidia
328 %endif
329
330 %description -n xorg-xserver-libglx
331 GLX extension library for X.org server.
332
333 %description -n xorg-xserver-libglx -l pl.UTF-8
334 Biblioteka rozszerzenia GLX dla serwera X.org.
335
336 %prep
337 %setup -q -n xorg-server-%{version}
338 %patch0 -p0
339 %patch1 -p1
340 %patch2 -p1
341 %patch3 -p1
342 %patch4 -p1
343
344 # xserver uses pixman-1 API/ABI so put that explictly here
345 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
346
347 %build
348 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
349 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
350         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
351         exit 1
352 fi
353
354 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
355 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
356         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
357         exit 1
358 fi
359
360 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
361 if [ $API != %{xorg_xserver_server_font_abi} ]; then
362         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
363         exit 1
364 fi
365 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
366 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
367         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
368         exit 1
369 fi
370 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
371 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
372         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
373         exit 1
374 fi
375
376 %{__libtoolize}
377 %{__aclocal} -I m4
378 %{__autoconf}
379 %{__autoheader}
380 %{__automake}
381 %configure \
382         --with-os-name="PLD/Linux" \
383         --with-os-vendor="PLD/Team" \
384         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
385         %{!?with_hal:--disable-config-hal} \
386         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
387         --enable-aiglx \
388         --enable-builddocs \
389         --enable-dga \
390         %{?with_dmx:--enable-dmx} \
391         --enable-glx-tls \
392         --enable-install-libxf86config \
393         %{?with_record:--enable-record} \
394         --enable-kdrive \
395         --enable-xephyr \
396         --enable-xfbdev \
397         --enable-glx-tls \
398         --disable-xsdl \
399         --disable-xfake \
400         --enable-secure-rpc \
401         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
402         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
403         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
404         --with-xkb-output=/var/lib/xkb
405
406 %{__make}
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410
411 %{__make} install \
412         DESTDIR=$RPM_BUILD_ROOT
413
414 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
415 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
416 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
417 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
418
419 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
420 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
421
422 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
423
424 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
425
426 %if %{with multigl}
427 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
428 mv -f libglx.so libglx.so.%{version}
429 ln -sf libglx.so.%{version} libglx.so
430 %endif
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %if %{with multigl}
436 %post -n xorg-xserver-libglx
437 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
438         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
439 fi
440 %endif
441
442 %triggerpostun -- xorg-xserver-server < 1.5.0
443 if [ -f /etc/X11/xorg.conf ]; then
444         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
445         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
446 %if %{without record}
447         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
448 %endif
449         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
450 fi
451
452 %files
453 %defattr(644,root,root,755)
454 %doc COPYING ChangeLog README
455 %attr(755,root,root) %{_bindir}/X
456 %attr(755,root,root) %{_bindir}/Xorg
457 %attr(4755,root,root) %{_bindir}/Xwrapper
458 %attr(755,root,root) %{_bindir}/cvt
459 %attr(755,root,root) %{_bindir}/gtf
460 %dir %{_libdir}/xorg
461 %{_libdir}/xorg/protocol.txt
462 %dir %{_libdir}/xorg/modules
463 %dir %{_libdir}/xorg/modules/dri
464 %dir %{_libdir}/xorg/modules/drivers
465 %dir %{_libdir}/xorg/modules/extensions
466 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
467 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
468 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
469 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
470 %dir %{_libdir}/xorg/modules/input
471 %dir %{_libdir}/xorg/modules/multimedia
472 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
473 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
474 %dir /var/lib/xkb
475 /var/lib/xkb/README.compiled
476 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
477 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
478 %config(missingok) /etc/security/console.apps/xserver
479 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
480 %dir /etc/X11/xorg.conf.d
481 %dir %{_datadir}/X11/xorg.conf.d
482 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
483 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
484 %{_mandir}/man1/Xorg.1x*
485 %{_mandir}/man1/Xserver.1x*
486 %{_mandir}/man1/cvt.1*
487 %{_mandir}/man1/gtf.1x*
488 %{_mandir}/man4/exa.4*
489 %{_mandir}/man4/fbdevhw.4*
490 %{_mandir}/man5/xorg.conf.5x*
491
492 %if %{with dmx}
493 %files -n xorg-xserver-Xdmx
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_bindir}/Xdmx
496 %attr(755,root,root) %{_bindir}/dmxaddinput
497 %attr(755,root,root) %{_bindir}/dmxaddscreen
498 %attr(755,root,root) %{_bindir}/dmxinfo
499 %attr(755,root,root) %{_bindir}/dmxreconfig
500 %attr(755,root,root) %{_bindir}/dmxresize
501 %attr(755,root,root) %{_bindir}/dmxrminput
502 %attr(755,root,root) %{_bindir}/dmxrmscreen
503 %attr(755,root,root) %{_bindir}/dmxtodmx
504 %attr(755,root,root) %{_bindir}/dmxwininfo
505 %attr(755,root,root) %{_bindir}/vdltodmx
506 %attr(755,root,root) %{_bindir}/xdmxconfig
507 %{_mandir}/man1/Xdmx.1x*
508 %{_mandir}/man1/dmxtodmx.1x*
509 %{_mandir}/man1/vdltodmx.1x*
510 %{_mandir}/man1/xdmxconfig.1x*
511 %endif
512
513 %files -n xorg-xserver-Xnest
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_bindir}/Xnest
516 %{_mandir}/man1/Xnest.1x*
517
518 %files -n xorg-xserver-Xephyr
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_bindir}/Xephyr
521 %{_mandir}/man1/Xephyr.1x*
522
523 %files -n xorg-xserver-Xfbdev
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_bindir}/Xfbdev
526
527 %files -n xorg-xserver-Xvfb
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/Xvfb
530 %{_mandir}/man1/Xvfb.1x*
531
532 %files devel
533 %defattr(644,root,root,755)
534 %doc doc/xml/{Xserver-spec.html,xorg.css}
535 %{_includedir}/xorg
536 %{_libdir}/libxf86config.a
537 %{_aclocaldir}/xorg-server.m4
538 %{_pkgconfigdir}/xorg-server.pc
539
540 %files -n xorg-xserver-libdri
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
543
544 %files -n xorg-xserver-libglx
545 %defattr(644,root,root,755)
546 %if %{with multigl}
547 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
548 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
549 %else
550 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
551 %endif
This page took 0.071332 seconds and 4 git commands to generate.