]> git.pld-linux.org Git - packages/xorg-lib-libX11.git/blob - xorg-lib-libX11.spec
- release 2
[packages/xorg-lib-libX11.git] / xorg-lib-libX11.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xcb             # XCB for low-level protocol implementation
5 #
6 Summary:        X11 Base library
7 Summary(pl.UTF-8):      Podstawowa biblioteka X11
8 Name:           xorg-lib-libX11
9 Version:        1.2.1
10 Release:        2
11 License:        MIT
12 Group:          X11/Libraries
13 Source0:        http://xorg.freedesktop.org/releases/individual/lib/libX11-%{version}.tar.bz2
14 # Source0-md5:  2f2beb98e71f397e1209beaca4e97cb1
15 Patch0:         %{name}-glibc-locale_sync.patch
16 URL:            http://xorg.freedesktop.org/
17 BuildRequires:  autoconf >= 2.57
18 BuildRequires:  automake
19 BuildRequires:  cpp
20 BuildRequires:  libtool
21 %{?with_xcb:BuildRequires:      libxcb-devel >= 1.2}
22 BuildRequires:  pkgconfig >= 1:0.19
23 BuildRequires:  xorg-lib-libXau-devel
24 BuildRequires:  xorg-lib-libXdmcp-devel
25 BuildRequires:  xorg-lib-xtrans-devel
26 BuildRequires:  xorg-proto-bigreqsproto-devel
27 BuildRequires:  xorg-proto-inputproto-devel
28 BuildRequires:  xorg-proto-kbproto-devel
29 BuildRequires:  xorg-proto-xcmiscproto-devel
30 BuildRequires:  xorg-proto-xextproto-devel
31 BuildRequires:  xorg-proto-xf86bigfontproto-devel
32 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
33 BuildRequires:  xorg-util-util-macros >= 1.1.0
34 %{?with_xcb:Requires:   libxcb >= 1.2}
35 Obsoletes:      libX11
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 X11 Base library.
40
41 %description -l pl.UTF-8
42 Podstawowa biblioteka X11.
43
44 %package devel
45 Summary:        Header files for libX11 library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libX11
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %{?with_xcb:Requires:   libxcb-devel >= 1.2}
50 Requires:       xorg-lib-libXau-devel
51 Requires:       xorg-lib-libXdmcp-devel
52 Requires:       xorg-proto-kbproto-devel
53 Requires:       xorg-proto-xproto-devel >= 7.0.13
54 Obsoletes:      libX11-devel
55
56 %description devel
57 X11 Base library.
58
59 This package contains the header files needed to develop programs that
60 use libX11.
61
62 %description devel -l pl.UTF-8
63 Podstawowa biblioteka X11.
64
65 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
66 używających biblioteki libX11.
67
68 %package static
69 Summary:        Static libX11 library
70 Summary(pl.UTF-8):      Biblioteka statyczna libX11
71 Group:          X11/Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73 Obsoletes:      libX11-static
74
75 %description static
76 X11 Base library.
77
78 This package contains the static libX11 library.
79
80 %description static -l pl.UTF-8
81 Podstawowa biblioteka X11.
82
83 Pakiet zawiera statyczną bibliotekę libX11.
84
85 %prep
86 %setup -q -n libX11-%{version}
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         %{!?with_static_libs:--disable-static} \
97         %{!?with_xcb:--without-xcb}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         pkgconfigdir=%{_pkgconfigdir}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %pretrans
115 # this needs to be a dir
116 if [ -L %{_libdir}/X11 ]; then
117         umask 022
118         mv -f %{_libdir}/X11{,.rpmsave}
119         mkdir %{_libdir}/X11
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS COPYING ChangeLog README
125 %attr(755,root,root) %{_libdir}/libX11.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libX11.so.6
127 %if %{with xcb}
128 %attr(755,root,root) %{_libdir}/libX11-xcb.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libX11-xcb.so.1
130 %endif
131 %dir %{_libdir}/X11
132 %{_libdir}/X11/Xcms.txt
133 %dir %{_datadir}/X11
134 %{_datadir}/X11/XErrorDB
135 %{_datadir}/X11/XKeysymDB
136 %{_datadir}/X11/locale
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libX11.so
141 %{_libdir}/libX11.la
142 %{_includedir}/X11/*.h
143 %{_pkgconfigdir}/x11.pc
144 %if %{with xcb}
145 %attr(755,root,root) %{_libdir}/libX11-xcb.so
146 %{_libdir}/libX11-xcb.la
147 #%{_includedir}/X11/Xlib-xcb.h (already included in *.h above)
148 %{_pkgconfigdir}/x11-xcb.pc
149 %endif
150 %{_mandir}/man3/*.3x*
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libX11.a
156 %if %{with xcb}
157 %{_libdir}/libX11-xcb.a
158 %endif
159 %endif
This page took 0.044901 seconds and 4 git commands to generate.