]> git.pld-linux.org Git - packages/xorg-lib-libX11.git/blob - xorg-lib-libX11.spec
- rel 2; R: libxcb >= 1.1.92 when built with xcb
[packages/xorg-lib-libX11.git] / xorg-lib-libX11.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xcb             # XCB for low-level protocol implementation
5 #
6 Summary:        X11 Base library
7 Summary(pl.UTF-8):      Podstawowa biblioteka X11
8 Name:           xorg-lib-libX11
9 Version:        1.1.99.2
10 Release:        2
11 License:        MIT
12 Group:          X11/Libraries
13 Source0:        http://xorg.freedesktop.org/releases/individual/lib/libX11-%{version}.tar.bz2
14 # Source0-md5:  2450f861d39939e46f8a4ced1abc3504
15 Patch0:         %{name}-glibc-locale_sync.patch
16 URL:            http://xorg.freedesktop.org/
17 BuildRequires:  autoconf >= 2.57
18 BuildRequires:  automake
19 BuildRequires:  cpp
20 BuildRequires:  libtool
21 %{?with_xcb:BuildRequires:      libxcb-devel >= 1.1.92}
22 BuildRequires:  pkgconfig >= 1:0.19
23 BuildRequires:  xorg-proto-bigreqsproto-devel
24 BuildRequires:  xorg-proto-inputproto-devel
25 BuildRequires:  xorg-proto-kbproto-devel
26 BuildRequires:  xorg-proto-xcmiscproto-devel
27 BuildRequires:  xorg-proto-xextproto-devel
28 BuildRequires:  xorg-proto-xf86bigfontproto-devel
29 BuildRequires:  xorg-proto-xproto-devel >= 7.0.6
30 BuildRequires:  xorg-lib-libXdmcp-devel
31 BuildRequires:  xorg-lib-libXau-devel
32 BuildRequires:  xorg-lib-xtrans-devel
33 BuildRequires:  xorg-util-util-macros >= 1.1.0
34 %{?with_xcb:Requires:   libxcb >= 1.1.92}
35 Obsoletes:      libX11
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 X11 Base library.
40
41 %description -l pl.UTF-8
42 Podstawowa biblioteka X11.
43
44 %package devel
45 Summary:        Header files for libX11 library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libX11
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %{?with_xcb:Requires:   libxcb-devel >= 1.1.92}
50 Requires:       xorg-lib-libXau-devel
51 Requires:       xorg-lib-libXdmcp-devel
52 Requires:       xorg-proto-kbproto-devel
53 Requires:       xorg-proto-xproto-devel >= 7.0.6
54 Obsoletes:      libX11-devel
55
56 %description devel
57 X11 Base library.
58
59 This package contains the header files needed to develop programs that
60 use libX11.
61
62 %description devel -l pl.UTF-8
63 Podstawowa biblioteka X11.
64
65 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
66 używających biblioteki libX11.
67
68 %package static
69 Summary:        Static libX11 library
70 Summary(pl.UTF-8):      Biblioteka statyczna libX11
71 Group:          X11/Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73 Obsoletes:      libX11-static
74
75 %description static
76 X11 Base library.
77
78 This package contains the static libX11 library.
79
80 %description static -l pl.UTF-8
81 Podstawowa biblioteka X11.
82
83 Pakiet zawiera statyczną bibliotekę libX11.
84
85 %prep
86 %setup -q -n libX11-%{version}
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         %{!?with_static_libs:--disable-static} \
97         %{!?with_xcb:--without-xcb}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         pkgconfigdir=%{_pkgconfigdir}
107         
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING ChangeLog README
117 %attr(755,root,root) %{_libdir}/libX11.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libX11.so.6
119 %if %{with xcb}
120 %attr(755,root,root) %{_libdir}/libX11-xcb.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libX11-xcb.so.1
122 %endif
123 %dir %{_libdir}/X11
124 %{_libdir}/X11/Xcms.txt
125 %dir %{_datadir}/X11
126 %{_datadir}/X11/XErrorDB
127 %{_datadir}/X11/XKeysymDB
128 %{_datadir}/X11/locale
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libX11.so
133 %{_libdir}/libX11.la
134 %{_includedir}/X11/*.h
135 %{_pkgconfigdir}/x11.pc
136 %if %{with xcb}
137 %attr(755,root,root) %{_libdir}/libX11-xcb.so
138 %{_libdir}/libX11-xcb.la
139 #%{_includedir}/X11/Xlib-xcb.h (already included in *.h above)
140 %{_pkgconfigdir}/x11-xcb.pc
141 %endif
142 %{_mandir}/man3/*.3x*
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libX11.a
148 %if %{with xcb}
149 %{_libdir}/libX11-xcb.a
150 %endif
151 %endif
This page took 0.091089 seconds and 4 git commands to generate.