]> git.pld-linux.org Git - packages/xorg-lib-libX11.git/blob - xorg-lib-libX11.spec
- up to 1.2.99.901
[packages/xorg-lib-libX11.git] / xorg-lib-libX11.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xcb             # XCB for low-level protocol implementation
5 #
6 Summary:        X11 Base library
7 Summary(pl.UTF-8):      Podstawowa biblioteka X11
8 Name:           xorg-lib-libX11
9 Version:        1.2.99.901
10 Release:        1
11 License:        MIT
12 Group:          X11/Libraries
13 Source0:        http://xorg.freedesktop.org/releases/individual/lib/libX11-%{version}.tar.bz2
14 # Source0-md5:  5923d6b4436fda8a0f04a3b08f693f17
15 # how this patch is being made?
16 Patch0:         %{name}-glibc-locale_sync.patch
17 URL:            http://xorg.freedesktop.org/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake
20 BuildRequires:  cpp
21 BuildRequires:  libtool
22 %{?with_xcb:BuildRequires:      libxcb-devel >= 1.2}
23 BuildRequires:  pkgconfig >= 1:0.19
24 BuildRequires:  xorg-lib-libXau-devel
25 BuildRequires:  xorg-lib-libXdmcp-devel
26 BuildRequires:  xorg-lib-xtrans-devel
27 BuildRequires:  xorg-proto-bigreqsproto-devel
28 BuildRequires:  xorg-proto-inputproto-devel
29 BuildRequires:  xorg-proto-kbproto-devel
30 BuildRequires:  xorg-proto-xcmiscproto-devel
31 BuildRequires:  xorg-proto-xextproto-devel
32 BuildRequires:  xorg-proto-xf86bigfontproto-devel
33 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
34 BuildRequires:  xorg-util-util-macros >= 1.1.0
35 %{?with_xcb:Requires:   libxcb >= 1.2}
36 Obsoletes:      libX11
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 X11 Base library.
41
42 %description -l pl.UTF-8
43 Podstawowa biblioteka X11.
44
45 %package devel
46 Summary:        Header files for libX11 library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libX11
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %{?with_xcb:Requires:   libxcb-devel >= 1.2}
51 Requires:       xorg-lib-libXau-devel
52 Requires:       xorg-lib-libXdmcp-devel
53 Requires:       xorg-proto-kbproto-devel
54 Requires:       xorg-proto-xproto-devel >= 7.0.13
55 Obsoletes:      libX11-devel
56
57 %description devel
58 X11 Base library.
59
60 This package contains the header files needed to develop programs that
61 use libX11.
62
63 %description devel -l pl.UTF-8
64 Podstawowa biblioteka X11.
65
66 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
67 używających biblioteki libX11.
68
69 %package static
70 Summary:        Static libX11 library
71 Summary(pl.UTF-8):      Biblioteka statyczna libX11
72 Group:          X11/Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74 Obsoletes:      libX11-static
75
76 %description static
77 X11 Base library.
78
79 This package contains the static libX11 library.
80
81 %description static -l pl.UTF-8
82 Podstawowa biblioteka X11.
83
84 Pakiet zawiera statyczną bibliotekę libX11.
85
86 %prep
87 %setup -q -n libX11-%{version}
88 #%patch0 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         %{!?with_static_libs:--disable-static} \
98         %{!?with_xcb:--without-xcb}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         pkgconfigdir=%{_pkgconfigdir}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %pretrans
116 # this needs to be a dir
117 if [ -L %{_libdir}/X11 ]; then
118         umask 022
119         mv -f %{_libdir}/X11{,.rpmsave}
120         mkdir %{_libdir}/X11
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS COPYING ChangeLog README
126 %attr(755,root,root) %{_libdir}/libX11.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libX11.so.6
128 %if %{with xcb}
129 %attr(755,root,root) %{_libdir}/libX11-xcb.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libX11-xcb.so.1
131 %endif
132 %dir %{_libdir}/X11
133 %{_libdir}/X11/Xcms.txt
134 %dir %{_datadir}/X11
135 %{_datadir}/X11/XErrorDB
136 %{_datadir}/X11/XKeysymDB
137 %{_datadir}/X11/locale
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libX11.so
142 %{_libdir}/libX11.la
143 %{_includedir}/X11/*.h
144 %{_pkgconfigdir}/x11.pc
145 %if %{with xcb}
146 %attr(755,root,root) %{_libdir}/libX11-xcb.so
147 %{_libdir}/libX11-xcb.la
148 #%{_includedir}/X11/Xlib-xcb.h (already included in *.h above)
149 %{_pkgconfigdir}/x11-xcb.pc
150 %endif
151 %{_mandir}/man3/*.3x*
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libX11.a
157 %if %{with xcb}
158 %{_libdir}/libX11-xcb.a
159 %endif
160 %endif
This page took 0.626031 seconds and 4 git commands to generate.