]> git.pld-linux.org Git - packages/xorg-lib-libX11.git/blob - xorg-lib-libX11.spec
a5834a3498f91960caa5993972c62ac91cf96cbc
[packages/xorg-lib-libX11.git] / xorg-lib-libX11.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Core X11 protocol client library
6 Summary(pl.UTF-8):      Podstawowa biblioteka kliencka protokołu X11
7 Name:           xorg-lib-libX11
8 Version:        1.7.3
9 Release:        1
10 License:        MIT
11 Group:          X11/Libraries
12 Source0:        https://xorg.freedesktop.org/releases/individual/lib/libX11-%{version}.tar.xz
13 # Source0-md5:  dfe451821036c28593bb1873ca3045ba
14 # sync locales and their encodings with glibc
15 Patch0:         %{name}-glibc-locale_sync.patch
16 URL:            https://xorg.freedesktop.org/
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake
19 BuildRequires:  cpp
20 BuildRequires:  docbook-dtd43-xml
21 BuildRequires:  libtool
22 BuildRequires:  libxcb-devel >= 1.11.1
23 BuildRequires:  perl-Encode
24 BuildRequires:  pkgconfig >= 1:0.19
25 BuildRequires:  sed >= 4.0
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xmlto >= 0.0.22
28 BuildRequires:  xorg-lib-xtrans-devel
29 BuildRequires:  xorg-proto-inputproto-devel
30 BuildRequires:  xorg-proto-kbproto-devel
31 BuildRequires:  xorg-proto-xextproto-devel
32 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
33 BuildRequires:  xorg-proto-xproto-devel >= 7.0.25
34 BuildRequires:  xorg-sgml-doctools >= 1.10
35 BuildRequires:  xorg-util-util-macros >= 1.15
36 BuildRequires:  xz
37 Requires:       %{name}-data = %{version}-%{release}
38 Requires:       libxcb >= 1.11.1
39 Obsoletes:      libX11
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Core X11 protocol client library.
44
45 %description -l pl.UTF-8
46 Podstawowa biblioteka kliencka protokołu X11.
47
48 %package data
49 Summary:        Data files for libX11 library
50 Summary(pl.UTF-8):      Pliki danych biblioteki libX11
51 Group:          X11/Libraries
52 Conflicts:      xorg-lib-libX11 < 1.6.3-2
53 BuildArch:      noarch
54
55 %description data
56 Data files for libX11 library.
57
58 %description data -l pl.UTF-8
59 Pliki danych biblioteki libX11.
60
61 %package devel
62 Summary:        Header files for libX11 library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libX11
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       libxcb-devel >= 1.11.1
67 # after <X11/extensions/XKBgeom.h> removal
68 Requires:       xorg-proto-kbproto-devel >= 1.0.7-2019.1.3
69 Requires:       xorg-proto-xproto-devel >= 7.0.25
70 Obsoletes:      libX11-devel
71
72 %description devel
73 Core X11 protocol client library.
74
75 This package contains the header files needed to develop programs that
76 use libX11.
77
78 %description devel -l pl.UTF-8
79 Podstawowa biblioteka kliencka protokołu X11.
80
81 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
82 używających biblioteki libX11.
83
84 %package static
85 Summary:        Static libX11 library
86 Summary(pl.UTF-8):      Biblioteka statyczna libX11
87 Group:          X11/Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Obsoletes:      libX11-static
90
91 %description static
92 Core X11 protocol client library.
93
94 This package contains the static libX11 library.
95
96 %description static -l pl.UTF-8
97 Podstawowa biblioteka kliencka protokołu X11.
98
99 Pakiet zawiera statyczną bibliotekę libX11.
100
101 %prep
102 %setup -q -n libX11-%{version}
103 # do we need this patch for anything? (aka is any pld user in need for these new locales)
104 # https://bugs.freedesktop.org/show_bug.cgi?id=7415
105 %patch0 -p1
106
107 # support __libmansuffix__ and __filemansuffix__ with "x" suffix (per FHS 2.3)
108 %{__sed} -i -e 's,\.so man__libmansuffix__/,.so man3/,' \
109             -e 's,\.so man__filemansuffix__/,.so man5/,' man/*.man
110
111 %build
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         %{!?with_static_libs:--disable-static}
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 %{__make} install \
125         INSTALL="install -p" \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libX11
129
130 cd specs
131 for dir in XIM i18n/framework i18n/localedb i18n/trans libX11; do
132         install -d rpm-doc/$dir
133         cp -a $dir/*.html rpm-doc/$dir
134         cp -a $dir/*.svg rpm-doc/$dir || :
135         sed -i -e "s#$RPM_BUILD_ROOT##g" rpm-doc/$dir/*.html
136 done
137
138 # for xorg-app-x11perf and possibly others
139 install -d $RPM_BUILD_ROOT%{_libdir}/X11
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %pretrans
148 # this needs to be a dir
149 if [ -L %{_libdir}/X11 ]; then
150         umask 022
151         mv -f %{_libdir}/X11{,.rpmsave}
152         mkdir %{_libdir}/X11
153 fi
154
155 %files
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libX11.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libX11.so.6
159 %attr(755,root,root) %{_libdir}/libX11-xcb.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libX11-xcb.so.1
161 %dir %{_libdir}/X11
162
163 %files data
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING ChangeLog README.md
166 %dir %{_datadir}/X11
167 %{_datadir}/X11/XErrorDB
168 %{_datadir}/X11/Xcms.txt
169 %dir %{_datadir}/X11/locale
170 %{_datadir}/X11/locale/compose.dir
171 %{_datadir}/X11/locale/locale.alias
172 %{_datadir}/X11/locale/locale.dir
173 %{_datadir}/X11/locale/C
174 %{_datadir}/X11/locale/en_US.UTF-8
175
176 # encodings, not really lang taggable
177 %{_datadir}/X11/locale/armscii-8
178 %{_datadir}/X11/locale/georgian-academy
179 %{_datadir}/X11/locale/georgian-ps
180 %{_datadir}/X11/locale/ibm-cp1133
181 %{_datadir}/X11/locale/iscii-dev
182 %{_datadir}/X11/locale/isiri-3342
183 %{_datadir}/X11/locale/iso8859-1
184 %{_datadir}/X11/locale/iso8859-10
185 %{_datadir}/X11/locale/iso8859-11
186 %{_datadir}/X11/locale/iso8859-13
187 %{_datadir}/X11/locale/iso8859-14
188 %{_datadir}/X11/locale/iso8859-15
189 %{_datadir}/X11/locale/iso8859-16
190 %{_datadir}/X11/locale/iso8859-2
191 %{_datadir}/X11/locale/iso8859-3
192 %{_datadir}/X11/locale/iso8859-4
193 %{_datadir}/X11/locale/iso8859-5
194 %{_datadir}/X11/locale/iso8859-6
195 %{_datadir}/X11/locale/iso8859-7
196 %{_datadir}/X11/locale/iso8859-8
197 %{_datadir}/X11/locale/iso8859-9
198 %{_datadir}/X11/locale/iso8859-9e
199 %{_datadir}/X11/locale/koi8-c
200 %{_datadir}/X11/locale/koi8-r
201 %{_datadir}/X11/locale/koi8-t
202 %{_datadir}/X11/locale/koi8-u
203 %{_datadir}/X11/locale/microsoft-cp1251
204 %{_datadir}/X11/locale/microsoft-cp1255
205 %{_datadir}/X11/locale/microsoft-cp1256
206 %{_datadir}/X11/locale/mulelao-1
207 %{_datadir}/X11/locale/nokhchi-1
208 %{_datadir}/X11/locale/tatar-cyr
209 %{_datadir}/X11/locale/tscii-0
210
211 %lang(am) %{_datadir}/X11/locale/am_ET.UTF-8
212 %lang(cs) %{_datadir}/X11/locale/cs_CZ.UTF-8
213 %lang(el) %{_datadir}/X11/locale/el_GR.UTF-8
214 %lang(fi) %{_datadir}/X11/locale/fi_FI.UTF-8
215 %lang(ja) %{_datadir}/X11/locale/ja
216 %lang(ja) %{_datadir}/X11/locale/ja.JIS
217 %lang(ja) %{_datadir}/X11/locale/ja.SJIS
218 %lang(ja) %{_datadir}/X11/locale/ja_JP.UTF-8
219 %lang(km) %{_datadir}/X11/locale/km_KH.UTF-8
220 %lang(ko) %{_datadir}/X11/locale/ko
221 %lang(ko) %{_datadir}/X11/locale/ko_KR.UTF-8
222 %lang(pt_BR) %{_datadir}/X11/locale/pt_BR.UTF-8
223 %lang(pt) %{_datadir}/X11/locale/pt_PT.UTF-8
224 %lang(ru) %{_datadir}/X11/locale/ru_RU.UTF-8
225 %lang(sr) %{_datadir}/X11/locale/sr_RS.UTF-8
226 %lang(th) %{_datadir}/X11/locale/th_TH
227 %lang(th) %{_datadir}/X11/locale/th_TH.UTF-8
228 %lang(vi) %{_datadir}/X11/locale/vi_VN.tcvn
229 %lang(vi) %{_datadir}/X11/locale/vi_VN.viscii
230 %lang(zh_CN) %{_datadir}/X11/locale/zh_CN
231 %lang(zh_CN) %{_datadir}/X11/locale/zh_CN.UTF-8
232 %lang(zh_CN) %{_datadir}/X11/locale/zh_CN.gb18030
233 %lang(zh_CN) %{_datadir}/X11/locale/zh_CN.gbk
234 %lang(zh_HK) %{_datadir}/X11/locale/zh_HK.UTF-8
235 %lang(zh_HK) %{_datadir}/X11/locale/zh_HK.big5
236 %lang(zh_HK) %{_datadir}/X11/locale/zh_HK.big5hkscs
237 %lang(zh_TW) %{_datadir}/X11/locale/zh_TW
238 %lang(zh_TW) %{_datadir}/X11/locale/zh_TW.UTF-8
239 %lang(zh_TW) %{_datadir}/X11/locale/zh_TW.big5
240 %{_mandir}/man5/Compose.5*
241 %{_mandir}/man5/XCompose.5*
242
243 %files devel
244 %defattr(644,root,root,755)
245 %doc specs/rpm-doc/*
246 %attr(755,root,root) %{_libdir}/libX11.so
247 %attr(755,root,root) %{_libdir}/libX11-xcb.so
248 %{_libdir}/libX11.la
249 %{_libdir}/libX11-xcb.la
250 %{_includedir}/X11/ImUtil.h
251 %{_includedir}/X11/XKBlib.h
252 %{_includedir}/X11/Xcms.h
253 %{_includedir}/X11/Xlib.h
254 %{_includedir}/X11/Xlib-xcb.h
255 %{_includedir}/X11/XlibConf.h
256 %{_includedir}/X11/Xlibint.h
257 %{_includedir}/X11/Xlocale.h
258 %{_includedir}/X11/Xregion.h
259 %{_includedir}/X11/Xresource.h
260 %{_includedir}/X11/Xutil.h
261 %{_includedir}/X11/cursorfont.h
262 %{_includedir}/X11/extensions/XKBgeom.h
263 %{_pkgconfigdir}/x11.pc
264 %{_pkgconfigdir}/x11-xcb.pc
265 %{_mandir}/man3/AllPlanes.3*
266 %{_mandir}/man3/Bitmap*.3*
267 %{_mandir}/man3/BlackPixel*.3*
268 %{_mandir}/man3/CellsOfScreen.3*
269 %{_mandir}/man3/ClientWhitePointOfCCC.3*
270 %{_mandir}/man3/ConnectionNumber.3*
271 %{_mandir}/man3/Default*.3*
272 %{_mandir}/man3/Display*.3*
273 %{_mandir}/man3/DoesBackingStore.3*
274 %{_mandir}/man3/DoesSaveUnders.3*
275 %{_mandir}/man3/EventMaskOfScreen.3*
276 %{_mandir}/man3/HeightMMOfScreen.3*
277 %{_mandir}/man3/HeightOfScreen.3*
278 %{_mandir}/man3/ImageByteOrder.3*
279 %{_mandir}/man3/Is*Key.3*
280 %{_mandir}/man3/LastKnownRequestProcessed.3*
281 %{_mandir}/man3/MaxCmapsOfScreen.3*
282 %{_mandir}/man3/MinCmapsOfScreen.3*
283 %{_mandir}/man3/NextRequest.3*
284 %{_mandir}/man3/PlanesOfScreen.3*
285 %{_mandir}/man3/ProtocolRevision.3*
286 %{_mandir}/man3/ProtocolVersion.3*
287 %{_mandir}/man3/QLength.3*
288 %{_mandir}/man3/RootWindow*.3*
289 %{_mandir}/man3/Screen*.3*
290 %{_mandir}/man3/ServerVendor.3*
291 %{_mandir}/man3/VendorRelease.3*
292 %{_mandir}/man3/VisualOfCCC.3*
293 %{_mandir}/man3/WhitePixel*.3*
294 %{_mandir}/man3/WidthMMOfScreen.3*
295 %{_mandir}/man3/WidthOfScreen.3*
296 %{_mandir}/man3/X*.3*
297
298 %if %{with static_libs}
299 %files static
300 %defattr(644,root,root,755)
301 %{_libdir}/libX11.a
302 %{_libdir}/libX11-xcb.a
303 %endif
This page took 0.092502 seconds and 2 git commands to generate.