]> git.pld-linux.org Git - packages/xorg-driver-video-qxl.git/blob - xorg-driver-video-qxl.spec
ac406459da37cb1e2ffab1617b9c236a0c0cf088
[packages/xorg-driver-video-qxl.git] / xorg-driver-video-qxl.spec
1 #
2 # Conditional build:
3 %bcond_without  pcsc    # spiceccid PC/SC driver
4 %bcond_without  xspice  # xspice driver
5 #
6 %if %{without xspice}
7 %undefine       with_pcsc
8 %endif
9 Summary:        X.org video driver for QXL virtual GPU
10 Summary(pl.UTF-8):      Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL
11 Name:           xorg-driver-video-qxl
12 Version:        0.1.4
13 Release:        5
14 License:        MIT
15 Group:          X11/Applications
16 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-qxl-%{version}.tar.bz2
17 # Source0-md5:  41e234f38fe8045eef7ade83c34f6dd4
18 Patch0:         %{name}-cast.patch
19 Patch1:         libcacard.patch
20 URL:            http://xorg.freedesktop.org/
21 BuildRequires:  autoconf >= 2.60
22 BuildRequires:  automake
23 %{?with_pcsc:BuildRequires:     libcacard-devel}
24 BuildRequires:  libdrm-devel >= 2.4.46
25 BuildRequires:  libtool
26 %{?with_pcsc:BuildRequires:     pcsc-lite-devel}
27 BuildRequires:  pkgconfig >= 1:0.19
28 BuildRequires:  rpmbuild(macros) >= 1.389
29 BuildRequires:  spice-protocol >= 0.12.0
30 %{?with_xspice:BuildRequires:   spice-server-devel >= 0.6.3}
31 BuildRequires:  udev-devel
32 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
33 BuildRequires:  xorg-proto-fontsproto-devel
34 BuildRequires:  xorg-proto-randrproto-devel
35 BuildRequires:  xorg-proto-renderproto-devel
36 BuildRequires:  xorg-proto-videoproto-devel
37 BuildRequires:  xorg-proto-xf86dgaproto-devel
38 BuildRequires:  xorg-util-util-macros >= 1.4
39 BuildRequires:  xorg-xserver-server-devel >= 1.0.99.901
40 %{?requires_xorg_xserver_videodrv}
41 Requires:       libdrm >= 2.4.46
42 Requires:       xorg-lib-libpciaccess >= 0.10.0
43 Requires:       xorg-xserver-server >= 1.0.99.901
44 Provides:       xorg-driver-video
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 X.org video driver for QXL virtual GPU, which can be found in the
49 RedHat Enterprise Virtualisation system, and also in the spice
50 project.
51
52 %description -l pl.UTF-8
53 Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL,
54 które można znaleźć w systemie RedHat Enterprise Virtualisation oraz w
55 projekcie spice.
56
57 %package -n pcsc-driver-spiceccid
58 Summary:        Chip/Smart Card Interface Devices driver for Spice
59 Summary(pl.UTF-8):      Sterownik CCID dla Spice
60 Group:          Libraries
61 Requires:       pcsc-lite
62
63 %description -n pcsc-driver-spiceccid
64 Chip/Smart Card Interface Devices driver for Spice.
65
66 This driver is built to interface to pcsc-lite as a serial smartcard
67 device. It translates the IFD (Interface device) ABI into the Spice
68 protocol.
69
70 %description -n pcsc-driver-spiceccid -l pl.UTF-8
71 Sterownik CCID (Chip/Smart Card Interface Device) dla Spice.
72
73 Ten sterownik współpracuje z pcsc-lite jako szeregowy czytnik kart
74 procesorowych. Tłumaczy ABI IFD (Interface device) na protokół Spice.
75
76 %package -n spice-xserver
77 Summary:        Xspice - X server and Spice server in one
78 Summary(pl.UTF-8):      Xspice - serwer X oraz serwer Spice w jednym
79 Group:          X11/Applications
80 Requires:       spice-server-libs >= 0.6.3
81 Requires:       xorg-xserver-server >= 1.0.99.901
82
83 %description -n spice-xserver
84 Xspice is an X server and Spice server in one. It consists of a
85 wrapper script for executing Xorg with the right parameters and
86 environment variables, a module named spiceqxl_drv.so implementing
87 three drivers: a video mostly code identical to the guest qxl X
88 driver, and keyboard and mouse reading from the spice inputs channel.
89
90 Xspice allows regular X connections, while a spice client provides the
91 keyboard and mouse and video output.
92
93 %description -n spice-xserver -l pl.UTF-8
94 Xspice to serwer X i serwer Spice w jednym. Składa się ze skryptu
95 wywołującego Xorg z właściwymi parametrami i zmiennymi środowiskowymi,
96 oraz modułu o nazwie spiceqxl_drv.so implementującego trzy sterowniki:
97 graficzny oparty na kodzie prawie identycznym ze sterownikiem X gościa
98 qxl, oraz klawiatury i myszy szytające z kanału wejćiowego spice.
99
100 Xspice pozwala na normalne połączenia X, podczas gdy klient spice
101 udostępnia wejście klawiatury i myszy oraz wyjście obrazu.
102
103 %prep
104 %setup -q -n xf86-video-qxl-%{version}
105 %patch0 -p1
106 %patch1 -p1
107
108 %build
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         %{?with_pcsc:--enable-ccid --with-ccid-module-dir=%{_libdir}/pcsc/drivers} \
116         %{?with_xspice:--enable-xspice}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la
127 %if %{with pcsc}
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers/*.la
129 %endif
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc COPYING ChangeLog README TODO
137 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/qxl_drv.so
138
139 %if %{with pcsc}
140 %files -n pcsc-driver-spiceccid
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/pcsc/drivers/libspiceccid.so*
143 %endif
144
145 %if %{with xspice}
146 %files -n spice-xserver
147 %defattr(644,root,root,755)
148 %doc README.xspice examples/spiceqxl.xorg.conf.example
149 %attr(755,root,root) %{_bindir}/Xspice
150 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/spiceqxl_drv.so
151 %endif
This page took 0.049217 seconds and 2 git commands to generate.