]> git.pld-linux.org Git - packages/xorg-driver-video-qxl.git/blob - xorg-driver-video-qxl.spec
205a25e20f58ae338503d862d5b5eb224064938b
[packages/xorg-driver-video-qxl.git] / xorg-driver-video-qxl.spec
1 #
2 # Conditional build:
3 %bcond_without  pcsc    # spiceccid PC/SC driver
4 %bcond_without  xspice  # xspice driver
5 #
6 %if %{without xspice}
7 %undefine       with_pcsc
8 %endif
9 Summary:        X.org video driver for QXL virtual GPU
10 Summary(pl.UTF-8):      Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL
11 Name:           xorg-driver-video-qxl
12 Version:        0.1.5
13 Release:        3
14 License:        MIT
15 Group:          X11/Applications
16 Source0:        https://xorg.freedesktop.org/releases/individual/driver/xf86-video-qxl-%{version}.tar.bz2
17 # Source0-md5:  addb686fce597a452eecd8d8f9fddf15
18 URL:            https://xorg.freedesktop.org/
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 %{?with_pcsc:BuildRequires:     libcacard-devel}
22 BuildRequires:  libdrm-devel >= 2.4.46
23 BuildRequires:  libtool
24 %{?with_pcsc:BuildRequires:     pcsc-lite-devel}
25 BuildRequires:  pkgconfig >= 1:0.19
26 BuildRequires:  rpmbuild(macros) >= 1.389
27 BuildRequires:  spice-protocol >= 0.12.0
28 %{?with_xspice:BuildRequires:   spice-server-devel >= 0.6.3}
29 BuildRequires:  udev-devel
30 BuildRequires:  xorg-lib-libXfont2-devel >= 2
31 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
32 BuildRequires:  xorg-proto-fontsproto-devel
33 BuildRequires:  xorg-proto-randrproto-devel
34 BuildRequires:  xorg-proto-renderproto-devel
35 BuildRequires:  xorg-proto-videoproto-devel
36 BuildRequires:  xorg-proto-xf86dgaproto-devel
37 BuildRequires:  xorg-proto-xproto-devel
38 BuildRequires:  xorg-util-util-macros >= 1.4
39 BuildRequires:  xorg-xserver-server-devel >= 1.0.99.901
40 %{?requires_xorg_xserver_videodrv}
41 Requires:       libdrm >= 2.4.46
42 Requires:       xorg-lib-libpciaccess >= 0.10.0
43 Requires:       xorg-xserver-server >= 1.0.99.901
44 Provides:       xorg-driver-video
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 X.org video driver for QXL virtual GPU, which can be found in the
49 RedHat Enterprise Virtualisation system, and also in the spice
50 project.
51
52 %description -l pl.UTF-8
53 Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL,
54 które można znaleźć w systemie RedHat Enterprise Virtualisation oraz w
55 projekcie spice.
56
57 %package -n pcsc-driver-spiceccid
58 Summary:        Chip/Smart Card Interface Devices driver for Spice
59 Summary(pl.UTF-8):      Sterownik CCID dla Spice
60 Group:          Libraries
61 Requires:       pcsc-lite
62
63 %description -n pcsc-driver-spiceccid
64 Chip/Smart Card Interface Devices driver for Spice.
65
66 This driver is built to interface to pcsc-lite as a serial smartcard
67 device. It translates the IFD (Interface device) ABI into the Spice
68 protocol.
69
70 %description -n pcsc-driver-spiceccid -l pl.UTF-8
71 Sterownik CCID (Chip/Smart Card Interface Device) dla Spice.
72
73 Ten sterownik współpracuje z pcsc-lite jako szeregowy czytnik kart
74 procesorowych. Tłumaczy ABI IFD (Interface device) na protokół Spice.
75
76 %package -n spice-xserver
77 Summary:        Xspice - X server and Spice server in one
78 Summary(pl.UTF-8):      Xspice - serwer X oraz serwer Spice w jednym
79 Group:          X11/Applications
80 Requires:       spice-server-libs >= 0.6.3
81 Requires:       xorg-xserver-server >= 1.0.99.901
82
83 %description -n spice-xserver
84 Xspice is an X server and Spice server in one. It consists of a
85 wrapper script for executing Xorg with the right parameters and
86 environment variables, a module named spiceqxl_drv.so implementing
87 three drivers: a video mostly code identical to the guest qxl X
88 driver, and keyboard and mouse reading from the spice inputs channel.
89
90 Xspice allows regular X connections, while a spice client provides the
91 keyboard and mouse and video output.
92
93 %description -n spice-xserver -l pl.UTF-8
94 Xspice to serwer X i serwer Spice w jednym. Składa się ze skryptu
95 wywołującego Xorg z właściwymi parametrami i zmiennymi środowiskowymi,
96 oraz modułu o nazwie spiceqxl_drv.so implementującego trzy sterowniki:
97 graficzny oparty na kodzie prawie identycznym ze sterownikiem X gościa
98 qxl, oraz klawiatury i myszy szytające z kanału wejćiowego spice.
99
100 Xspice pozwala na normalne połączenia X, podczas gdy klient spice
101 udostępnia wejście klawiatury i myszy oraz wyjście obrazu.
102
103 %prep
104 %setup -q -n xf86-video-qxl-%{version}
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         %{?with_pcsc:--enable-ccid --with-ccid-module-dir=%{_libdir}/pcsc/drivers} \
114         %{?with_xspice:--enable-xspice}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la
125 %if %{with pcsc}
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers/*.la
127 %endif
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc COPYING ChangeLog NEWS README TODO
135 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/qxl_drv.so
136
137 %if %{with pcsc}
138 %files -n pcsc-driver-spiceccid
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/pcsc/drivers/libspiceccid.so*
141 %endif
142
143 %if %{with xspice}
144 %files -n spice-xserver
145 %defattr(644,root,root,755)
146 %doc README.xspice examples/spiceqxl.xorg.conf.example
147 %attr(755,root,root) %{_bindir}/Xspice
148 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/spiceqxl_drv.so
149 %endif
This page took 0.098633 seconds and 2 git commands to generate.