]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
dee7dd97db92a6811b4e05b0d8e65ed37e07e3d9
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     glamor  Glamor acceleration
4 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
5 #
6 %define libdrm_ver      2.4.41
7 %define pixman_ver      0.28.0
8 %if %{with sna}
9 %define xserver_ver     1.10
10 %else
11 %define xserver_ver     1.6.3
12 %endif
13 Summary:        X.org video driver for Intel integrated graphics chipsets
14 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
15 Name:           xorg-driver-video-intel
16 Version:        2.21.15
17 Release:        6
18 License:        MIT
19 Group:          X11/Applications
20 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
21 # Source0-md5:  8b646d257ace8197d6ab4e5ddeb8efb2
22 Patch0:         xserver-1.15.patch
23 URL:            http://xorg.freedesktop.org/
24 BuildRequires:  Mesa-libGL-devel
25 #BuildRequires: autoconf >= 2.63
26 #BuildRequires: automake >= 1:1.10.2-2
27 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
28 BuildRequires:  libdrm-devel >= %{libdrm_ver}
29 #BuildRequires: libtool >= 2:2.2
30 BuildRequires:  libxcb-devel >= 1.5
31 BuildRequires:  pixman-devel >= %{pixman_ver}
32 BuildRequires:  pkgconfig >= 1:0.19
33 BuildRequires:  rpmbuild(macros) >= 1.389
34 BuildRequires:  udev-devel
35 BuildRequires:  xcb-util-devel
36 BuildRequires:  xorg-lib-libX11-devel
37 BuildRequires:  xorg-lib-libXfixes-devel
38 BuildRequires:  xorg-lib-libXrender-devel
39 BuildRequires:  xorg-lib-libXvMC-devel
40 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
41 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
42 BuildRequires:  xorg-proto-fontsproto-devel
43 BuildRequires:  xorg-proto-glproto-devel
44 BuildRequires:  xorg-proto-randrproto-devel
45 BuildRequires:  xorg-proto-renderproto-devel
46 BuildRequires:  xorg-proto-videoproto-devel
47 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
48 BuildRequires:  xorg-proto-xf86driproto-devel
49 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
50 BuildRequires:  xorg-util-util-macros >= 1.8
51 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
52 %{?requires_xorg_xserver_videodrv}
53 %{?with_glamor:Requires:        glamor >= 0.3.1}
54 Requires:       libdrm >= %{libdrm_ver}
55 Requires:       pixman >= %{pixman_ver}
56 Requires:       xorg-lib-libpciaccess >= 0.10
57 Requires:       xorg-xserver-libdri >= %{xserver_ver}
58 Requires:       xorg-xserver-libglx >= %{xserver_ver}
59 Requires:       xorg-xserver-server >= %{xserver_ver}
60 Provides:       xorg-driver-video
61 Provides:       xorg-driver-video-i810
62 Obsoletes:      X11-driver-i810 < 1:7.0.0
63 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
64 Obsoletes:      XFree86-i810
65 Obsoletes:      xorg-driver-video-i810 < 1.7.2
66 Conflicts:      vbetool
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 X.org video driver for Intel integrated graphics chipsets. It
71 supports:
72 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
73   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
74   Q35, GM45, G45, Q45, G43, G41 chipsets,
75 - Pineview-M in Atom N400 series,
76 - Pineview-D in Atom D400/D500 series.
77
78 Requires Kernel Mode Setting (KMS) to be active.
79
80 %description -l pl.UTF-8
81 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
82 Obsługuje:
83 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
84   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
85   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
86 - Pineview-M w procesorach Atom z serii N400,
87 - Pineview-D w procesorach Atom z serii D400/D500.
88
89 Wymaga aktywnego Kernel Mode Setting (KMS).
90
91 %prep
92 %setup -q -n xf86-video-intel-%{version}
93 %patch0 -p1
94
95 %build
96 %configure \
97         --disable-silent-rules \
98         %{?with_glamor:--enable-glamor} \
99         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
100         --enable-uxa \
101         --enable-sna%{!?with_sna:=no}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
112         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYING ChangeLog NEWS README
123 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
125 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
127 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
128 %{_mandir}/man4/intel.4*
This page took 0.072833 seconds and 2 git commands to generate.