]> git.pld-linux.org Git - packages/xmlrpc-epi.git/blob - xmlrpc-epi.spec
- fix building with -Wformat-security
[packages/xmlrpc-epi.git] / xmlrpc-epi.spec
1 # TODO:
2 # - fix group for -progs subpackage
3 Summary:        XML-RPC EPI library - an implementation of the xmlrpc protocol
4 Summary(pl.UTF-8):      Biblioteka XML-RPC EPI - implementacja protokołu xmlrpc
5 Name:           xmlrpc-epi
6 Version:        0.54.1
7 Release:        4
8 License:        BSD
9 Group:          Libraries
10 Source0:        http://downloads.sourceforge.net/xmlrpc-epi/%{name}-%{version}.tar.gz
11 # Source0-md5:  546ce341e7d79691371344449cb9e484
12 Patch0:         format-security.patch
13 URL:            http://xmlrpc-epi.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  expat-devel
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _includedir     %{_prefix}/include/%{name}
21
22 %description
23 xmlrpc-epi is an implementation of the xmlrpc protocol in C. It
24 provides an easy to use API for developers to serialize RPC requests
25 to and from XML. It doesn't include a transport layer, such as HTTP.
26 The API is primarily based upon proprietary code written for internal
27 usage at Epinions.com, and was later modified to incorporate concepts
28 from the xmlrpc protocol. It passed the xmlrpc validation test suite
29 in December 2000.
30
31 %description -l pl.UTF-8
32 xmlrpc-epi to implementacja protokołu xmlrpc napisana w C. Daje proste
33 w użyciu API dla programistów do serializacji żądań RPC do i z XML-a.
34 Nie zawiera warstwy transportowej typu HTTP. API bazuje głównie na
35 własnościowym kodzie napisanym do użytku wewnętrznego na Epinions.com
36 i zostało później zmodyfikowane, aby włączyć idee protokołu xmlrpc.
37 API to przeszło test sprawdzający poprawność implementacji w grudniu
38 2000.
39
40 %package devel
41 Summary:        Header files etc to develop XML-RPC applications
42 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia aplikacji XML-RPC
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       expat-devel
46
47 %description devel
48 Header files etc needed to develop XML-RPC applications.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe potrzebne do tworzenia aplikacji używających XML-RPC.
52
53 %package static
54 Summary:        Static XML-RPC EPI libraries
55 Summary(pl.UTF-8):      Biblioteki statyczne XML-RPC EPI
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static XML-RPC EPI libraries.
61
62 %description static -l pl.UTF-8
63 Biblioteki statyczne XML-RPC EPI.
64
65 %package progs
66 Summary:        XML-RPC sample programs
67 Summary(pl.UTF-8):      Programy przykładowe XML-RPC
68 Group:          Applications/Text
69 Requires:       %{name} = %{version}-%{release}
70
71 %description progs
72 Sample programs for XML-RPC EPI library.
73
74 %description progs -l pl.UTF-8
75 Programy przykładowe do biblioteki XML-RPC EPI.
76
77 %prep
78 %setup -q -n xmlrpc
79 %patch0 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         --program-prefix=xmlrpc-epi-
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libxmlrpc-epi.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc-epi.so.0
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc AUTHORS COPYING ChangeLog NEWS README
110 %attr(755,root,root) %{_libdir}/libxmlrpc-epi.so
111 %{_libdir}/libxmlrpc-epi.la
112 %{_includedir}
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libxmlrpc-epi.a
117
118 %files progs
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/xmlrpc-epi-*
This page took 0.068713 seconds and 3 git commands to generate.