]> git.pld-linux.org Git - packages/xmlrpc-c.git/blob - xmlrpc-c.spec
- updated to 1.39.13
[packages/xmlrpc-c.git] / xmlrpc-c.spec
1 Summary:        XML-RPC C library - an implementation of the xmlrpc protocol
2 Summary(pl.UTF-8):      Biblioteka XML-RPC C - implementacja protokołu xmlrpc
3 Name:           xmlrpc-c
4 Version:        1.39.13
5 Release:        1
6 License:        XML-RPC for C License (BSD-like)
7 Group:          Libraries
8 # for feature versions:
9 # svn co http://xmlrpc-c.svn.sourceforge.net/svnroot/xmlrpc-c/advanced xmlrpc-c
10 # Unfortunately, upstream does not tag versions so we must fetch from the branch
11 # and check which version was used for it.
12 # for "super stable" versions:
13 Source0:        http://downloads.sourceforge.net/xmlrpc-c/%{name}-%{version}.tgz
14 # Source0-md5:  393d5450c74baffc94b36a2a0c838c3b
15 Patch0:         %{name}-fastdep.patch
16 Patch1:         %{name}-soname.patch
17 Patch2:         %{name}-cflags.patch
18 Patch3:         %{name}-format.patch
19 # patches 10+ come from Fedora (cmake patch is updated from original version)
20 Patch10:        %{name}-cmake.patch
21 Patch11:        %{name}-printf-size_t.patch
22 Patch12:        %{name}-longlong.patch
23 Patch13:        %{name}-uninit-curl.patch
24 Patch14:        %{name}-30x-redirect.patch
25 URL:            http://xmlrpc-c.sourceforge.net/
26 BuildRequires:  cmake >= 2.6
27 BuildRequires:  curl-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  ncurses-devel >= 5.7-21
31 BuildRequires:  pkgconfig
32 BuildRequires:  readline-devel
33 BuildRequires:  rpmbuild(macros) >= 1.577
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  w3c-libwww-devel >= 5.4.0-20
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 XML-RPC is a quick-and-easy way to make procedure calls over the
41 Internet. It converts the procedure call into XML document, sends it
42 to a remote server using HTTP, and gets back the response as XML.
43
44 This library provides a modular implementation of XML-RPC for C.
45
46 %description -l pl.UTF-8
47 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
48 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
49 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
50
51 Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka C.
52
53 %package devel
54 Summary:        C header files for xmlrpc-c base libraries
55 Summary(pl.UTF-8):      Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c 
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       curl-devel
59 Requires:       expat-devel
60 Requires:       libxml2-devel >= 2.0
61 Requires:       w3c-libwww-devel
62
63 %description devel
64 C header files for xmlrpc-c base libraries.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c.
68
69 %package client
70 Summary:        C client library for xmlrpc-c
71 Summary(pl.UTF-8):      Biblioteka kliencka C xmlrpc-c
72 Group:          Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description client
76 XML-RPC is a quick-and-easy way to make procedure calls over the
77 Internet. It converts the procedure call into XML document, sends it
78 to a remote server using HTTP, and gets back the response as XML.
79
80 This library provides a modular implementation of XML-RPC for C
81 clients.
82
83 %description client -l pl.UTF-8
84 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
85 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
86 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
87
88 Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
89 w języku C.
90
91 %package client-devel
92 Summary:        C header files for xmlrpc-c client library
93 Summary(pl.UTF-8):      Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c
94 Group:          Development/Libraries
95 Requires:       %{name}-client = %{version}-%{release}
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description client-devel
99 C header files for xmlrpc-c client library.
100
101 %description client-devel -l pl.UTF-8
102 Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c.
103
104 %package server
105 Summary:        C server libraries for xmlrpc-c
106 Summary(pl.UTF-8):      Biblioteki serwerowe C xmlrpc-c
107 Group:          Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description server
111 XML-RPC is a quick-and-easy way to make procedure calls over the
112 Internet. It converts the procedure call into XML document, sends it
113 to a remote server using HTTP, and gets back the response as XML.
114
115 These libraries provide a modular implementation of XML-RPC for C
116 servers.
117
118 %description server -l pl.UTF-8
119 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
120 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
121 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
122
123 Te biblioteki udostepniają modularną implementacją XML-RPC dla
124 serwerów w języku C.
125
126 %package server-devel
127 Summary:        C header files for xmlrpc-c server libraries
128 Summary(pl.UTF-8):      Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
129 Group:          Development/Libraries
130 Requires:       %{name}-server = %{version}-%{release}
131 Requires:       %{name}-devel = %{version}-%{release}
132
133 %description server-devel
134 C header files for xmlrpc-c server libraries.
135
136 %description server-devel -l pl.UTF-8
137 Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c.
138
139 %package c++
140 Summary:        C++ libraries for xmlrpc-c
141 Summary(pl.UTF-8):      Biblioteki C++ xmlrpc-c
142 Group:          Libraries
143 Requires:       %{name} = %{version}-%{release}
144
145 %description c++
146 XML-RPC is a quick-and-easy way to make procedure calls over the
147 Internet. It converts the procedure call into XML document, sends it
148 to a remote server using HTTP, and gets back the response as XML.
149
150 This library provides a modular implementation of XML-RPC for C++.
151
152 %description c++ -l pl.UTF-8
153 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
154 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
155 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
156
157 Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka
158 C++.
159
160 %package c++-devel
161 Summary:        C++ header files for xmlrpc-c base libraries
162 Summary(pl.UTF-8):      Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c
163 Group:          Development/Libraries
164 Requires:       %{name}-c++ = %{version}-%{release}
165 Requires:       %{name}-devel = %{version}-%{release}
166 Requires:       libstdc++-devel
167
168 %description c++-devel
169 C++ header files for xmlrpc-c base libraries.
170
171 %description c++-devel -l pl.UTF-8
172 Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c.
173
174 %package client++
175 Summary:        C++ client library for xmlrpc-c
176 Summary(pl.UTF-8):      Biblioteka kliencka C++ xmlrpc-c
177 Group:          Libraries
178 Requires:       %{name}-c++ = %{version}-%{release}
179 Requires:       %{name}-client = %{version}-%{release}
180
181 %description client++
182 XML-RPC is a quick-and-easy way to make procedure calls over the
183 Internet. It converts the procedure call into XML document, sends it
184 to a remote server using HTTP, and gets back the response as XML.
185
186 This library provides a modular implementation of XML-RPC for C++
187 clients.
188
189 %description client++ -l pl.UTF-8
190 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
191 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
192 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
193
194 Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
195 w języku C++.
196
197 %package client++-devel
198 Summary:        C++ header files for xmlrpc-c client library
199 Summary(pl.UTF-8):      Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c
200 Group:          Development/Libraries
201 Requires:       %{name}-c++-devel = %{version}-%{release}
202 Requires:       %{name}-client++ = %{version}-%{release}
203 Requires:       %{name}-client-devel = %{version}-%{release}
204
205 %description client++-devel
206 C++ header files for xmlrpc-c client library.
207
208 %description client++-devel -l pl.UTF-8
209 Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c.
210
211 %package server++
212 Summary:        C++ server libraries for xmlrpc-c
213 Summary(pl.UTF-8):      Biblioteki serwerowe C++ xmlrpc-c
214 Group:          Libraries
215 Requires:       %{name}-c++ = %{version}-%{release}
216 Requires:       %{name}-server = %{version}-%{release}
217
218 %description server++
219 XML-RPC is a quick-and-easy way to make procedure calls over the
220 Internet. It converts the procedure call into XML document, sends it
221 to a remote server using HTTP, and gets back the response as XML.
222
223 These libraries provide a modular implementation of XML-RPC for C++
224 servers.
225
226 %description server++ -l pl.UTF-8
227 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
228 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
229 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
230
231 Te biblioteki udostepniają modularną implementacją XML-RPC dla
232 serwerów w języku C++.
233
234 %package server++-devel
235 Summary:        C++ header files for xmlrpc-c server libraries
236 Summary(pl.UTF-8):      Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
237 Group:          Development/Libraries
238 Requires:       %{name}-c++-devel = %{version}-%{release}
239 Requires:       %{name}-server++ = %{version}-%{release}
240 Requires:       %{name}-server-devel = %{version}-%{release}
241
242 %description server++-devel
243 C++ header files for xmlrpc-c server libraries.
244
245 %description server++-devel -l pl.UTF-8
246 Pliki nagłówkowe C++ dla bibliotek serwerowych xmlrpc-c.
247
248 %package apps
249 Summary:        Sample XML-RPC applications
250 Summary(pl.UTF-8):      Przykładowe aplikacje XML-RPC
251 Group:          Applications/Networking
252 Requires:       %{name} = %{version}-%{release}
253 Requires:       %{name}-c++ = %{version}-%{release}
254 Requires:       %{name}-client = %{version}-%{release}
255 Requires:       %{name}-client++ = %{version}-%{release}
256
257 %description apps
258 XML-RPC is a quick-and-easy way to make procedure calls over the
259 Internet. It converts the procedure call into XML document, sends it
260 to a remote server using HTTP, and gets back the response as XML.
261
262 This package contains some handy XML-RPC demo applications.
263
264 %description apps -l pl.UTF-8
265 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
266 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
267 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
268
269 Ten pakiet zawiera kilka podręcznych aplikacji demonstracyjnych
270 XML-RPC.
271
272 %prep
273 %setup -q
274 %patch0 -p1
275 %patch2 -p1
276 %patch10 -p1
277 %patch11 -p1
278 %patch12 -p1
279 %patch13 -p1
280 %patch14 -p1
281 %patch1 -p1
282 %patch3 -p1
283
284 %build
285 mkdir -p build
286 cd build
287 %cmake .. \
288         -D_lib:STRING=%{_lib} \
289         -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
290         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
291         -DMUST_BUILD_CURL_CLIENT:BOOL=ON \
292         -DMUST_BUILD_LIBWWW_CLIENT:BOOL=ON \
293         -DBUILD_SHARED_LIBS:BOOL=ON \
294         -DENABLE_TOOLS:BOOL=ON
295
296 %{__make}
297
298 %install
299 rm -rf $RPM_BUILD_ROOT
300
301 %{__make} -C build install \
302         DESTDIR=$RPM_BUILD_ROOT \
303
304 chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so*
305
306 # Win32-specific
307 %{__rm} $RPM_BUILD_ROOT%{_includedir}/xmlrpc_server_w32httpsys.h \
308         $RPM_BUILD_ROOT%{_includedir}/xmlrpc-c/server_w32httpsys.h
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %post   -p /sbin/ldconfig
314 %postun -p /sbin/ldconfig
315
316 %post   client -p /sbin/ldconfig
317 %postun client -p /sbin/ldconfig
318
319 %post   server -p /sbin/ldconfig
320 %postun server -p /sbin/ldconfig
321
322 %post   c++ -p /sbin/ldconfig
323 %postun c++ -p /sbin/ldconfig
324
325 %post   client++ -p /sbin/ldconfig
326 %postun client++ -p /sbin/ldconfig
327
328 %post   server++ -p /sbin/ldconfig
329 %postun server++ -p /sbin/ldconfig
330
331 %files
332 %defattr(644,root,root,755)
333 %doc README doc/{COPYING,CREDITS,HISTORY,SECURITY,TODO}
334 %attr(755,root,root) %{_libdir}/libxmlrpc-c.so.*.*
335 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc-c.so.3
336 %attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so.*.*
337 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_abyss.so.3
338 %attr(755,root,root) %{_libdir}/libxmlrpc_util.so.*.*
339 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_util.so.3
340
341 %files devel
342 %defattr(644,root,root,755)
343 %doc doc/{DEVELOPING,TESTING}
344 %attr(755,root,root) %{_bindir}/xmlrpc-c-config
345 %attr(755,root,root) %{_libdir}/libxmlrpc-c.so
346 %attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so
347 %attr(755,root,root) %{_libdir}/libxmlrpc_util.so
348 %dir %{_includedir}/xmlrpc-c
349 %{_includedir}/xmlrpc-c/abyss*.h
350 %{_includedir}/xmlrpc-c/base.h
351 %{_includedir}/xmlrpc-c/c_util.h
352 %{_includedir}/xmlrpc-c/config.h
353 %{_includedir}/xmlrpc-c/inttypes.h
354 %{_includedir}/xmlrpc-c/json.h
355 %{_includedir}/xmlrpc-c/oldxmlrpc.h
356 %{_includedir}/xmlrpc-c/transport.h
357 %{_includedir}/xmlrpc-c/util.h
358 %{_includedir}/xmlrpc.h
359 %{_pkgconfigdir}/xmlrpc.pc
360 %{_pkgconfigdir}/xmlrpc_abyss.pc
361 %{_pkgconfigdir}/xmlrpc_util.pc
362
363 %files client
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_libdir}/libxmlrpc_client.so.*.*
366 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client.so.3
367
368 %files client-devel
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_libdir}/libxmlrpc_client.so
371 %{_includedir}/xmlrpc-c/client*.h
372 %{_includedir}/xmlrpc_client.h
373 %{_pkgconfigdir}/xmlrpc_client.pc
374
375 %files server
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/libxmlrpc_server.so.*.*
378 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server.so.3
379 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so.*.*
380 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss.so.3
381 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so.*.*
382 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi.so.3
383
384 %files server-devel
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/libxmlrpc_server.so
387 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so
388 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so
389 %{_includedir}/xmlrpc-c/server.h
390 %{_includedir}/xmlrpc-c/server_abyss.h
391 %{_includedir}/xmlrpc-c/server_cgi.h
392 %{_includedir}/xmlrpc_abyss.h
393 %{_includedir}/xmlrpc_cgi.h
394 %{_includedir}/xmlrpc_server.h
395 %{_pkgconfigdir}/xmlrpc_server.pc
396 %{_pkgconfigdir}/xmlrpc_server_abyss.pc
397 %{_pkgconfigdir}/xmlrpc_server_cgi.pc
398
399 %files c++
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/libxmlrpc++.so.*.*
402 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc++.so.8
403 %attr(755,root,root) %{_libdir}/libxmlrpc_abyss++.so.*.*
404 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_abyss++.so.8
405 %attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so.*.*
406 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_cpp.so.8
407 %attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_packetsocket.so.8
409 %attr(755,root,root) %{_libdir}/libxmlrpc_util++.so.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_util++.so.8
411
412 %files c++-devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libxmlrpc++.so
415 %attr(755,root,root) %{_libdir}/libxmlrpc_abyss++.so
416 %attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so
417 %attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so
418 %attr(755,root,root) %{_libdir}/libxmlrpc_util++.so
419 %{_includedir}/xmlrpc-c/base.hpp
420 %{_includedir}/xmlrpc-c/base64.hpp
421 %{_includedir}/xmlrpc-c/girerr.hpp
422 %{_includedir}/xmlrpc-c/girmem.hpp
423 %{_includedir}/xmlrpc-c/oldcppwrapper.hpp
424 %{_includedir}/xmlrpc-c/packetsocket.hpp
425 %{_includedir}/xmlrpc-c/registry.hpp
426 %{_includedir}/xmlrpc-c/timeout.hpp
427 %{_includedir}/xmlrpc-c/xml.hpp
428 %{_includedir}/XmlRpcCpp.h
429 %{_pkgconfigdir}/xmlrpc++.pc
430 %{_pkgconfigdir}/xmlrpc_abyss++.pc
431 %{_pkgconfigdir}/xmlrpc_cpp.pc
432 %{_pkgconfigdir}/xmlrpc_packetsocket.pc
433 %{_pkgconfigdir}/xmlrpc_util++.pc
434
435 %files client++
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/libxmlrpc_client++.so.*.*
438 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client++.so.8
439
440 %files client++-devel
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_libdir}/libxmlrpc_client++.so
443 %{_includedir}/xmlrpc-c/client*.hpp
444 %{_pkgconfigdir}/xmlrpc_client++.pc
445
446 %files server++
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_libdir}/libxmlrpc_server++.so.*.*
449 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server++.so.8
450 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so.*.*
451 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss++.so.8
452 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so.*.*
453 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi++.so.8
454 %attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so.*.*
455 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_pstream++.so.8
456
457 %files server++-devel
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_libdir}/libxmlrpc_server++.so
460 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so
461 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so
462 %attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so
463 %{_includedir}/xmlrpc-c/server_abyss.hpp
464 %{_includedir}/xmlrpc-c/server_pstream.hpp
465 %{_pkgconfigdir}/xmlrpc_server++.pc
466 %{_pkgconfigdir}/xmlrpc_server_abyss++.pc
467 %{_pkgconfigdir}/xmlrpc_server_cgi++.pc
468 %{_pkgconfigdir}/xmlrpc_server_pstream++.pc
469
470 %files apps
471 %defattr(644,root,root,755)
472 %doc tools/xmlrpc_transport/xmlrpc_transport.html
473 %attr(755,root,root) %{_bindir}/xmlrpc
474 %attr(755,root,root) %{_bindir}/xmlrpc_parsecall
475 %attr(755,root,root) %{_bindir}/xmlrpc_transport
476 %attr(755,root,root) %{_bindir}/xml-rpc-api2cpp
477 %attr(755,root,root) %{_bindir}/xml-rpc-api2txt
478 %attr(755,root,root) %{_bindir}/xmlrpc_cpp_proxy
479 %attr(755,root,root) %{_bindir}/xmlrpc_pstream
480 %{_mandir}/man1/xml-rpc-api2cpp.1*
481 %{_mandir}/man1/xml-rpc-api2txt.1*
This page took 0.117983 seconds and 4 git commands to generate.