]> git.pld-linux.org Git - packages/xmlrpc-c.git/blob - xmlrpc-c.spec
- x32 rebuild
[packages/xmlrpc-c.git] / xmlrpc-c.spec
1 Summary:        XML-RPC C library - an implementation of the xmlrpc protocol
2 Summary(pl.UTF-8):      Biblioteka XML-RPC C - implementacja protokołu xmlrpc
3 Name:           xmlrpc-c
4 Version:        1.32.05
5 Release:        3
6 License:        XML-RPC for C License (BSD-like)
7 Group:          Libraries
8 # svn co http://xmlrpc-c.svn.sourceforge.net/svnroot/xmlrpc-c/advanced xmlrpc-c
9 # Unfortunately, upstream does not tag versions so we must fetch from the branch
10 # and check which version was used for it
11 # 1.32.05 is svn r2451
12 Source0:        %{name}-%{version}.tar.xz
13 # Source0-md5:  c80cfb54a6e26247369de042474e08e0
14 Patch0:         %{name}-fastdep.patch
15 Patch1:         %{name}-soname.patch
16 Patch2:         %{name}-cflags.patch
17 Patch3:         %{name}-cmake-fix.patch
18 Patch4:         %{name}-format.patch
19 # patches 10+ come from Fedora
20 Patch10:        %{name}-cmake.patch
21 Patch11:        %{name}-printf-size_t.patch
22 Patch12:        %{name}-longlong.patch
23 Patch13:        %{name}-uninit-curl.patch
24 Patch14:        %{name}-30x-redirect.patch
25 Patch15:        %{name}-check-vasprintf-return-value.patch
26 Patch16:        %{name}-include-string_int.h.patch
27 URL:            http://xmlrpc-c.sourceforge.net/
28 BuildRequires:  cmake >= 2.6
29 BuildRequires:  curl-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libxml2-devel >= 2.0
32 BuildRequires:  ncurses-devel >= 5.7-21
33 BuildRequires:  pkgconfig
34 BuildRequires:  readline-devel
35 BuildRequires:  rpmbuild(macros) >= 1.577
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  w3c-libwww-devel >= 5.4.0-11
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 XML-RPC is a quick-and-easy way to make procedure calls over the
43 Internet. It converts the procedure call into XML document, sends it
44 to a remote server using HTTP, and gets back the response as XML.
45
46 This library provides a modular implementation of XML-RPC for C.
47
48 %description -l pl.UTF-8
49 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
50 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
51 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
52
53 Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka C.
54
55 %package devel
56 Summary:        C header files for xmlrpc-c base libraries
57 Summary(pl.UTF-8):      Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c 
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       curl-devel
61 Requires:       expat-devel
62 Requires:       libxml2-devel >= 2.0
63 Requires:       w3c-libwww-devel
64
65 %description devel
66 C header files for xmlrpc-c base libraries.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c.
70
71 %package client
72 Summary:        C client library for xmlrpc-c
73 Summary(pl.UTF-8):      Biblioteka kliencka C xmlrpc-c
74 Group:          Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description client
78 XML-RPC is a quick-and-easy way to make procedure calls over the
79 Internet. It converts the procedure call into XML document, sends it
80 to a remote server using HTTP, and gets back the response as XML.
81
82 This library provides a modular implementation of XML-RPC for C
83 clients.
84
85 %description client -l pl.UTF-8
86 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
87 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
88 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
89
90 Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
91 w języku C.
92
93 %package client-devel
94 Summary:        C header files for xmlrpc-c client library
95 Summary(pl.UTF-8):      Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c
96 Group:          Development/Libraries
97 Requires:       %{name}-client = %{version}-%{release}
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description client-devel
101 C header files for xmlrpc-c client library.
102
103 %description client-devel -l pl.UTF-8
104 Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c.
105
106 %package server
107 Summary:        C server libraries for xmlrpc-c
108 Summary(pl.UTF-8):      Biblioteki serwerowe C xmlrpc-c
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description server
113 XML-RPC is a quick-and-easy way to make procedure calls over the
114 Internet. It converts the procedure call into XML document, sends it
115 to a remote server using HTTP, and gets back the response as XML.
116
117 These libraries provide a modular implementation of XML-RPC for C
118 servers.
119
120 %description server -l pl.UTF-8
121 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
122 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
123 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
124
125 Te biblioteki udostepniają modularną implementacją XML-RPC dla
126 serwerów w języku C.
127
128 %package server-devel
129 Summary:        C header files for xmlrpc-c server libraries
130 Summary(pl.UTF-8):      Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
131 Group:          Development/Libraries
132 Requires:       %{name}-server = %{version}-%{release}
133 Requires:       %{name}-devel = %{version}-%{release}
134
135 %description server-devel
136 C header files for xmlrpc-c server libraries.
137
138 %description server-devel -l pl.UTF-8
139 Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c.
140
141 %package c++
142 Summary:        C++ libraries for xmlrpc-c
143 Summary(pl.UTF-8):      Biblioteki C++ xmlrpc-c
144 Group:          Libraries
145 Requires:       %{name} = %{version}-%{release}
146
147 %description c++
148 XML-RPC is a quick-and-easy way to make procedure calls over the
149 Internet. It converts the procedure call into XML document, sends it
150 to a remote server using HTTP, and gets back the response as XML.
151
152 This library provides a modular implementation of XML-RPC for C++.
153
154 %description c++ -l pl.UTF-8
155 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
156 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
157 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
158
159 Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka
160 C++.
161
162 %package c++-devel
163 Summary:        C++ header files for xmlrpc-c base libraries
164 Summary(pl.UTF-8):      Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c
165 Group:          Development/Libraries
166 Requires:       %{name}-c++ = %{version}-%{release}
167 Requires:       %{name}-devel = %{version}-%{release}
168 Requires:       libstdc++-devel
169
170 %description c++-devel
171 C++ header files for xmlrpc-c base libraries.
172
173 %description c++-devel -l pl.UTF-8
174 Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c.
175
176 %package client++
177 Summary:        C++ client library for xmlrpc-c
178 Summary(pl.UTF-8):      Biblioteka kliencka C++ xmlrpc-c
179 Group:          Libraries
180 Requires:       %{name}-c++ = %{version}-%{release}
181 Requires:       %{name}-client = %{version}-%{release}
182
183 %description client++
184 XML-RPC is a quick-and-easy way to make procedure calls over the
185 Internet. It converts the procedure call into XML document, sends it
186 to a remote server using HTTP, and gets back the response as XML.
187
188 This library provides a modular implementation of XML-RPC for C++
189 clients.
190
191 %description client++ -l pl.UTF-8
192 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
193 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
194 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
195
196 Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
197 w języku C++.
198
199 %package client++-devel
200 Summary:        C++ header files for xmlrpc-c client library
201 Summary(pl.UTF-8):      Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c
202 Group:          Development/Libraries
203 Requires:       %{name}-c++-devel = %{version}-%{release}
204 Requires:       %{name}-client++ = %{version}-%{release}
205 Requires:       %{name}-client-devel = %{version}-%{release}
206
207 %description client++-devel
208 C++ header files for xmlrpc-c client library.
209
210 %description client++-devel -l pl.UTF-8
211 Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c.
212
213 %package server++
214 Summary:        C++ server libraries for xmlrpc-c
215 Summary(pl.UTF-8):      Biblioteki serwerowe C++ xmlrpc-c
216 Group:          Libraries
217 Requires:       %{name}-c++ = %{version}-%{release}
218 Requires:       %{name}-server = %{version}-%{release}
219
220 %description server++
221 XML-RPC is a quick-and-easy way to make procedure calls over the
222 Internet. It converts the procedure call into XML document, sends it
223 to a remote server using HTTP, and gets back the response as XML.
224
225 These libraries provide a modular implementation of XML-RPC for C++
226 servers.
227
228 %description server++ -l pl.UTF-8
229 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
230 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
231 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
232
233 Te biblioteki udostepniają modularną implementacją XML-RPC dla
234 serwerów w języku C++.
235
236 %package server++-devel
237 Summary:        C++ header files for xmlrpc-c server libraries
238 Summary(pl.UTF-8):      Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
239 Group:          Development/Libraries
240 Requires:       %{name}-c++-devel = %{version}-%{release}
241 Requires:       %{name}-server++ = %{version}-%{release}
242 Requires:       %{name}-server-devel = %{version}-%{release}
243
244 %description server++-devel
245 C++ header files for xmlrpc-c server libraries.
246
247 %description server++-devel -l pl.UTF-8
248 Pliki nagłówkowe C++ dla bibliotek serwerowych xmlrpc-c.
249
250 %package apps
251 Summary:        Sample XML-RPC applications
252 Summary(pl.UTF-8):      Przykładowe aplikacje XML-RPC
253 Group:          Applications/Networking
254 Requires:       %{name} = %{version}-%{release}
255 Requires:       %{name}-c++ = %{version}-%{release}
256 Requires:       %{name}-client = %{version}-%{release}
257 Requires:       %{name}-client++ = %{version}-%{release}
258
259 %description apps
260 XML-RPC is a quick-and-easy way to make procedure calls over the
261 Internet. It converts the procedure call into XML document, sends it
262 to a remote server using HTTP, and gets back the response as XML.
263
264 This package contains some handy XML-RPC demo applications.
265
266 %description apps -l pl.UTF-8
267 XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
268 Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
269 zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
270
271 Ten pakiet zawiera kilka podręcznych aplikacji demonstracyjnych
272 XML-RPC.
273
274 %prep
275 %setup -q -n %{name}
276 %patch0 -p1
277 %patch2 -p1
278 %patch10 -p1
279 %patch11 -p1
280 %patch12 -p1
281 %patch13 -p1
282 %patch14 -p1
283 %patch15 -p1
284 %patch16 -p1
285 %patch1 -p1
286 %patch3 -p1
287 %patch4 -p1
288
289 %build
290 mkdir -p build
291 cd build
292 %cmake .. \
293         -D_lib:STRING=%{_lib} \
294         -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
295         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
296         -DMUST_BUILD_CURL_CLIENT:BOOL=ON \
297         -DMUST_BUILD_LIBWWW_CLIENT:BOOL=ON \
298         -DBUILD_SHARED_LIBS:BOOL=ON \
299         -DENABLE_TOOLS:BOOL=ON
300
301 %{__make}
302
303 %install
304 rm -rf $RPM_BUILD_ROOT
305
306 %{__make} -C build install \
307         DESTDIR=$RPM_BUILD_ROOT \
308
309 chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so*
310
311 # Win32-specific
312 %{__rm} $RPM_BUILD_ROOT%{_includedir}/xmlrpc_server_w32httpsys.h \
313         $RPM_BUILD_ROOT%{_includedir}/xmlrpc-c/server_w32httpsys.h
314
315 %clean
316 rm -rf $RPM_BUILD_ROOT
317
318 %post   -p /sbin/ldconfig
319 %postun -p /sbin/ldconfig
320
321 %post   client -p /sbin/ldconfig
322 %postun client -p /sbin/ldconfig
323
324 %post   server -p /sbin/ldconfig
325 %postun server -p /sbin/ldconfig
326
327 %post   c++ -p /sbin/ldconfig
328 %postun c++ -p /sbin/ldconfig
329
330 %post   client++ -p /sbin/ldconfig
331 %postun client++ -p /sbin/ldconfig
332
333 %post   server++ -p /sbin/ldconfig
334 %postun server++ -p /sbin/ldconfig
335
336 %files
337 %defattr(644,root,root,755)
338 %doc README doc/{COPYING,CREDITS,HISTORY,SECURITY,TODO}
339 %attr(755,root,root) %{_libdir}/libxmlrpc-c.so.*.*
340 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc-c.so.3
341 %attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so.*.*
342 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_abyss.so.3
343 %attr(755,root,root) %{_libdir}/libxmlrpc_util.so.*.*
344 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_util.so.3
345
346 %files devel
347 %defattr(644,root,root,755)
348 %doc doc/{DEVELOPING,TESTING}
349 %attr(755,root,root) %{_bindir}/xmlrpc-c-config
350 %attr(755,root,root) %{_libdir}/libxmlrpc-c.so
351 %attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so
352 %attr(755,root,root) %{_libdir}/libxmlrpc_util.so
353 %dir %{_includedir}/xmlrpc-c
354 %{_includedir}/xmlrpc-c/abyss*.h
355 %{_includedir}/xmlrpc-c/base.h
356 %{_includedir}/xmlrpc-c/c_util.h
357 %{_includedir}/xmlrpc-c/config.h
358 %{_includedir}/xmlrpc-c/inttypes.h
359 %{_includedir}/xmlrpc-c/json.h
360 %{_includedir}/xmlrpc-c/oldxmlrpc.h
361 %{_includedir}/xmlrpc-c/transport.h
362 %{_includedir}/xmlrpc-c/util.h
363 %{_includedir}/xmlrpc.h
364 %{_pkgconfigdir}/xmlrpc.pc
365 %{_pkgconfigdir}/xmlrpc_abyss.pc
366 %{_pkgconfigdir}/xmlrpc_util.pc
367
368 %files client
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_libdir}/libxmlrpc_client.so.*.*
371 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client.so.3
372
373 %files client-devel
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{_libdir}/libxmlrpc_client.so
376 %{_includedir}/xmlrpc-c/client*.h
377 %{_includedir}/xmlrpc_client.h
378 %{_pkgconfigdir}/xmlrpc_client.pc
379
380 %files server
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/libxmlrpc_server.so.*.*
383 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server.so.3
384 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so.*.*
385 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss.so.3
386 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi.so.3
388
389 %files server-devel
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/libxmlrpc_server.so
392 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so
393 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so
394 %{_includedir}/xmlrpc-c/server.h
395 %{_includedir}/xmlrpc-c/server_abyss.h
396 %{_includedir}/xmlrpc-c/server_cgi.h
397 %{_includedir}/xmlrpc_abyss.h
398 %{_includedir}/xmlrpc_cgi.h
399 %{_includedir}/xmlrpc_server.h
400 %{_pkgconfigdir}/xmlrpc_server.pc
401 %{_pkgconfigdir}/xmlrpc_server_abyss.pc
402 %{_pkgconfigdir}/xmlrpc_server_cgi.pc
403
404 %files c++
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_libdir}/libxmlrpc++.so.*.*
407 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc++.so.8
408 %attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so.*.*
409 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_cpp.so.8
410 %attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so.*.*
411 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_packetsocket.so.8
412
413 %files c++-devel
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_libdir}/libxmlrpc++.so
416 %attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so
417 %attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so
418 %{_includedir}/xmlrpc-c/base.hpp
419 %{_includedir}/xmlrpc-c/girerr.hpp
420 %{_includedir}/xmlrpc-c/girmem.hpp
421 %{_includedir}/xmlrpc-c/oldcppwrapper.hpp
422 %{_includedir}/xmlrpc-c/packetsocket.hpp
423 %{_includedir}/xmlrpc-c/registry.hpp
424 %{_includedir}/xmlrpc-c/timeout.hpp
425 %{_includedir}/xmlrpc-c/xml.hpp
426 %{_includedir}/XmlRpcCpp.h
427 %{_pkgconfigdir}/xmlrpc++.pc
428 %{_pkgconfigdir}/xmlrpc_cpp.pc
429 %{_pkgconfigdir}/xmlrpc_packetsocket.pc
430
431 %files client++
432 %defattr(644,root,root,755)
433 %attr(755,root,root) %{_libdir}/libxmlrpc_client++.so.*.*
434 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client++.so.8
435
436 %files client++-devel
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/libxmlrpc_client++.so
439 %{_includedir}/xmlrpc-c/client*.hpp
440 %{_pkgconfigdir}/xmlrpc_client++.pc
441
442 %files server++
443 %defattr(644,root,root,755)
444 %attr(755,root,root) %{_libdir}/libxmlrpc_server++.so.*.*
445 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server++.so.8
446 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so.*.*
447 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss++.so.8
448 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so.*.*
449 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi++.so.8
450 %attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so.*.*
451 %attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_pstream++.so.8
452
453 %files server++-devel
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_libdir}/libxmlrpc_server++.so
456 %attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so
457 %attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so
458 %attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so
459 %{_includedir}/xmlrpc-c/server_abyss.hpp
460 %{_includedir}/xmlrpc-c/server_pstream.hpp
461 %{_pkgconfigdir}/xmlrpc_server++.pc
462 %{_pkgconfigdir}/xmlrpc_server_abyss++.pc
463 %{_pkgconfigdir}/xmlrpc_server_cgi++.pc
464 %{_pkgconfigdir}/xmlrpc_server_pstream++.pc
465
466 %files apps
467 %defattr(644,root,root,755)
468 %doc tools/xmlrpc/xmlrpc.html tools/xmlrpc_transport/xmlrpc_transport.html
469 %attr(755,root,root) %{_bindir}/xmlrpc
470 %attr(755,root,root) %{_bindir}/xmlrpc_parsecall
471 %attr(755,root,root) %{_bindir}/xmlrpc_transport
472 %attr(755,root,root) %{_bindir}/xml-rpc-api2cpp
473 %attr(755,root,root) %{_bindir}/xml-rpc-api2txt
474 %attr(755,root,root) %{_bindir}/xmlrpc_cpp_proxy
475 %attr(755,root,root) %{_bindir}/xmlrpc_pstream
476 %{_mandir}/man1/xml-rpc-api2cpp.1*
477 %{_mandir}/man1/xml-rpc-api2txt.1*
This page took 0.132425 seconds and 3 git commands to generate.