]> git.pld-linux.org Git - packages/xine-ui.git/blob - xine-ui.spec
- disable lirc support on alpha and sparc*.
[packages/xine-ui.git] / xine-ui.spec
1 # Conditional build:
2 # --without     aa
3 # --without     lirc
4 # --with        directfb
5
6 %ifarch alpha
7 %define         _without_lirc   1
8 %endif
9 %ifarch sparc sparc64
10 %define         _without_lirc   1
11 %endif
12
13 Summary:        A Free Video Player
14 Summary(ko):    °ø°³ µ¿¿µ»ó Ç÷¹À̾î
15 Summary(pl):    Odtwarzacz video
16 Summary(pt_BR): Xine, um player de video
17 Name:           xine-ui
18 Version:        0.9.12
19 Release:        1
20 License:        GPL
21 Group:          X11/Applications/Multimedia
22 Source0:        http://xine.sourceforge.net/files/%{name}-%{version}.tar.gz
23 Source1:        xine.desktop
24 Source2:        xine.png
25 Source3:        xine_logo.png
26 Patch0:         %{name}-DESTDIR.patch
27 Patch1:         %{name}-dfb.patch
28 Patch2:         %{name}-ac_am.patch
29 Patch3:         %{name}-no_corba.patch
30 URL:            http://xine.sourceforge.net
31 %{?_with_directfb:BuildRequires:        DirectFB-devel}
32 %{!?_without_aa:BuildRequires:          aalib-devel}
33 %{!?_without_aa:BuildRequires:          aalib-progs}
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 %{!?_without_lirc:BuildRequires:        lirc-devel}
41 BuildRequires:  ncurses-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  xine-lib-devel >= %{version}
44 Obsoletes:      xine
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _prefix         /usr/X11R6
48 %define         _mandir         %{_prefix}/man
49 %define         _abindir        /usr/bin
50
51 %description
52 xine is a free gpl-licensed video player for unix-like systems. We
53 support mpeg-2 and mpeg-1 system (audio + video multiplexed) streams,
54 eventually mpeg-4 and other formats might be added.
55
56 xine plays the video and audio data of mpeg-2 videos and synchronizes
57 the playback of both. Depending on the properties of the mpeg stream,
58 playback will need more or less processor power, 100% frame rate has
59 been seen on a 400 MHz P II system.
60
61 %description -l fr
62 xine est un lecteur vidéo libre sous license GPL pour les systèmes de
63 type unix. Nous supportons les flux mpeg-2 et mpeg-1 (audio + vidéo
64 multiplexés), éventuellement le mpeg-4 et d'autres formats peuvent
65 êtres ajoutés.
66
67 xine joue les données vidéo et audio de vidéo mpeg-2 et synchronise la
68 lecture des deux. En fonction des propriétes du flux mpeg, la lecture
69 aura besoin de plus ou moins de puissance du processeur, 100% de
70 restitution de trame a été vus sur un système PII 400MHz.
71
72 %description -l ko
73 xine ´Â GPL¶óÀ̼±½º¸¦ µû¸£´Â UNIX¿ë °ø°³ µ¿¿µ»ó Ç÷¹À̾îÀÔ´Ï´Ù. ÀÌ
74 Ç÷¹À̾î´Â mpeg-2 ¿Í mpeg 1 ½ºÆ®¸²À» Áö¿øÇϸç, ÇöÀç´Â Áö¿øÇÏÁö ¾ÊÁö¸¸
75 ³ªÁß¿¡´Â mpeg-4 ¿Í ´Ù¸¥ Çü½ÄÀÇ µ¿¿µ»óµµ Áö¿øÇÒ ¿¹Á¤ÀÔ´Ï´Ù.
76
77 %description -l pl
78 xine jest wolnodostêpnym odtwarzaczem filmów dla systemów uniksowych.
79 Obs³uguje strumienie MPEG-2 i MPEG-1 (przeplatany d¼wiêk i obraz),
80 mo¿e byæ dodana obs³uga MPEG-4 i innych formatów.
81
82 %description -l pt_BR
83 O xine é um video player GPL para sistemas unix. Lê arquivos MPEG-2 e
84 MPEG-1, além de AVIs MS MPEG4 / OpenDivX.
85
86 O xine lê o conteúdo vídeo e áudio e sincroniza-os em tempo-real. As
87 necessidades de processador dependem das propriedades de cada arquivo.
88
89 %package aa
90 Summary:        XINE - Ascii Art player
91 Summary(pl):    XINE - odtwarzacz Ascii Art
92 Summary(pt_BR): XINE - Player em Ascii Art (aalib)
93 Group:          Applications/Graphics
94 Requires:       xine-lib-aa >= %{version}
95
96 %description aa
97 Video player using Ascii Art library.
98
99 %description aa -l pl
100 Odtwarzacz filmów u¿ywaj±cy biblioteki Ascii Art.
101
102 %description aa -l pt_BR
103 Interface para o xine utilizando aalib (Ascii Art Library).
104
105 %package dfb
106 Summary:        XINE - player for DirectFB
107 Summary(pl):    XINE - odtwarzacz dla DirectFB
108 Group:          Applications/Graphics
109 Requires:       xine-lib-directfb >= %{version}
110
111 %description dfb
112 Video player using DirectFB library.
113
114 %description dfb -l pl
115 Odtwarzacz filmów u¿ywaj±cy biblioteki DirectFB.
116
117 %prep
118 %setup -q -n xine-ui-%{version}
119 #%patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123
124 %build
125 %{__libtoolize}
126 aclocal
127 %{__autoconf}
128 %{__automake}
129 autoheader
130 %configure \
131         --disable-orbit \
132         --disable-corba \
133 %{?_without_lirc:       --disable-lirc} \
134 %{!?_without_lirc:      --enable-lirc}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Multimedia,%{_pixmapsdir},%{_datadir}/xine/skins}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         docdir=$RPM_BUILD_ROOT%{_datadir}/doc/xine
145
146 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia/xine.desktop
147 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
148 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/xine/skins
149
150 %{!?_without_aa:install -d $RPM_BUILD_ROOT%{_abindir}}
151 %{!?_without_aa:install $RPM_BUILD_ROOT%{_bindir}/aaxine $RPM_BUILD_ROOT%{_abindir}}
152 %{?_with_directfb:install -d $RPM_BUILD_ROOT%{_abindir}}
153 %{?_with_directfb:install $RPM_BUILD_ROOT%{_bindir}/dfbxine $RPM_BUILD_ROOT%{_abindir}}
154
155 %find_lang %{name} --all-name
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc doc/{README_en,README.{config_en,divx4,dxr3,mrl,opengl,syncfb,tvmode},FAQ_en} ChangeLog 
163 %lang(pl) %doc doc/{README,README.dxr3,FAQ}_pl
164 %lang(it) %doc doc/{README,FAQ}_it
165 %lang(es) %doc doc/{README,FAQ}_es
166 %lang(fr) %doc doc/{README,FAQ}_fr
167 %lang(de) %doc doc/{README,FAQ}_de
168 %lang(it) %doc doc/{README,FAQ}_it
169 %lang(uk) %doc doc/{README,FAQ}_uk
170 %attr(755,root,root) %{_bindir}/xine
171 %attr(755,root,root) %{_bindir}/xine-bugreport
172 %attr(755,root,root) %{_bindir}/xine-check
173 %{_datadir}/xine/skins/*
174 %{_mandir}/man1/*.1*
175 %lang(de) %{_mandir}/de/man1/*.1*
176 %lang(fr) %{_mandir}/fr/man1/*.1*
177 %lang(es) %{_mandir}/es/man1/*.1*
178 %lang(pl) %{_mandir}/pl/man1/*.1*
179 %{_applnkdir}/Multimedia/xine.desktop
180 %{_pixmapsdir}/*
181 # CORBA files 
182 #%{_datadir}/idl/xine.idl
183 #%attr(755,root,root) %{_bindir}/xine-remote
184
185 %{!?_without_aa:%files aa}
186 %{!?_without_aa:%defattr(644,root,root,755)}
187 %{!?_without_aa:%attr(755,root,root) %{_abindir}/aaxine}
188
189 %{?_with_directfb:%files dfb}
190 %{?_with_directfb:%defattr(644,root,root,755)}
191 %{?_with_directfb:%attr(755,root,root) %{_abindir}/dfbxine}
This page took 0.044682 seconds and 3 git commands to generate.