]> git.pld-linux.org Git - packages/xine-ui.git/blob - xine-ui.spec
- dropped am18 patch, BR am 1.8.1 instead (bug present only in 1.8)
[packages/xine-ui.git] / xine-ui.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # without aaxine UI
4 %bcond_without  lirc            # without lirc support
5 %bcond_with     directfb        # with dfbxine UI [disabled in sources at the moment]
6 #
7 %define xine_ver 1:1.0
8 Summary:        A Free Video Player
9 Summary(ko):    °ø°³ µ¿¿µ»ó Ç÷¹À̾î
10 Summary(pl):    Odtwarzacz video
11 Summary(pt_BR): Xine, um player de video
12 Summary(zh_CN): Ò»¸öÃâ·ÑµÄÊÓƵ²¥·ÅÆ÷(½çÃæ)
13 Name:           xine-ui
14 Version:        0.9.23
15 Release:        2
16 License:        GPL
17 Group:          X11/Applications/Multimedia
18 Source0:        http://dl.sourceforge.net/xine/%{name}-%{version}.tar.gz
19 # Source0-md5:  526c96a7c08d2913e6f328e347fe615f
20 Source1:        xine.desktop
21 Source2:        xine.png
22 Source3:        xine_logo.png
23 Patch0:         %{name}-ncurses.patch
24 Patch1:         %{name}-nolibs.patch
25 Patch2:         %{name}-system-readline.patch
26 Patch3:         %{name}-pl.po.patch
27 Patch4:         %{name}-curl.patch
28 URL:            http://xine.sourceforge.net/
29 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.10}
30 %{?with_aalib:BuildRequires:    aalib-devel >= 1.2.0}
31 BuildRequires:  autoconf >= 2.53
32 BuildRequires:  automake >= 1.8.1
33 BuildRequires:  bison
34 BuildRequires:  gettext-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libtool
37 %{?with_lirc:BuildRequires:     lirc-devel}
38 BuildRequires:  ncurses-devel
39 #BuildRequires: nvtv-devel >= 0.4.6     # not released yet
40 BuildRequires:  pkgconfig
41 BuildRequires:  readline-devel >= 4.2a
42 BuildRequires:  xine-lib-devel >= %{xine_ver}
43 Requires:       xine-lib >= %{xine_ver}
44 Requires:       xine-plugin-audio >= %{xine_ver}
45 Obsoletes:      xine
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 xine is a free gpl-licensed video player for unix-like systems. We
50 support mpeg-2 and mpeg-1 system (audio + video multiplexed) streams,
51 eventually mpeg-4 and other formats might be added.
52
53 xine plays the video and audio data of mpeg-2 videos and synchronizes
54 the playback of both. Depending on the properties of the mpeg stream,
55 playback will need more or less processor power, 100% frame rate has
56 been seen on a 400 MHz P II system.
57
58 %description -l fr
59 xine est un lecteur vidéo libre sous license GPL pour les systèmes de
60 type unix. Nous supportons les flux mpeg-2 et mpeg-1 (audio + vidéo
61 multiplexés), éventuellement le mpeg-4 et d'autres formats peuvent
62 êtres ajoutés.
63
64 xine joue les données vidéo et audio de vidéo mpeg-2 et synchronise la
65 lecture des deux. En fonction des propriétes du flux mpeg, la lecture
66 aura besoin de plus ou moins de puissance du processeur, 100% de
67 restitution de trame a été vus sur un système PII 400MHz.
68
69 %description -l ko
70 xine ´Â GPL¶óÀ̼±½º¸¦ µû¸£´Â UNIX¿ë °ø°³ µ¿¿µ»ó Ç÷¹À̾îÀÔ´Ï´Ù. ÀÌ
71 Ç÷¹À̾î´Â mpeg-2 ¿Í mpeg 1 ½ºÆ®¸²À» Áö¿øÇϸç, ÇöÀç´Â Áö¿øÇÏÁö ¾ÊÁö¸¸
72 ³ªÁß¿¡´Â mpeg-4 ¿Í ´Ù¸¥ Çü½ÄÀÇ µ¿¿µ»óµµ Áö¿øÇÒ ¿¹Á¤ÀÔ´Ï´Ù.
73
74 %description -l pl
75 xine jest wolnodostêpnym odtwarzaczem filmów dla systemów uniksowych.
76 Obs³uguje strumienie MPEG-2 i MPEG-1 (przeplatany d¼wiêk i obraz),
77 mo¿e byæ dodana obs³uga MPEG-4 i innych formatów.
78
79 %description -l pt_BR
80 O xine é um video player GPL para sistemas unix. Lê arquivos MPEG-2 e
81 MPEG-1, além de AVIs MS MPEG4 / OpenDivX.
82
83 O xine lê o conteúdo vídeo e áudio e sincroniza-os em tempo-real. As
84 necessidades de processador dependem das propriedades de cada arquivo.
85
86 %package aa
87 Summary:        XINE - Ascii Art player
88 Summary(pl):    XINE - odtwarzacz Ascii Art
89 Summary(pt_BR): XINE - Player em Ascii Art (aalib)
90 Group:          Applications/Multimedia
91 Requires:       xine-lib >= %{xine_ver}
92 Requires:       xine-output-video-aa >= %{xine_ver}
93 Requires:       xine-plugin-audio >= %{xine_ver}
94
95 %description aa
96 Video player using Ascii Art library.
97
98 %description aa -l pl
99 Odtwarzacz filmów u¿ywaj±cy biblioteki Ascii Art.
100
101 %description aa -l pt_BR
102 Interface para o xine utilizando aalib (Ascii Art Library).
103
104 %package dfb
105 Summary:        XINE - player for DirectFB
106 Summary(pl):    XINE - odtwarzacz dla DirectFB
107 Group:          Applications/Multimedia
108 Requires:       xine-lib >= %{xine_ver}
109 Requires:       xine-output-video-directfb >= %{xine_ver}
110 Requires:       xine-plugin-audio >= %{xine_ver}
111
112 %description dfb
113 Video player using DirectFB library.
114
115 %description dfb -l pl
116 Odtwarzacz filmów u¿ywaj±cy biblioteki DirectFB.
117
118 %prep
119 %setup -q
120 %patch0 -p0
121 %patch1 -p1
122 %patch2 -p1
123 %patch3 -p1
124 %patch4 -p1
125
126 %build
127 %{__libtoolize}
128 %{__aclocal} -I m4
129 %{__autoconf}
130 %{__automake}
131 %{__autoheader}
132 %configure \
133         --disable-orbit \
134         --disable-corba \
135 %{!?with_lirc:  --disable-lirc} \
136 %{?with_lirc:   --enable-lirc}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/xine/skins}
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         docdir=$RPM_BUILD_ROOT%{_datadir}/doc/xine
147
148 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
149 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
150 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/xine/skins
151
152 mv $RPM_BUILD_ROOT%{_datadir}/locale/{pl_PL,pl}
153
154 cp src/xitk/xine-toolkit/README doc/README.xitk
155
156 %find_lang %{name} --all-name
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc doc/{README_en,README.*} ChangeLog
164 %lang(cs) %doc doc/README_cs
165 %lang(de) %doc doc/README_de
166 %lang(es) %doc doc/README_es
167 %lang(fi) %doc doc/README_fi
168 %lang(fr) %doc doc/README_fr
169 %lang(it) %doc doc/README_it
170 %lang(pl) %doc doc/README_pl
171 %lang(uk) %doc doc/README_uk
172 %attr(755,root,root) %{_bindir}/fbxine
173 %attr(755,root,root) %{_bindir}/xine
174 %attr(755,root,root) %{_bindir}/xine-bugreport
175 %attr(755,root,root) %{_bindir}/xine-check
176 %attr(755,root,root) %{_bindir}/xine-remote
177 %{_datadir}/xine/skins
178 %{_datadir}/xine/desktop
179 %{_datadir}/xine/visuals
180 %{_mandir}/man1/xine*.1*
181 %lang(de) %{_mandir}/de/man1/xine*.1*
182 %lang(es) %{_mandir}/es/man1/xine*.1*
183 %lang(fr) %{_mandir}/fr/man1/xine*.1*
184 %lang(pl) %{_mandir}/pl/man1/xine*.1*
185 %{_desktopdir}/xine.desktop
186 %{_pixmapsdir}/*
187 # CORBA files
188 #%%{_datadir}/idl/xine.idl
189 #%attr(755,root,root) %{_bindir}/xine-remote
190
191 %if %{with aalib}
192 %files aa
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/aaxine
195 %{_mandir}/man1/aaxine.1*
196 %lang(de) %{_mandir}/de/man1/aaxine.1*
197 %lang(pl) %{_mandir}/pl/man1/aaxine.1*
198 %endif
199
200 %if %{with directfb}
201 %files dfb
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/dfbxine
204 %endif
This page took 0.056996 seconds and 3 git commands to generate.