]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 4.15.0; xfs_scrub as new tool (online xfs check/repair)
[packages/xfsprogs.git] / xfsprogs.spec
1 Summary:        Tools for the XFS filesystem
2 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
3 Name:           xfsprogs
4 Version:        4.15.0
5 Release:        1
6 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
7 Group:          Applications/System
8 Source0:        https://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
9 # Source0-md5:  62096a4a7487bf3b24a6b67be99402f8
10 Source1:        xfs_lsprojid
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-pl.po-update.patch
13 URL:            http://www.xfs.org/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  gettext-tools
18 BuildRequires:  glibc-static
19 BuildRequires:  libblkid-devel
20 BuildRequires:  libtool
21 BuildRequires:  libuuid-devel
22 BuildRequires:  libuuid-static
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm >= 4.4.9-56
25 BuildRequires:  rpmbuild(macros) >= 1.402
26 Requires:       systemd-units >= 38
27 Obsoletes:      xfsprogs-initrd
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %if "%{pld_release}" == "ac"
31 # libtool in ac doesn't do the reordering of args properly
32 %define         filterout_ld -Wl,--as-needed
33 %endif
34
35 %define         _sbindir        /sbin
36 %define         _bindir         /usr/sbin
37 %define         _libdir         /%{_lib}
38 %define         _libexecdir     /usr/%{_lib}
39
40 %description
41 A set of commands to use the XFS filesystem, including mkfs.xfs.
42
43 XFS is a high performance journaling filesystem which originated on
44 the SGI IRIX platform. It is completely multi-threaded, can support
45 large files and large filesystems, extended attributes, variable block
46 sizes, is extent based, and makes extensive use of Btrees
47 (directories, extents, free space) to aid both performance and
48 scalability.
49
50 This implementation is on-disk compatible with the IRIX version of
51 XFS.
52
53 %description -l pl.UTF-8
54 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
55
56 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
57 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
58 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
59 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
60 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
61
62 %package devel
63 Summary:        Header files and libraries to develop XFS software
64 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       libuuid-devel
68
69 %description devel
70 Header files and libraries to develop software which operates on XFS
71 filesystems.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
75 operującego na systemie plików XFS.
76
77 %package static
78 Summary:        Static XFS software libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static XFS software libraries.
85
86 %description static -l pl.UTF-8
87 Biblioteki statyczne do XFS.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %configure \
98         --sbindir=%{_bindir}\
99         --enable-gettext \
100         --enable-readline \
101         --enable-blkid \
102         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
103         OPTIMIZER="%{rpmcflags}"
104
105 %{__make} -j1 \
106         V=1
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc/cron.d}
111
112 DIST_ROOT=$RPM_BUILD_ROOT
113 DIST_INSTALL=$(pwd)/install.manifest
114 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
115 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
116
117 %{__make} install \
118         DIST_MANIFEST="$DIST_INSTALL"
119 %{__make} install-dev \
120         DIST_MANIFEST="$DIST_INSTALL_DEV"
121
122 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
123
124 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
125          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
126
127 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
128 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
129
130 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
131         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
132
133 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
134 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
135
136 %find_lang %{name}
137
138 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
139
140 # already in /usr
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
142
143 mv $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 %systemd_reload
151
152 %postun -p /sbin/ldconfig
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc README doc/{CHANGES,CREDITS}
157 %config(noreplace) %verify(not md5 mtime size) /etc/projects
158 %config(noreplace) %verify(not md5 mtime size) /etc/projid
159 %attr(755,root,root) %{_sbindir}/fsck.xfs
160 %attr(755,root,root) %{_sbindir}/mkfs.xfs
161 %attr(755,root,root) %{_sbindir}/xfs_scrub
162 %attr(755,root,root) %{_sbindir}/xfs_scrub_all
163 %attr(755,root,root) %{_sbindir}/xfs_repair
164 %attr(755,root,root) %{_bindir}/xfs_*
165 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
167 %dir %{_libdir}/%{name}
168 %attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
169 %{systemdunitdir}/xfs_scrub@.service
170 %{systemdunitdir}/xfs_scrub_all.service
171 %{systemdunitdir}/xfs_scrub_all.timer
172 %{systemdunitdir}/xfs_scrub_fail@.service
173 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
174 %{_mandir}/man5/projects.5*
175 %{_mandir}/man5/projid.5*
176 %{_mandir}/man5/xfs.5*
177 %{_mandir}/man8/fsck.xfs.8*
178 %{_mandir}/man8/mkfs.xfs.8*
179 %{_mandir}/man8/xfs_*.8*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libexecdir}/libhandle.so
184 %{_libexecdir}/libhandle.la
185 %{_includedir}/xfs
186 %{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
187 %{_mandir}/man3/*handle.3*
188 %{_mandir}/man3/xfsctl.3*
189
190 %files static
191 %defattr(644,root,root,755)
192 %{_libexecdir}/libhandle.a
This page took 0.052178 seconds and 3 git commands to generate.