]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- final 3.2.0; lib64 systems need fix
[packages/xen.git] / xen.spec
1 #
2 # NOTE:
3 # - this is userspace for xen-3.2.0 (provided by kernel-xen.spec)
4 #   if you are looking for xen-3.0.2 (kernel.spec:LINUX_2_6_16), checkout
5 #   this spec from XEN_3_0_2 branch
6 #
7 # TODO:
8 # - pldized init scripts
9 # - script for rc-boot
10 #
11 # Conditional build:
12 %bcond_with     pae             # build with PAE (HIGHMEM64G) support
13 %bcond_with     hvm             # build with hvm (full virtualization) support
14 #
15 Summary:        Xen - a virtual machine monitor
16 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
17 Name:           xen
18 Version:        3.2.0
19 Release:        0.1
20 License:        GPL
21 Group:          Applications/System
22 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  4aa57328d0802a063fa67dfc063da30e
24 Source1:        %{name}-xend.init
25 Source2:        %{name}-xendomains.init
26 Patch0:         %{name}-python_scripts.patch
27 Patch1:         %{name}-gcc.patch
28 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
29 BuildRequires:  curl-devel
30 BuildRequires:  e2fsprogs-devel
31 BuildRequires:  latex2html
32 BuildRequires:  libidn-devel
33 BuildRequires:  ncurses-devel
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.268
37 BuildRequires:  tetex-dvips
38 BuildRequires:  tetex-format-latex
39 BuildRequires:  tetex-latex-psnfss
40 BuildRequires:  transfig
41 BuildRequires:  which
42 BuildRequires:  zlib-devel
43 %{?with_hvm:BuildRequires:      bcc}
44 Requires(post,preun):   /sbin/chkconfig
45 Requires:       ZopeInterface
46 Requires:       bridge-utils
47 Requires:       kernel(xen0) = %{_major}
48 Requires:       losetup
49 Requires:       rc-scripts
50 Obsoletes:      xen-doc
51 ExclusiveArch:  %{ix86} %{x8664}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %ifnarch i686 athlon pentium3 pentium4
55 %undefine       with_pae
56 %endif
57
58 %description
59 This package contains the Xen hypervisor and Xen tools, needed to run
60 virtual machines on x86 systems, together with the kernel-xen*
61 packages. Information on how to use Xen can be found at the Xen
62 project pages.
63
64 Virtualisation can be used to run multiple versions or multiple Linux
65 distributions on one system, or to test untrusted applications in a
66 sandboxed environment. Note that the Xen technology is still in
67 development, and this RPM has received extremely little testing. Don't
68 be surprised if this RPM eats your data, drinks your coffee or makes
69 fun of you in front of your friends.
70
71 %description -l pl.UTF-8
72 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
73 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
74 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
75 projektu.
76
77 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
78 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
79 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
80 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
81 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
82 się wyśmiewał w obecności przyjaciół.
83
84 %package libs
85 Summary:        xen libraries
86 Summary(pl.UTF-8):      Biblioteki xena
87 Group:          Libraries
88
89 %description libs
90 xen libraries.
91
92 %description libs -l pl.UTF-8
93 Biblioteki xena.
94
95 %package hotplug
96 Summary:        xen hotplug
97 Group:          Application/System
98
99 %description hotplug
100 xen hotplug.
101
102 %package udev
103 Summary:        xen udev
104 Group:          Application/System
105
106 %description udev
107 xen udev.
108
109 %package devel
110 Summary:        Header files for xen
111 Summary(pl.UTF-8):      Pliki nagłówkowe xena
112 Group:          Development/Libraries
113 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
114
115 %description devel
116 Header files for xen.
117
118 %description devel -l pl.UTF-8
119 Pliki nagłówkowe xena.
120
121 %package static
122 Summary:        Static xen libraries
123 Summary(pl.UTF-8):      Statyczne biblioteki xena
124 Group:          Development/Libraries
125 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
126
127 %description static
128 Static xen libraries.
129
130 %description static -l pl.UTF-8
131 Statyczne biblioteki xena.
132
133 %prep
134 %setup -q
135 %patch0 -p1
136 %patch1 -p1
137
138 find . -iregex .*.orig -exec rm {} \;
139
140 chmod -R u+w .
141
142 %build
143 CFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
144 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
145 %{__make} -j1 xen tools \
146         %{?with_pae:XEN_TARGET_X86_PAE=y} \
147         CC="%{__cc}" \
148         CXX="%{__cxx}"
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT/var/run/{xen-hotplug,xend,xenstored}
153
154 %{__make} install-xen install-tools install-docs \
155         %{?with_pae:XEN_TARGET_X86_PAE=y} \
156         DESTDIR=$RPM_BUILD_ROOT \
157         XEN_PYTHON_NATIVE_INSTALL=1
158
159 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
160 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
161 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
162
163 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
164 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/save
165
166 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
167
168 %{py_comp} $RPM_BUILD_ROOT%{py_sitedir}
169 %{py_ocomp} $RPM_BUILD_ROOT%{py_sitedir}
170 %{py_comp} $RPM_BUILD_ROOT%{py_sitescriptdir}
171 %{py_ocomp} $RPM_BUILD_ROOT%{py_sitescriptdir}
172
173 cp -a dist/install/etc/udev $RPM_BUILD_ROOT%{_sysconfdir}
174
175 # remove unneeded files
176 #find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' -exec rm "{}" ";"
177 #find $RPM_BUILD_ROOT%{py_sitescriptdir} -name '*.py' -exec rm "{}" ";"
178 rm -rf $RPM_BUILD_ROOT%{_docdir}/xen
179 rm -rf $RPM_BUILD_ROOT/etc/init.d
180 rm -f $RPM_BUILD_ROOT/boot/xen-3.2.gz
181 rm -f $RPM_BUILD_ROOT/boot/xen-3.gz
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 /sbin/chkconfig --add xend
188 /sbin/chkconfig --add xendomains
189
190 %preun
191 if [ "$1" = "0" ]; then
192         %service xend stop
193         /sbin/chkconfig --del xend
194
195         %service xendomains stop
196         /sbin/chkconfig --del xendomains
197 fi
198
199 %post   libs -p /sbin/ldconfig
200 %postun libs -p /sbin/ldconfig
201
202 %files
203 %defattr(644,root,root,755)
204 %doc COPYING README docs/misc/*
205 %doc docs/html/*
206 /boot/%{name}-syms-%{version}
207 /boot/%{name}-%{version}.gz
208 /boot/%{name}.gz
209 %attr(754,root,root) /etc/rc.d/init.d/*
210 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
211 %dir %{_sysconfdir}/xen
212 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/qemu-ifup
213 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
214 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
215 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
216 %dir %{_sysconfdir}/xen/auto
217 %dir %{_sysconfdir}/xen/scripts
218 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
219 %attr(755,root,root) %{_bindir}/*
220 %attr(755,root,root) %{_sbindir}/*
221 %dir %{_libdir}/%{name}
222 %dir %{_libdir}/%{name}/bin
223 %attr(744,root,root) %{_libdir}/%{name}/bin/*
224 %dir %{_libdir}/%{name}/boot
225 %attr(744,root,root) %{_libdir}/%{name}/boot/hvmloader
226 %{_datadir}/xen
227 %{py_sitedir}/fsimage.so
228 %{py_sitedir}/grub
229 %dir %{py_sitedir}/%{name}
230 %dir %{py_sitedir}/%{name}/lowlevel
231 %{py_sitedir}/%{name}/lowlevel/*.py*
232 %attr(755,root,root) %{py_sitedir}/%{name}/lowlevel/*.so
233 %{py_sitedir}/%{name}/sv
234 %{py_sitedir}/%{name}/util
235 %{py_sitedir}/%{name}/web
236 %{py_sitedir}/%{name}/xend
237 %{py_sitedir}/%{name}/xm
238 %{py_sitedir}/%{name}/xsview
239 %{py_sitedir}/%{name}/*.py*
240 %{py_sitedir}/*.egg-info
241 #%{py_sitescriptdir}/*
242 %{_mandir}/man?/*
243 %{_sharedstatedir}/xen
244 %{_sharedstatedir}/xenstored
245 %dir /var/run/xen-hotplug
246 %dir %attr(700,root,root) /var/run/xend
247 %dir /var/run/xenstored
248
249 %files libs
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/lib*.so.*
252 %dir %{_libdir}/fs
253 %dir %{_libdir}/fs/ext2fs-lib
254 %dir %{_libdir}/fs/fat
255 %dir %{_libdir}/fs/iso9660
256 %dir %{_libdir}/fs/reiserfs
257 %dir %{_libdir}/fs/ufs
258 %attr(755,root,root) %{_libdir}/fs/*/*.so
259
260 %files hotplug
261 %defattr(644,root,root,755)
262 %attr(755,root,root) /etc/hotplug/*
263
264 %files udev
265 %defattr(644,root,root,755)
266 %config(noreplace) %verify(not md5 mtime size) /etc/udev/*
267
268 %files devel
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_libdir}/lib*.so
271 %{_includedir}/*
272
273 %files static
274 %defattr(644,root,root,755)
275 %{_libdir}/lib*.a
This page took 0.066842 seconds and 4 git commands to generate.