]> git.pld-linux.org Git - packages/xapps.git/blob - xapps.spec
- rebuild with python 3.8
[packages/xapps.git] / xapps.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  python2         # CPython 2.x binding
5 %bcond_without  python3         # CPython 3.x binding
6 %bcond_without  static_libs     # static library
7 #
8 Summary:        Components common to multiple desktop environments
9 Summary(pl.UTF-8):      Komponenty wspólne dla wielu środowisk graficznych
10 Name:           xapps
11 Version:        1.4.8
12 Release:        3
13 License:        LGPL v3+ (library), GPL v3+ (xfce4-set-wallpaper tool)
14 Group:          X11/Applications
15 #Source0Download: https://github.com/linuxmint/xapps/releases
16 Source0:        https://github.com/linuxmint/xapps/archive/%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  8eb1f412d7deddd87cda5b783488ca9b
18 URL:            https://github.com/linuxmint/xapps
19 BuildRequires:  cairo-devel
20 BuildRequires:  gdk-pixbuf2-devel >= 2.22.0
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.37.3
23 BuildRequires:  gtk+3-devel >= 3.3.16
24 BuildRequires:  gtk-doc
25 BuildRequires:  libgnomekbd-devel
26 BuildRequires:  meson
27 BuildRequires:  ninja >= 1.5
28 BuildRequires:  pkgconfig
29 %if %{with python2}
30 BuildRequires:  python >= 2
31 BuildRequires:  python-pygobject3 >= 3
32 %endif
33 %if %{with python3}
34 BuildRequires:  python3 >= 1:3
35 BuildRequires:  python3-pygobject3 >= 3
36 %endif
37 BuildRequires:  rpmbuild(macros) >= 1.736
38 BuildRequires:  xorg-lib-libX11-devel
39 BuildRequires:  xorg-lib-libxkbfile-devel
40 Requires(post,postun):  glib2 >= 1:2.40
41 Requires(post,postun):  gtk-update-icon-cache
42 Requires:       %{name}-libs = %{version}-%{release}
43 Requires:       hicolor-icon-theme
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 This project gathers the components which are common to multiple
48 desktop environments and required to implement cross-DE solutions.
49
50 This package contains a set of resources and tools.
51
52 %description -l pl.UTF-8
53 Ten projekt gromadzi komponenty wspólne dla wielu środowisk
54 graficznych, wymagane do implementowania rozwiązań działających w
55 wielu różnych środowiskach.
56
57 Ten pakiet zawiera zbiór zasobów i narzędzi.
58
59 %package libs
60 Summary:        X applications utility library
61 Summary(pl.UTF-8):      Biblioteka narzędziowa dla aplikacji X
62 License:        LGPL v3+
63 Group:          X11/Applications
64 Requires:       gdk-pixbuf2 >= 2.22.0
65 Requires:       glib2 >= 1:2.37.3
66 Requires:       gtk+3 >= 3.3.16
67
68 %description libs
69 X applications utility library.
70
71 %description libs -l pl.UTF-8
72 Biblioteka narzędziowa dla aplikacji X.
73
74 %package devel
75 Summary:        Header files for xapp library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki xapp
77 License:        LGPL v3+
78 Group:          X11/Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       cairo-devel
81 Requires:       gdk-pixbuf2-devel >= 2.22.0
82 Requires:       glib2-devel >= 1:2.37.3
83 Requires:       gtk+3-devel >= 3.3.16
84 Requires:       libgnomekbd-devel
85 Requires:       xorg-lib-libX11-devel
86 Requires:       xorg-lib-libxkbfile-devel
87
88 %description devel
89 Header files for xapp library.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki xapp.
93
94 %package static
95 Summary:        Static xapp library
96 Summary(pl.UTF-8):      Statyczna biblioteka xapp
97 License:        LGPL v3+
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 Static xapp library.
103
104 %description static -l pl.UTF-8
105 Statyczna biblioteka xapp.
106
107 %package apidocs
108 Summary:        API documentation for xapp library
109 Summary(pl.UTF-8):      Dokumentacja API biblioteki xapp
110 License:        LGPL v3+
111 Group:          Documentation
112 %if "%{_rpmversion}" >= "5"
113 BuildArch:      noarch
114 %endif
115
116 %description apidocs
117 API documentation for xapp library.
118
119 %description apidocs -l pl.UTF-8
120 Dokumentacja API biblioteki xapp.
121
122 %package glade
123 Summary:        Glade catalog file for xapp library
124 Summary(pl.UTF-8):      Plik katalogu Glade dla biblioteki xapp
125 License:        LGPL v3+
126 Group:          Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128 Requires:       glade >= 2
129 %if "%{_rpmversion}" >= "5"
130 BuildArch:      noarch
131 %endif
132
133 %description glade
134 Glade catalog file for xapp library.
135
136 %description glade -l pl.UTF-8
137 Plik katalogu Glade dla biblioteki xapp.
138
139 %package -n vala-xapp
140 Summary:        Vala API for xapp library
141 Summary(pl.UTF-8):      API języka Vala do biblioteki xapp
142 License:        LGPL v3+
143 Group:          Development/Libraries
144 Requires:       %{name}-devel = %{version}-%{release}
145 Requires:       vala
146 %if "%{_rpmversion}" >= "5"
147 BuildArch:      noarch
148 %endif
149
150 %description -n vala-xapp
151 Vala API for xapp library.
152
153 %description -n vala-xapp -l pl.UTF-8
154 API języka Vala do biblioteki xapp.
155
156 %package -n python-xapps-overrides
157 Summary:        Python 2 binding for xapp library
158 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki xapp
159 License:        LGPL v3+
160 Group:          Libraries/Python
161 Requires:       %{name}-libs = %{version}-%{release}
162 Requires:       python-pygobject3 >= 3
163 Obsoletes:      python-xapp < 1.4.8
164
165 %description -n python-xapps-overrides
166 Python 2 binding for xapp library.
167
168 %description -n python-xapps-overrides -l pl.UTF-8
169 Wiązanie Pythona 2 do biblioteki xapp.
170
171 %package -n python3-xapps-overrides
172 Summary:        Python 3 binding for xapp library
173 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki xapp
174 License:        LGPL v3+
175 Group:          Libraries/Python
176 Requires:       %{name}-libs = %{version}-%{release}
177 Requires:       python3-pygobject3 >= 3
178 Obsoletes:      python3-xapp < 1.4.8
179
180 %description -n python3-xapps-overrides
181 Python 3 binding for xapp library.
182
183 %description -n python3-xapps-overrides -l pl.UTF-8
184 Wiązanie Pythona 3 do biblioteki xapp.
185
186 %prep
187 %setup -q
188
189 %build
190 %meson build \
191         %{!?with_static_libs:--default-library=shared} \
192         %{?with_apidocs:-Ddocs=true}
193
194 %ninja_build -C build
195
196 %install
197 rm -rf $RPM_BUILD_ROOT
198
199 %ninja_install -C build
200
201 %if %{with python2}
202 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
203 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
204 %py_postclean
205 %endif
206
207 %if %{with python3}
208 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
209 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
210 %endif
211
212 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
213
214 %find_lang xapp
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post
220 %update_icon_cache hicolor
221 %glib_compile_schemas
222
223 %postun
224 %update_icon_cache hicolor
225 %glib_compile_schemas
226
227 %post   libs -p /sbin/ldconfig
228 %postun libs -p /sbin/ldconfig
229
230 %files -f xapp.lang
231 %defattr(644,root,root,755)
232 %doc AUTHORS README.md
233 # utility apps, not related to library
234 %attr(755,root,root) %{_bindir}/pastebin
235 %attr(755,root,root) %{_bindir}/upload-system-info
236 %attr(755,root,root) %{_bindir}/xfce4-set-wallpaper
237 # misc data, some for use with library, some independently
238 %{_datadir}/glib-2.0/schemas/org.x.apps.gschema.xml
239 %{_iconsdir}/hicolor/scalable/actions/add-files-to-archive-symbolic.svg
240 %{_iconsdir}/hicolor/scalable/actions/category-search-symbolic.svg
241 %{_iconsdir}/hicolor/scalable/actions/extract-archive-symbolic.svg
242 %{_iconsdir}/hicolor/scalable/actions/media-mount-symbolic.svg
243 %{_iconsdir}/hicolor/scalable/actions/view-*-symbolic*.svg
244 %{_iconsdir}/hicolor/scalable/actions/xapp-*-symbolic*.svg
245 %{_iconsdir}/hicolor/scalable/categories/xapp-prefs-*-symbolic.svg
246
247 %files libs
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_libdir}/libxapp.so.*.*.*
250 %attr(755,root,root) %ghost %{_libdir}/libxapp.so.1
251 %{_libdir}/girepository-1.0/XApp-1.0.typelib
252
253 %files devel
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libxapp.so
256 %{_includedir}/xapp
257 %{_datadir}/gir-1.0/XApp-1.0.gir
258 %{_pkgconfigdir}/xapp.pc
259
260 %if %{with static_libs}
261 %files static
262 %defattr(644,root,root,755)
263 %{_libdir}/libxapp.a
264 %endif
265
266 %if %{with apidocs}
267 %files apidocs
268 %defattr(644,root,root,755)
269 %{_gtkdocdir}/libxapp
270 %endif
271
272 %files glade
273 %defattr(644,root,root,755)
274 %{_datadir}/glade/catalogs/xapp-glade-catalog.xml
275
276 %files -n vala-xapp
277 %defattr(644,root,root,755)
278 %{_datadir}/vala/vapi/xapp.deps
279 %{_datadir}/vala/vapi/xapp.vapi
280
281 %if %{with python2}
282 %files -n python-xapps-overrides
283 %defattr(644,root,root,755)
284 %{py_sitedir}/gi/overrides/XApp.py[co]
285 %endif
286
287 %if %{with python3}
288 %files -n python3-xapps-overrides
289 %defattr(644,root,root,755)
290 %{py3_sitedir}/gi/overrides/XApp.py
291 %{py3_sitedir}/gi/overrides/__pycache__/XApp.cpython-*.py[co]
292 %endif
This page took 0.122437 seconds and 3 git commands to generate.