]> git.pld-linux.org Git - packages/x265.git/blob - x265.spec
- removed outdated bitbucket URL
[packages/x265.git] / x265.spec
1 # TODO: vmaf
2 #
3 # Conditional build:
4 %bcond_without  asm     # x86 assembler
5 %bcond_with     vmaf    # VMAF support [not ready for vmaf-1.3.x as of x265 3.2]
6
7 %ifnarch %{ix86} %{x8664} x32
8 %undefine       with_asm
9 %endif
10
11 Summary:        H.265/HEVC video encoder
12 Summary(pl.UTF-8):      Koder obrazu H.265/HEVC
13 Name:           x265
14 Version:        3.2.1
15 Release:        1
16 License:        GPL v2+
17 Group:          Libraries
18 Source0:        https://download.videolan.org/videolan/x265/%{name}_%{version}.tar.gz
19 # Source0-md5:  94808045a34d88a857e5eaf3f68f4bca
20 Patch0:         %{name}-opt.patch
21 Patch1:         %{name}-x32.patch
22 URL:            http://x265.org/
23 BuildRequires:  cmake >= 2.8.11
24 BuildRequires:  libstdc++-devel >= 6:4.8
25 BuildRequires:  numactl-devel >= 2
26 BuildRequires:  rpmbuild(macros) >= 1.605
27 %{?with_asm:BuildRequires:      nasm >= 2.13.0}
28 %{?with_vmaf:BuildRequires:     vmaf-devel}
29 Requires:       libx265 = %{version}-%{release}
30 # see CMakeLists.txt, more is probably possible
31 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} ppc64 ppc64le aarch64
32 # needs 64-bit atomic compare and swap
33 ExcludeArch:    i386 i486
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 H.265/HEVC video encoder.
38
39 %description -l pl.UTF-8
40 Koder obrazu H.265/HEVC.
41
42 %package -n libx265
43 Summary:        H.265/HEVC video encoder library
44 Summary(pl.UTF-8):      Biblioteka kodowania obrazu H.265/HEVC
45 Group:          Libraries
46
47 %description -n libx265
48 H.265/HEVC video encoder library.
49
50 %description -n libx265 -l pl.UTF-8
51 Biblioteka kodowania obrazu H.265/HEVC.
52
53 %package -n libx265-devel
54 Summary:        Header files for x265 library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x265
56 Group:          Development/Libraries
57 Requires:       libstdc++-devel >= 6:4.8
58 Requires:       libx265 = %{version}-%{release}
59 Requires:       numactl-devel >= 2
60
61 %description -n libx265-devel
62 Header files for x265 library.
63
64 %description -n libx265-devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki x265.
66
67 %package -n libx265-static
68 Summary:        Static x265 library
69 Summary(pl.UTF-8):      Statyczna biblioteka x265
70 Group:          Development/Libraries
71 Requires:       libx265-devel = %{version}-%{release}
72
73 %description -n libx265-static
74 Static x265 library.
75
76 %description -n libx265-static -l pl.UTF-8
77 Statyczna biblioteka x265.
78
79 %prep
80 %setup -q -n %{name}_%{version}
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 install -d source/build
86 cd source/build
87 %cmake .. \
88         -DENABLE_ASSEMBLY=%{!?with_asm:OFF}%{?with_asm:ON} \
89         -DENABLE_HDR10_PLUS=ON \
90         %{?with_vmaf:-DENABLE_LIBVMAF=ON} \
91         -DENABLE_SHARED=ON \
92         -DLIB_INSTALL_DIR=%{_lib}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -C source/build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -n libx265 -p /sbin/ldconfig
106 %postun -n libx265 -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc doc/reST/cli.rst
111 %attr(755,root,root) %{_bindir}/x265
112
113 %files -n libx265
114 %defattr(644,root,root,755)
115 %doc doc/reST/introduction.rst
116 %attr(755,root,root) %{_libdir}/libx265.so.179
117 %attr(755,root,root) %{_libdir}/libhdr10plus.so
118
119 %files -n libx265-devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libx265.so
122 %{_includedir}/hdr10plus.h
123 %{_includedir}/x265.h
124 %{_includedir}/x265_config.h
125 %{_pkgconfigdir}/x265.pc
126
127 %files -n libx265-static
128 %defattr(644,root,root,755)
129 %{_libdir}/libhdr10plus.a
130 %{_libdir}/libx265.a
This page took 0.066074 seconds and 3 git commands to generate.