]> git.pld-linux.org Git - packages/x265.git/blob - x265.spec
- updated to 3.2 (ABI 179)
[packages/x265.git] / x265.spec
1 # TODO: vmaf
2 #
3 # Conditional build:
4 %bcond_without  asm     # x86 assembler
5 %bcond_with     vmaf    # VMAF support [not ready for vmaf-1.3.x as of x265 3.2]
6
7 %ifnarch %{ix86} %{x8664} x32
8 %undefine       with_asm
9 %endif
10
11 Summary:        H.265/HEVC video encoder
12 Summary(pl.UTF-8):      Koder obrazu H.265/HEVC
13 Name:           x265
14 Version:        3.2
15 Release:        1
16 License:        GPL v2+
17 Group:          Libraries
18 # also at https://bitbucket.org/multicoreware/x265/downloads
19 Source0:        https://download.videolan.org/videolan/x265/%{name}_%{version}.tar.gz
20 # Source0-md5:  374e6359a00d17fd82195c02c341c861
21 Patch0:         %{name}-opt.patch
22 Patch1:         %{name}-x32.patch
23 URL:            http://x265.org/
24 BuildRequires:  cmake >= 2.8.11
25 BuildRequires:  libstdc++-devel >= 6:4.8
26 BuildRequires:  numactl-devel >= 2
27 BuildRequires:  rpmbuild(macros) >= 1.605
28 %{?with_asm:BuildRequires:      nasm >= 2.13.0}
29 %{?with_vmaf:BuildRequires:     vmaf-devel}
30 Requires:       libx265 = %{version}-%{release}
31 # see CMakeLists.txt, more is probably possible
32 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} ppc64 ppc64le
33 # needs 64-bit atomic compare and swap
34 ExcludeArch:    i386 i486
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 H.265/HEVC video encoder.
39
40 %description -l pl.UTF-8
41 Koder obrazu H.265/HEVC.
42
43 %package -n libx265
44 Summary:        H.265/HEVC video encoder library
45 Summary(pl.UTF-8):      Biblioteka kodowania obrazu H.265/HEVC
46 Group:          Libraries
47
48 %description -n libx265
49 H.265/HEVC video encoder library.
50
51 %description -n libx265 -l pl.UTF-8
52 Biblioteka kodowania obrazu H.265/HEVC.
53
54 %package -n libx265-devel
55 Summary:        Header files for x265 library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x265
57 Group:          Development/Libraries
58 Requires:       libstdc++-devel >= 6:4.8
59 Requires:       libx265 = %{version}-%{release}
60 Requires:       numactl-devel >= 2
61
62 %description -n libx265-devel
63 Header files for x265 library.
64
65 %description -n libx265-devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki x265.
67
68 %package -n libx265-static
69 Summary:        Static x265 library
70 Summary(pl.UTF-8):      Statyczna biblioteka x265
71 Group:          Development/Libraries
72 Requires:       libx265-devel = %{version}-%{release}
73
74 %description -n libx265-static
75 Static x265 library.
76
77 %description -n libx265-static -l pl.UTF-8
78 Statyczna biblioteka x265.
79
80 %prep
81 %setup -q -n %{name}_%{version}
82 %patch0 -p1
83 %patch1 -p1
84
85 %build
86 install -d source/build
87 cd source/build
88 %cmake .. \
89         -DENABLE_ASSEMBLY=%{!?with_asm:OFF}%{?with_asm:ON} \
90         -DENABLE_HDR10_PLUS=ON \
91         %{?with_vmaf:-DENABLE_LIBVMAF=ON} \
92         -DENABLE_SHARED=ON \
93         -DLIB_INSTALL_DIR=%{_lib}
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C source/build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -n libx265 -p /sbin/ldconfig
107 %postun -n libx265 -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc doc/reST/cli.rst
112 %attr(755,root,root) %{_bindir}/x265
113
114 %files -n libx265
115 %defattr(644,root,root,755)
116 %doc doc/reST/introduction.rst
117 %attr(755,root,root) %{_libdir}/libx265.so.179
118 %attr(755,root,root) %{_libdir}/libhdr10plus.so
119
120 %files -n libx265-devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libx265.so
123 %{_includedir}/hdr10plus.h
124 %{_includedir}/x265.h
125 %{_includedir}/x265_config.h
126 %{_pkgconfigdir}/x265.pc
127
128 %files -n libx265-static
129 %defattr(644,root,root,755)
130 %{_libdir}/libhdr10plus.a
131 %{_libdir}/libx265.a
This page took 0.060503 seconds and 3 git commands to generate.