]> git.pld-linux.org Git - packages/x265.git/blob - x265.spec
002d44fe0be4166d21b5555bbca1ac025828b546
[packages/x265.git] / x265.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4
5 %ifnarch %{ix86} %{x8664} x32
6 %undefine       with_asm
7 %endif
8
9 Summary:        H.265/HEVC video encoder
10 Summary(pl.UTF-8):      Koder obrazu H.265/HEVC
11 Name:           x265
12 Version:        2.6
13 Release:        1
14 License:        GPL v2+
15 Group:          Libraries
16 # also at https://bitbucket.org/multicoreware/x265/downloads
17 Source0:        http://ftp.videolan.org/pub/videolan/x265/%{name}_%{version}.tar.gz
18 # Source0-md5:  4d318be1f19b58985432a144bd054572
19 Patch0:         %{name}-opt.patch
20 Patch1:         %{name}-x32.patch
21 URL:            http://x265.org/
22 BuildRequires:  cmake >= 2.8.11
23 BuildRequires:  libstdc++-devel >= 6:4.8
24 BuildRequires:  numactl-devel >= 2
25 BuildRequires:  rpmbuild(macros) >= 1.605
26 %{?with_asm:BuildRequires:      yasm >= 1.2.0}
27 Requires:       libx265 = %{version}-%{release}
28 # see CMakeLists.txt, more is probably possible
29 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} ppc64 ppc64le
30 # needs 64-bit atomic compare and swap
31 ExcludeArch:    i386 i486
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 H.265/HEVC video encoder.
36
37 %description -l pl.UTF-8
38 Koder obrazu H.265/HEVC.
39
40 %package -n libx265
41 Summary:        H.265/HEVC video encoder library
42 Summary(pl.UTF-8):      Biblioteka kodowania obrazu H.265/HEVC
43 Group:          Libraries
44
45 %description -n libx265
46 H.265/HEVC video encoder library.
47
48 %description -n libx265 -l pl.UTF-8
49 Biblioteka kodowania obrazu H.265/HEVC.
50
51 %package -n libx265-devel
52 Summary:        Header files for x265 library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x265
54 Group:          Development/Libraries
55 Requires:       libstdc++-devel >= 6:4.8
56 Requires:       libx265 = %{version}-%{release}
57 Requires:       numactl-devel >= 2
58
59 %description -n libx265-devel
60 Header files for x265 library.
61
62 %description -n libx265-devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki x265.
64
65 %package -n libx265-static
66 Summary:        Static x265 library
67 Summary(pl.UTF-8):      Statyczna biblioteka x265
68 Group:          Development/Libraries
69 Requires:       libx265-devel = %{version}-%{release}
70
71 %description -n libx265-static
72 Static x265 library.
73
74 %description -n libx265-static -l pl.UTF-8
75 Statyczna biblioteka x265.
76
77 %prep
78 %setup -q -n %{name}_v%{version}
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 install -d source/build
84 cd source/build
85 %cmake .. \
86         -DENABLE_ASSEMBLY=%{!?with_asm:OFF}%{?with_asm:ON} \
87         -DENABLE_HDR10_PLUS=ON \
88         -DENABLE_SHARED=ON \
89         -DLIB_INSTALL_DIR=%{_lib}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} -C source/build install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -n libx265 -p /sbin/ldconfig
102 %postun -n libx265 -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc doc/reST/cli.rst
107 %attr(755,root,root) %{_bindir}/x265
108
109 %files -n libx265
110 %defattr(644,root,root,755)
111 %doc doc/reST/introduction.rst
112 %attr(755,root,root) %{_libdir}/libx265.so.146
113 %attr(755,root,root) %{_libdir}/libhdr10plus.so
114
115 %files -n libx265-devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libx265.so
118 %{_includedir}/hdr10plus.h
119 %{_includedir}/x265.h
120 %{_includedir}/x265_config.h
121 %{_pkgconfigdir}/x265.pc
122
123 %files -n libx265-static
124 %defattr(644,root,root,755)
125 %{_libdir}/libhdr10plus.a
126 %{_libdir}/libx265.a
This page took 0.050489 seconds and 2 git commands to generate.