]> git.pld-linux.org Git - packages/wrapland.git/blob - wrapland.spec
ee2f2edb6f72a290f5a6d4f43b12fdc9fb8906c8
[packages/wrapland.git] / wrapland.spec
1 %define         kdeplasmaver    5.23.4
2 %define         kf_ver          5.78
3 %define         qt_ver          5.15.0
4 %define         kpname          wrapland
5 #
6 Summary:        Qt/C++ library wrapping libwayland
7 Name:           %{kpname}
8 Version:        0.523.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        https://gitlab.com/kwinft/%{kpname}/-/archive/%{kpname}@%{version}/%{name}-%{name}@%{version}.tar.bz2
13 # Source0-md5:  2f9c21645be7a8e968afd00abf25f92e
14 URL:            http://www.kde.org/
15 BuildRequires:  EGL-devel
16 BuildRequires:  Qt5Concurrent-devel
17 BuildRequires:  Qt5Gui-devel
18 BuildRequires:  Qt5Test-devel
19 BuildRequires:  kf5-extra-cmake-modules >= 5.66.0
20 BuildRequires:  wayland-devel >= 1.18
21 BuildRequires:  wayland-protocols >= 1.22
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         qt5dir          %{_libdir}/qt5
25
26 %description
27 Wrapland is a Qt/C++ library that wraps and mediates the libwayland
28 client and server API for its consumers. Wrapland is an independent
29 part of the [KWinFT project][kwinft-project] with the KWinFT window
30 manager being Wrapland's first and most prominent user.
31
32 %package devel
33 Summary:        Header files for %{kpname} development
34 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
35 Group:          X11/Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for %{kpname} development.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe dla programistów używających %{kpname}.
43
44 %prep
45 %setup -q -n %{name}-%{name}@%{version}
46
47 %build
48 install -d build
49
50 cd build
51 %cmake -G Ninja \
52         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
53         -DHTML_INSTALL_DIR=%{_kdedocdir} \
54         ../
55 %ninja_build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %ninja_install -C build
60 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,sr@latin}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %{_libdir}/libWraplandServer.so.0.*.*
71 %ghost %{_libdir}/libWraplandServer.so.0
72 %{_libdir}/libWraplandClient.so.0.*.*
73 %ghost %{_libdir}/libWraplandClient.so.0
74 %attr(755,root,root) %{_prefix}/libexec/org-kde-kf5-wrapland-testserver
75 %{_datadir}/qlogging-categories5/org_kde_wrapland.categories
76
77 %files devel
78 %defattr(644,root,root,755)
79 %{_libdir}/cmake/Wrapland
80 %{_includedir}/wrapland_version.h
81 %{_libdir}/libWraplandServer.so
82 %{_libdir}/libWraplandClient.so
83 %{_includedir}/Wrapland
This page took 0.023838 seconds and 2 git commands to generate.