]> git.pld-linux.org Git - packages/wpa_supplicant.git/blob - wpa_supplicant.spec
- up to 0.6.6
[packages/wpa_supplicant.git] / wpa_supplicant.spec
1 # TODO:
2 # - wpa_gui can be built with qt4 - bcond?
3 # - icon for wpa_gui
4 # - reverse madwifi bcond when appropriate packages will be available on ftp
5 #       / as of madwifi-ng > r1499 and kernel > 2.6.14 wext driver could be
6 #       used instead of madwifi - so madwifi bcond will become obsolete soon /
7 #
8 # Conditional build
9 %bcond_without  dbus            # don't build D-BUS control interface
10 %bcond_without  gui             # don't build gui
11 %bcond_with     madwifi         # with madwifi support
12 #
13 # sync archlist with madwifi.spec
14 %ifnarch %{x8664} arm %{ix86} mips ppc xscale
15 %undefine       with_madwifi
16 %endif
17 #
18 Summary:        Linux WPA/WPA2/RSN/IEEE 802.1X supplicant
19 Summary(pl.UTF-8):      Suplikant WPA/WPA2/RSN/IEEE 802.1X dla Linuksa
20 Name:           wpa_supplicant
21 Version:        0.6.6
22 Release:        1
23 License:        GPL v2
24 Group:          Networking
25 Source0:        http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
26 # Source0-md5:  cd0b386bdf4b0b3b01516e36cb6977d1
27 Source1:        %{name}.config
28 Source2:        %{name}-wpa_gui.desktop
29 Source3:        %{name}-dbus.service
30 Patch0:         %{name}-makefile.patch
31 Patch1:         %{name}-0.4.7_dscape-02.patch
32 Patch2:         %{name}-OPTCFLAGS.patch
33 URL:            http://hostap.epitest.fi/wpa_supplicant/
34 %{?with_dbus:BuildRequires:     dbus-devel}
35 %{?with_madwifi:BuildRequires:  madwifi-devel}
36 BuildRequires:  ncurses-devel
37 BuildRequires:  openssl-devel
38 BuildRequires:  pkgconfig
39 %if %{with gui}
40 BuildRequires:  Qt3Support-devel
41 BuildRequires:  QtGui-devel
42 BuildRequires:  qt4-build
43 BuildRequires:  qt4-qmake
44 %endif
45 BuildRequires:  readline-devel
46 Requires:       rc-scripts >= 0.4.1.24
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
51 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA component that is
52 used in the client stations. It implements key negotiation with a WPA
53 Authenticator and it controls the roaming and IEEE 802.11
54 authentication/association of the wlan driver.
55
56 wpa_supplicant is designed to be a "daemon" program that runs in the
57 background and acts as the backend component controlling the wireless
58 connection. Support for separate frontend programs is included and an
59 example text-based frontend, wpa_cli, is included with wpa_supplicant.
60
61 Supported WPA/IEEE 802.11i features:
62 - WPA-PSK ("WPA-Personal")
63 - WPA with EAP (e.g., with RADIUS authentication server)
64   ("WPA-Enterprise") (currently, EAP-TLS and EAP-PEAP/MSCHAPv2 are
65   supported with an integrated IEEE 802.1X Supplicant; other EAP types
66   may be used with an external program, Xsupplicant)
67 - key management for CCMP, TKIP, WEP104, WEP40
68 - RSN/WPA2 (IEEE 802.11i)
69
70 %description -l pl.UTF-8
71 wpa_supplicant to suplikant WPA z obsługą WPA oraz WPA2 (IEEE 802.11i
72 / RSN). Suplikant to element IEEE 802.1X/WPA używany na stacjach
73 klienckich. Implementuje negocjację kluczy z elementem
74 uwierzytelniającym WPA (WPA Authenticator) i kontroluje roaming oraz
75 uwierzytelnianie/kojarzenie sterownika wlan zgodnie z IEEE 802.11.
76
77 wpa_supplicant jest zaprojektowany tak, by był wspólnym programem
78 działającym w tle i działa jako element backendu sterujący połączeniem
79 bezprzewodowym. Dostępna jest obsługa oddzielnych programów
80 frontendowych, a w pakiecie wpa_supplicant załączony jest prosty
81 frontend tekstowy - wpa_cli.
82
83 Obsługiwane możliwości WPA/IEEE 802.11i:
84 - WPA-PSK ("WPA-Personal")
85 - WPA z EAP (np. z serwerem uwierzytleniającym RADIUS)
86   ("WPA-Enterprise") (aktualnie EAP-TLS i EAP-PEAP/MSCHAPv2 są
87   obsługiwane przez załączonego suplikanta IEEE 802.1X; inne rodzaje EAP
88   mogą być używane przez zewnętrzny program - Xsupplicant)
89 - zarządzanie kluczy dla CCMP, TKIP, WEP104, WEP40
90 - RSN/WPA2 (IEEE 802.11i)
91
92 %package -n wpa_gui
93 Summary:        Linux WPA/WPA2/RSN/IEEE 802.1X supplicant GUI
94 Summary(pl.UTF-8):      Graficzny interfejs suplikanta WPA/WPA2/RSN/IEEE 802.1X dla Linuksa
95 Group:          X11/Applications/Networking
96 Requires:       %{name} = %{version}-%{release}
97
98 %description -n wpa_gui
99 Linux WPA/WPA2/RSN/IEEE 802.1X supplicant GUI.
100
101 %description -n wpa_gui -l pl.UTF-8
102 Graficzny interfejs suplikanta WPA/WPA2/RSN/IEEE 802.1X dla Linuksa.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 install %{SOURCE1} wpa_supplicant/.config
111
112 %if %{with dbus}
113 echo 'CONFIG_CTRL_IFACE_DBUS=y' >> wpa_supplicant/.config
114 %endif
115
116 %if %{with madwifi}
117 echo 'CONFIG_DRIVER_MADWIFI=y' >> wpa_supplicant/.config
118 %endif
119
120 %build
121 %{__make} -C wpa_supplicant \
122         CC="%{__cc}" \
123         LDFLAGS="%{rpmldflags}" \
124         OPTCFLAGS="%{rpmcflags}"
125
126 # eapol_test:
127 %{__make} -C wpa_supplicant eapol_test \
128         CC="%{__cc}" \
129         LDFLAGS="%{rpmldflags}" \
130         OPTCFLAGS="%{rpmcflags}"
131
132 %if %{with gui}
133 cd wpa_supplicant/wpa_gui-qt4
134 qmake-qt4 -o Makefile wpa_gui.pro
135 cd ../..
136 %{__make} -C wpa_supplicant wpa_gui-qt4 \
137         QTDIR=%{_libdir}/qt4 \
138         UIC=%{_bindir}/uic-qt4 \
139         CC="%{__cc}" \
140         CXX="%{__cxx}" \
141         LDFLAGS="%{rpmldflags}" \
142         OPTCFLAGS="%{rpmcflags}"
143 %endif
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT{%{_mandir}/man{5,8},%{_bindir},%{_desktopdir},/var/run/%{name}}
148
149 %{__make} -C wpa_supplicant install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 install wpa_supplicant/doc/docbook/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
153 install wpa_supplicant/doc/docbook/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
154
155 %if %{with dbus}
156 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/dbus-1/system.d,%{_datadir}/dbus-1/system-services}
157 install wpa_supplicant/dbus-wpa_supplicant.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
158 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
159 %endif
160
161 %if %{with gui}
162 install wpa_supplicant/wpa_gui-qt4/wpa_gui $RPM_BUILD_ROOT%{_bindir}
163 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/wpa_gui.desktop
164 %endif
165
166 install wpa_supplicant/eapol_test $RPM_BUILD_ROOT%{_bindir}
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %files
172 %defattr(644,root,root,755)
173 %doc wpa_supplicant/{ChangeLog,README,eap_testing.txt,todo.txt}
174 %doc wpa_supplicant/{*wpa_supplicant.conf,examples}
175 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
176 %attr(755,root,root) %{_sbindir}/*
177 %attr(755,root,root) %{_bindir}/eapol_test
178 %attr(750,root,root) %ghost %dir /var/run/%{name}
179 %{_mandir}/man[58]/*
180 %if %{with dbus}
181 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/wpa_supplicant.conf
182 %{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
183 %endif
184
185 %if %{with gui}
186 %files -n wpa_gui
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/wpa_gui
189 %{_desktopdir}/wpa_gui.desktop
190 %endif
This page took 0.105563 seconds and 3 git commands to generate.