]> git.pld-linux.org Git - packages/wlcs.git/blob - wlcs.spec
- cleanup
[packages/wlcs.git] / wlcs.spec
1 #
2 # Conditional build:
3 %bcond_without  asan    # Address Sanitizer module
4 %bcond_without  tsan    # Thread Sanitizer module
5 %bcond_without  ubsan   # Undefined Behaviour Sanitizer module
6
7 %ifnarch %{ix86} %{x8664} x32 %{arm} aarch64 ppc ppc64 s390 s390x sparc sparcv9 sparc64
8 %undefine       with_asan
9 %undefine       with_ubsan
10 %endif
11 %ifnarch %{x8664} aarch64 ppc64 s390x
12 %undefine       with_tsan
13 %endif
14 Summary:        Wayland Conformance Test Suite
15 Summary(pl.UTF-8):      Wayland Conformance Test Suite - testy zgodności Waylanda
16 Name:           wlcs
17 Version:        1.5.0
18 Release:        2
19 License:        GPL v3
20 Group:          Libraries
21 #Source0Download: https://github.com/MirServer/wlcs/releases
22 Source0:        https://github.com/MirServer/wlcs/archive/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  24c479147fccb07de141b282ea630770
24 URL:            https://github.com/MirServer/wlcs
25 BuildRequires:  boost-devel
26 BuildRequires:  cmake >= 3.5
27 BuildRequires:  gmock-devel
28 BuildRequires:  gtest-devel
29 %{?with_asan:BuildRequires:     libasan-devel}
30 %{?with_tsan:BuildRequires:     libtsan-devel}
31 %{?with_ubsan:BuildRequires:    libubsan-devel}
32 BuildRequires:  pkgconfig
33 # client, server, scanner
34 BuildRequires:  wayland-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Wayland Conformance Test Suite.
39
40 %description -l pl.UTF-8
41 Wayland Conformance Test Suite - testy zgodności Waylanda.
42
43 %package devel
44 Summary:        Header files for wlcs
45 Summary(pl.UTF-8):      Pliki nagłówkowe wlcs
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       wayland-devel
49
50 %description devel
51 Header files for wlcs.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe wlcs.
55
56 %prep
57 %setup -q
58
59 %build
60 install -d build
61 cd build
62 %cmake .. \
63         %{cmake_on_off asan WLCS_BUILD_ASAN} \
64         %{cmake_on_off tsan WLCS_BUILD_TSAN} \
65         %{cmake_on_off ubsan WLCS_BUILD_UBSAN}
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README.rst
81 %dir %{_libexecdir}/wlcs
82 %attr(755,root,root) %{_libexecdir}/wlcs/wlcs*
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_includedir}/wlcs
87 %{_pkgconfigdir}/wlcs.pc
This page took 0.188528 seconds and 3 git commands to generate.