]> git.pld-linux.org Git - packages/wlc.git/blob - wlc.spec
060283108e3431ff4285a5908be409969288d27e
[packages/wlc.git] / wlc.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module          wlc
6 %define         egg_name        wlc
7 %define         pypi_name       wlc
8 Summary:        Weblate commandline client using Weblate's REST API
9 Name:           wlc
10 Version:        0.5
11 Release:        1
12 License:        GPL v3+
13 Group:          Libraries/Python
14 Source0:        https://files.pythonhosted.org/packages/source/w/%{module}/%{module}-%{version}.tar.gz
15 # Source0-md5:  15a3a221938aa4ef75698aed72ffd0be
16 URL:            https://weblate.org/
17 BuildRequires:  python3-devel
18 BuildRequires:  python3-setuptools
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 Requires:       python3-pyxdg
22 Requires:       python3-setuptools
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A command line utility for Weblate, translation tool with tight
28 version control integration
29
30 %prep
31 %setup -q -n %{module}-%{version}
32
33 # Remove bundled egg-info
34 %{__rm} -r %{module}.egg-info
35
36 %build
37 %py3_build %{?with_tests:test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %py3_install
42
43 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/%{module}/test_*
44 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/%{module}/__pycache__/test_*
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README.rst
52 %attr(755,root,root) %{_bindir}/wlc
53 %{py3_sitescriptdir}/%{pypi_name}
54 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.03804 seconds and 2 git commands to generate.