]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
- with gui cleanups, portaudio-devel no longer BR-ed
[packages/wireshark.git] / wireshark.spec
1 # TODO
2 # - use policykit to gain root
3 # - use %caps when rpm supports it: %attr(750,root,wireshark) %caps(cap_net_raw,cap_net_admin=eip) %{_sbindir}/dumpcap
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # Kerberos V support
7 %bcond_without  snmp            # SNMP support
8 %bcond_without  gui             # without QT GUI
9
10 Summary:        Network traffic and protocol analyzer
11 Summary(es.UTF-8):      Analizador de tráfico de red
12 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych
13 Summary(pt_BR.UTF-8):   Analisador de tráfego de rede
14 Summary(ru.UTF-8):      Анализатор сетевого траффика
15 Summary(uk.UTF-8):      Аналізатор мережевого трафіку
16 Name:           wireshark
17 Version:        3.0.0
18 Release:        0.1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        https://www.wireshark.org/download/src/%{name}-%{version}.tar.xz
22 # Source0-md5:  258d62ac7434d126dc497303c8f7961b
23 URL:            https://www.wireshark.org/
24 BuildRequires:  GeoIP-devel
25 BuildRequires:  asciidoc
26 BuildRequires:  bcg729-devel
27 BuildRequires:  bison
28 BuildRequires:  cmake
29 BuildRequires:  c-ares-devel >= 1.5.0
30 BuildRequires:  doxygen
31 BuildRequires:  flex
32 BuildRequires:  gcc >= 5:3.2
33 BuildRequires:  glib2-devel >= 1:2.32
34 BuildRequires:  gnutls-devel >= 3.2.0
35 %{?with_kerberos5:BuildRequires:        heimdal-devel}
36 BuildRequires:  libcap-devel
37 BuildRequires:  libgcrypt-devel >= 1.4.2
38 BuildRequires:  libmaxminddb-devel
39 BuildRequires:  libnl-devel >= 3.2
40 BuildRequires:  libpcap-devel >= 2:1.0.0-4
41 BuildRequires:  libssh-devel >= 0.6.0
42 BuildRequires:  libsmi-devel
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 2:2.2.2
45 BuildRequires:  libxml2-devel >= 2.0
46 BuildRequires:  libxslt-progs
47 BuildRequires:  lua52-devel
48 BuildRequires:  lz4-devel
49 %{?with_snmp:BuildRequires:     net-snmp-devel}
50 BuildRequires:  nghttp2-devel
51 BuildRequires:  perl-tools-pod
52 BuildRequires:  pkgconfig >= 1:0.7
53 BuildRequires:  python3 >= 1:3.4
54 BuildRequires:  rpmbuild(macros) >= 1.527
55 %{?with_gui:BuildRequires:      sbc-devel >= 1.0}
56 %{?with_gui:BuildRequires:      speexdsp-devel}
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  snappy-devel
59 BuildRequires:  spandsp-devel
60 BuildRequires:  tar >= 1:1.22
61 BuildRequires:  w3m
62 BuildRequires:  xz
63 BuildRequires:  zlib-devel
64 %if %{with gui}
65 BuildRequires:  Qt5Core-devel >= 5.2
66 BuildRequires:  Qt5Multimedia-devel >= 5.2
67 BuildRequires:  Qt5PrintSupport-devel >= 5.2
68 BuildRequires:  Qt5Widgets-devel >= 5.2
69 BuildRequires:  libstdc++-devel >= 5
70 BuildRequires:  qt5-build >= 5.2
71 BuildRequires:  qt5-linguist >= 5.2
72 %endif
73 Requires:       %{name}-gui-common = %{version}-%{release}
74 Requires:       gdk-pixbuf2 >= 2.26
75 Suggests:       xdg-utils
76 Provides:       ethereal
77 Provides:       ethereal-gnome
78 Obsoletes:      ethereal
79 Obsoletes:      ethereal-gnome
80 Obsoletes:      wireshark-gui-common
81 Obsoletes:      wireshark-qt
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 Wireshark is the name for powerful graphical network sniffer, traffic
86 and protocol analyzer based on QT and libpcap libraries. It lets you
87 capture and interactively browse the contents of network frames with
88 vast knowledge of more than 100 network protocols. Wireshark has
89 severeal useful features, including a rich display filter language,
90 the ability to view the ASCII contents of a TCP connection and plug-in
91 capabilities.
92
93 %description -l es.UTF-8
94 Analizador de tráfico de red.
95
96 %description -l pl.UTF-8
97 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
98 protokołów sieciowych opartym na bibliotekach QT oraz libpcap.
99 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
100 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
101 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
102 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
103 wtyczek (plug-ins).
104
105 %description -l pt_BR.UTF-8
106 O Wireshark é um analisador de protocolo de rede baseado no QT.
107
108 %description -l ru.UTF-8
109 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
110 базируется на QT и libpcap.
111
112 %description -l uk.UTF-8
113 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
114 базується на QT та libpcap.
115
116 %package common
117 Summary:        Network traffic and protocol analyzer - common files
118 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych - wspólne pliki
119 Group:          Networking
120 Requires:       %{name}-libs = %{version}-%{release}
121 Requires:       gnutls >= 3.1.10
122 Requires:       libpcap >= 0.4
123 Requires:       libssh >= 0.6.0
124 Provides:       ethereal-common
125 Provides:       group(wireshark)
126 Provides:       wireshark-tools
127 Obsoletes:      ethereal-common
128 Obsoletes:      wireshark-tools
129 Requires(post,postun):  /sbin/setcap
130
131 %description common
132 Wireshark is the name for powerful graphical network sniffer, traffic
133 and protocol analyzer based on QT and libpcap libraries. It lets you
134 capture and interactively browse the contents of network frames with
135 vast knowledge of more than 100 network protocols. Wireshark has
136 severeal useful features, including a rich display filter language,
137 the ability to view the ASCII contents of a TCP connection and plug-in
138 capabilities.
139
140 This package provides the shared library, plugins, data and a set of
141 tools for manipulating capture files. It contains:
142 - capinfos - prints informatio about binary capture files,
143 - captype - prints the file types of capture files,
144 - dftest - shows display filter byte-code,
145 - dumpcap - dumps network traffic to a file,
146 - editcap - edit and/or translate the format of capture files,
147 - mergecap - merges two capture files into one,
148 - randpkt - generates libpcap trace file full of random packets,
149 - rawshark - dumps and analyzes raw libpcap data,
150 - text2cap - generate a capture file from an ASCII hexdump of packets.
151
152 %description common -l es.UTF-8
153 Analizador de tráfico de red.
154
155 %description common -l pl.UTF-8
156 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
157 protokołów sieciowych opartym na bibliotekach QT oraz libpcap.
158 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
159 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
160 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
161 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
162 wtyczek (plug-ins).
163
164 Ten pakiet ten zawiera bibliotekę współdzieloną, wtyczki, dane oraz
165 zestaw narzędzi do obróbki plików z przechwyconymi pakietami,
166 obejmujący:
167 - capinfos - do wyświetlania informacji o binarnych plikach zrzutu,
168 - captype - do wyświetlania rodzaju plików zrzutu,
169 - dftest - do pokazywania bajtkodu filtrów wyświetlania,
170 - dumpcap - do zrzucania ruchu sieciowego do pliku,
171 - editcap - do edycji plików i tłumaczenia ich na inne formaty,
172 - mergecap - do łączenia dwóch plików w jeden,
173 - randpkt - do generowania plikow cap z losowymi danymi,
174 - rawshark - do obróbki plików cap,
175 - text2cap - do generowania pliku cap z szesnastkowego zrzutu ASCII
176   pakietów.
177
178 %description common -l pt_BR.UTF-8
179 O Wireshark é um analisador de protocolo de rede baseado no QT.
180
181 %description common -l ru.UTF-8
182 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
183 базируется на QT и libpcap.
184
185 %description common -l uk.UTF-8
186 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
187 базується на QT та libpcap.
188
189 %package -n twireshark
190 Summary:        Text-mode network traffic and protocol analyzer
191 Summary(pl.UTF-8):      Tekstowy analizator ruchu i protokołów sieciowych
192 Summary(pt_BR.UTF-8):   Analisador modo texto de tráfego de rede (sniffer)
193 Group:          Networking
194 Requires:       %{name}-common = %{version}-%{release}
195 Requires:       libpcap >= 0.4
196 Provides:       tethereal
197 Obsoletes:      tethereal
198
199 %description -n twireshark
200 Twireshark is a network protocol analyzer. It lets you capture packet
201 data from a live network, or read packets from a previously saved
202 capture file, either printing a decoded form of those packets to the
203 standard output or writing the packets to a file. Twireshark's native
204 capture file format is libpcap format, which is also the format used
205 by tcpdump and various other tools.
206
207 %description -n twireshark -l pl.UTF-8
208 Twireshark jest analizatorem protokołów sieciowych. Pozwala na
209 przechwytywanie pakietów z sieci lub wczytywanie danych z pliku.
210 Zdekodowany wynik (a twireshark zna ponad 100 rozmaitych protokołów
211 sieciowych!) jest wyświetlony na ekranie. Natywnym formatem plików
212 tetherala jest format libpcap, tak więc jest on kompatybilny z
213 tcpdumpem i innymi podobnymi narzędziami.
214
215 %description -n twireshark -l pt_BR.UTF-8
216 Esta é uma versão para modo texto do analisador de tráfego de rede
217 Wireshark.
218
219 %package libs
220 Summary:        Wireshark packet capture and dissection libraries
221 Summary(pl.UTF-8):      Biblioteki Wiresharka do przechwytywania i sekcji pakietów
222 Group:          Libraries
223 Requires:       glib2 >= 1:2.32
224 Requires:       libgcrypt >= 1.4.2
225 Requires:       libnl >= 3.2
226 Obsoletes:      libwiretap < 2.4.0
227
228 %description libs
229 Wireshark packet capture and dissection libraries.
230
231 %description libs -l pl.UTF-8
232 Biblioteki Wiresharka do przechwytywania i sekcji pakietów.
233
234 %package devel
235 Summary:        Header files for Wireshark libraries
236 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Wiresharka
237 Group:          Development/Libraries
238 Requires:       %{name}-libs = %{version}-%{release}
239 Requires:       glib2-devel >= 1:2.32
240 Requires:       libgcrypt-devel >= 1.4.2
241 Requires:       libnl-devel >= 3.2
242 Obsoletes:      libwiretap-devel < 2.4.0
243
244 %description devel
245 Header files for Wireshark libraries.
246
247 %description devel -l pl.UTF-8
248 Pliki nagłówkowe bibliotek Wiresharka.
249
250 %prep
251 %setup -q
252
253 %build
254 %cmake -G "Unix Makefiles" \
255   -DDISABLE_WERROR=ON \
256   -DBUILD_wireshark=ON \
257   -DENABLE_QT5=ON \
258   -DENABLE_LUA=ON \
259   -DBUILD_mmdbresolve=ON \
260   -DBUILD_randpktdump=ON \
261   -DBUILD_androiddump=ON \
262   -DBUILD_tfshark=OFF \
263   -DBUILD_corbaidl2wrs=ON \
264   -DBUILD_dcerpcidl2wrs=ON \
265   -DBUILD_xxx2deb=ON \
266   -DENABLE_SMI=ON \
267   -DENABLE_PORTAUDIO=ON \
268   -DENABLE_PLUGINS=ON \
269   -DENABLE_NETLINK=ON
270
271 %{__make}
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_includedir}/wireshark}
276
277 %{__make} install \
278         DESTDIR=$RPM_BUILD_ROOT
279
280 cp -p image/wsicon48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
281
282 %{?with_gui:cp -p wireshark.desktop $RPM_BUILD_ROOT%{_desktopdir}/wireshark.desktop}
283
284 # headers (from Fedora, inspired by debian/wireshark-dev.header-files)
285 install -d $RPM_BUILD_ROOT%{_includedir}/wireshark/{epan/{crypt,ftypes,dfilter,dissectors,wmem},wiretap,wsutil}
286 install config.h            $RPM_BUILD_ROOT%{_includedir}/wireshark
287 install cfile.h file.h      $RPM_BUILD_ROOT%{_includedir}/wireshark
288 install ws_diag_control.h   $RPM_BUILD_ROOT%{_includedir}/wireshark
289 install ws_symbol_export.h  $RPM_BUILD_ROOT%{_includedir}/wireshark
290 install epan/*.h            $RPM_BUILD_ROOT%{_includedir}/wireshark/epan
291 install epan/crypt/*.h      $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/crypt
292 install epan/ftypes/*.h     $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/ftypes
293 install epan/dfilter/*.h    $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/dfilter
294 install epan/dissectors/*.h $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/dissectors
295 install epan/wmem/*.h       $RPM_BUILD_ROOT%{_includedir}/wireshark/epan/wmem
296 install wiretap/*.h         $RPM_BUILD_ROOT%{_includedir}/wireshark/wiretap
297 install wsutil/*.h          $RPM_BUILD_ROOT%{_includedir}/wireshark/wsutil
298
299 # plugins *.la are useless - *.so are loaded through gmodule
300 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*/*/*.la
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %pre
306 %update_mime_database
307
308 %postun
309 %update_mime_database
310
311 %pre    common
312 %groupadd -P %{name}-common -g 104 wireshark
313
314 %post   common
315 /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' %{_bindir}/dumpcap
316 exit 0
317
318 %postun common
319 if [ "$1" = "0" ]; then
320         %groupremove wireshark
321 fi
322
323 %post   libs -p /sbin/ldconfig
324 %postun libs -p /sbin/ldconfig
325
326 %if %{with gui}
327 %files
328 %defattr(644,root,root,755)
329 %attr(755,root,root) %{_bindir}/wireshark
330 %{_desktopdir}/wireshark.desktop
331 #%{_datadir}/%{name}
332 %{_datadir}/appdata/wireshark.appdata.xml
333 %{_datadir}/mime/packages/wireshark.xml
334 %{_pixmapsdir}/%{name}.png
335 %{_iconsdir}/hicolor/16x16/apps/%{name}.png
336 %{_iconsdir}/hicolor/16x16/mimetypes/application-%{name}-doc.png
337 %{_iconsdir}/hicolor/24x24/apps/%{name}.png
338 %{_iconsdir}/hicolor/24x24/mimetypes/application-%{name}-doc.png
339 %{_iconsdir}/hicolor/32x32/apps/%{name}.png
340 %{_iconsdir}/hicolor/32x32/mimetypes/application-%{name}-doc.png
341 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
342 %{_iconsdir}/hicolor/48x48/mimetypes/application-%{name}-doc.png
343 %{_iconsdir}/hicolor/64x64/apps/%{name}.png
344 %{_iconsdir}/hicolor/64x64/mimetypes/application-%{name}-doc.png
345 %{_iconsdir}/hicolor/128x128/apps/%{name}.png
346 %{_iconsdir}/hicolor/128x128/mimetypes/application-%{name}-doc.png
347 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
348 %{_iconsdir}/hicolor/256x256/mimetypes/application-%{name}-doc.png
349 %{_iconsdir}/hicolor/scalable/apps/%{name}.svg
350 %{_mandir}/man1/wireshark.1*
351 %endif
352
353 %files common
354 %defattr(644,root,root,755)
355 %doc AUTHORS* ChangeLog NEWS README.md README.linux doc/README.*
356 %dir %{_libdir}/%{name}
357 %dir %{_libdir}/%{name}/extcap
358 %dir %{_libdir}/%{name}/plugins
359 %dir %{_libdir}/%{name}/plugins/3.0
360 %dir %{_libdir}/%{name}/plugins/3.0/codecs
361 %dir %{_libdir}/%{name}/plugins/3.0/epan
362 %dir %{_libdir}/%{name}/plugins/3.0/wiretap
363 %attr(755,root,root) %{_libdir}/%{name}/extcap/androiddump
364 %attr(755,root,root) %{_libdir}/%{name}/extcap/ciscodump
365 %attr(755,root,root) %{_libdir}/%{name}/extcap/dpauxmon
366 %attr(755,root,root) %{_libdir}/%{name}/extcap/randpktdump
367 %attr(755,root,root) %{_libdir}/%{name}/extcap/sshdump
368 %attr(755,root,root) %{_libdir}/%{name}/extcap/sdjournal
369 %attr(755,root,root) %{_libdir}/%{name}/extcap/udpdump
370 %attr(755,root,root) %{_libdir}/%{name}/plugins/3.0/codecs/*.so
371 %attr(755,root,root) %{_libdir}/%{name}/plugins/3.0/epan/*.so
372 %attr(755,root,root) %{_libdir}/%{name}/plugins/3.0/wiretap/*.so
373 %attr(755,root,root) %{_bindir}/capinfos
374 %attr(755,root,root) %{_bindir}/captype
375 #%attr(755,root,root) %{_bindir}/dftest
376 %attr(750,root,wireshark) %{_bindir}/dumpcap
377 %attr(755,root,root) %{_bindir}/editcap
378 %attr(755,root,root) %{_bindir}/idl2wrs
379 %attr(755,root,root) %{_bindir}/mergecap
380 %attr(755,root,root) %{_bindir}/mmdbresolve
381 %attr(755,root,root) %{_bindir}/randpkt
382 %attr(755,root,root) %{_bindir}/rawshark
383 %attr(755,root,root) %{_bindir}/reordercap
384 %attr(755,root,root) %{_bindir}/sharkd
385 %attr(755,root,root) %{_bindir}/text2pcap
386 #%attr(755,root,root) %{_bindir}/tfshark
387 %{_mandir}/man1/androiddump.1*
388 %{_mandir}/man1/capinfos.1*
389 %{_mandir}/man1/captype.1*
390 %{_mandir}/man1/ciscodump.1*
391 %{_mandir}/man1/dftest.1*
392 %{_mandir}/man1/dumpcap.1*
393 %{_mandir}/man1/editcap.1*
394 %{_mandir}/man1/mergecap.1*
395 %{_mandir}/man1/mmdbresolve.1*
396 %{_mandir}/man1/rawshark.1*
397 %{_mandir}/man1/randpkt.1*
398 %{_mandir}/man1/randpktdump.1*
399 %{_mandir}/man1/reordercap.1*
400 %{_mandir}/man1/sshdump.1*
401 %{_mandir}/man1/text2pcap.1*
402 %{_mandir}/man1/udpdump.1*
403 %{_mandir}/man4/extcap.4*
404 %{_mandir}/man4/wireshark-filter.4*
405
406 %files -n twireshark
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_bindir}/tshark
409 %{_mandir}/man1/tshark*.1*
410
411 %files libs
412 %defattr(644,root,root,755)
413 #%doc wiretap/README*
414 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.12
416 %attr(755,root,root) %{_libdir}/libwiretap.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libwiretap.so.9
418 %attr(755,root,root) %{_libdir}/libwscodecs.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libwscodecs.so.2
420 %attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libwsutil.so.10
422
423 %files devel
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/libwireshark.so
426 %attr(755,root,root) %{_libdir}/libwiretap.so
427 %attr(755,root,root) %{_libdir}/libwscodecs.so
428 %attr(755,root,root) %{_libdir}/libwsutil.so
429 #%{_libdir}/libwireshark.la
430 #%{_libdir}/libwiretap.la
431 #%{_libdir}/libwscodecs.la
432 #%{_libdir}/libwsutil.la
433 %{_includedir}/wireshark
434 %{_pkgconfigdir}/wireshark.pc
This page took 0.227114 seconds and 3 git commands to generate.