]> git.pld-linux.org Git - packages/wireshark.git/blob - wireshark.spec
5265791d25640da29e02b49d25a9fc9f428b9a39
[packages/wireshark.git] / wireshark.spec
1 # TODO
2 # - use policykit to gain root
3 # - use %caps when rpm supports it: %attr(750,root,wireshark) %caps(cap_net_raw,cap_net_admin=eip) %{_sbindir}/dumpcap
4 # - think of loosing dependency loop:
5 #   Executing rpm --upgrade -vh --root /...
6 #   error: LOOP:
7 #   error: removing libwiretap-1.2.4-1.i686 "Requires(auto): libwsutil.so.0" from tsort relations.
8 #   error:     libwiretap-1.2.4-1.i686                  Requires(auto): libwsutil.so.0
9 #   error: removing wireshark-common-1.2.4-1.i686 "Requires: libwiretap = 1.2.4-1" from tsort relations.
10 #   error:     wireshark-common-1.2.4-1.i686            Requires: libwiretap = 1.2.4-1
11 #   error: LOOP:
12 #   error: removing libwiretap-1.2.3-1.i686 "Requires: libwiretap = 1.2.3-1" from tsort relations.
13 #   error:     libwiretap-1.2.3-1.i686                  Requires: libwiretap = 1.2.3-1
14 #   error: removing wireshark-common-1.2.3-1.i686 "Requires(auto): libwsutil.so.0" from tsort relations.
15 #   error:     wireshark-common-1.2.3-1.i686            Requires(auto): libwsutil.so.0
16 #
17 # Conditional build:
18 %bcond_without  kerberos5       # build without Kerberos V support
19 %bcond_without  snmp            # build without snmp support
20
21 Summary:        Network traffic and protocol analyzer
22 Summary(es.UTF-8):      Analizador de tráfico de red
23 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych
24 Summary(pt_BR.UTF-8):   Analisador de tráfego de rede
25 Summary(ru.UTF-8):      Анализатор сетевого траффика
26 Summary(uk.UTF-8):      Аналізатор мережевого трафіку
27 Name:           wireshark
28 Version:        1.8.6
29 Release:        1
30 License:        GPL
31 Group:          Networking/Utilities
32 Source0:        http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
33 # Source0-md5:  317361e701936c72f7f18f857059b944
34 Patch0:         %{name}-Werror.patch
35 Patch1:         %{name}-gcc43.patch
36 Patch2:         %{name}-ac.patch
37 Patch3:         %{name}-desktop.patch
38 URL:            http://www.wireshark.org/
39 BuildRequires:  autoconf >= 2.52
40 BuildRequires:  automake
41 BuildRequires:  bison
42 BuildRequires:  elfutils-devel
43 BuildRequires:  flex
44 BuildRequires:  gnutls-devel >= 1.0.0
45 BuildRequires:  gtk+2-devel >= 1:2.0.0
46 %{?with_kerberos5:BuildRequires:        heimdal-devel}
47 BuildRequires:  libcap-devel
48 BuildRequires:  libgcrypt-devel >= 1.1.42
49 BuildRequires:  libpcap-devel >= 2:1.0.0-4
50 BuildRequires:  libsmi-devel
51 BuildRequires:  libtool
52 BuildRequires:  libxslt-progs
53 BuildRequires:  lua51-devel
54 %{?with_snmp:BuildRequires:     net-snmp-devel}
55 BuildRequires:  pcre-devel
56 BuildRequires:  perl-tools-pod
57 BuildRequires:  pkgconfig
58 BuildRequires:  portaudio-devel
59 BuildRequires:  sed >= 4.0
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-common = %{version}-%{release}
62 Requires:       libpcap >= 0.4
63 Provides:       ethereal
64 Provides:       ethereal-gnome
65 Obsoletes:      ethereal
66 Obsoletes:      ethereal-gnome
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Wireshark is the name for powerful graphical network sniffer, traffic
71 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
72 capture and interactively browse the contents of network frames with
73 vast knowledge of more than 100 network protocols. Wireshark has
74 severeal useful features, including a rich display filter language,
75 the ability to view the ASCII contents of a TCP connection and plug-in
76 capabilities.
77
78 %description -l es.UTF-8
79 Analizador de tráfico de red.
80
81 %description -l pl.UTF-8
82 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
83 protokołów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
84 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
85 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
86 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
87 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
88 wtyczek (plug-ins).
89
90 %description -l pt_BR.UTF-8
91 O Wireshark é um analisador de protocolo de rede baseado no GTK+.
92
93 %description -l ru.UTF-8
94 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
95 базируется на GTK+ и libpcap.
96
97 %description -l uk.UTF-8
98 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
99 базується на GTK+ та libpcap.
100
101 %package common
102 Summary:        Network traffic and protocol analyzer - common files
103 Summary(pl.UTF-8):      Analizator ruchu i protokołów sieciowych - wspólne pliki
104 Group:          Networking
105 Requires:       libwiretap = %{version}-%{release}
106 Provides:       %{name}-tools
107 Provides:       ethereal-common
108 Provides:       group(wireshark)
109 Obsoletes:      ethereal-common
110 Obsoletes:      wireshark-tools
111 Requires(post,postun):  /sbin/ldconfig
112 Requires(post,postun):  /sbin/setcap
113
114 %description common
115 Wireshark is the name for powerful graphical network sniffer, traffic
116 and protocol analyzer based on GTK+ and libpcap libraries. It lets you
117 capture and interactively browse the contents of network frames with
118 vast knowledge of more than 100 network protocols. Wireshark has
119 severeal useful features, including a rich display filter language,
120 the ability to view the ASCII contents of a TCP connection and plug-in
121 capabilities.
122
123 This package provides set of tools for manipulating capture files. It
124 contains:
125 - capinfo - prints informatio about binary capture files,
126 - dftest - shows display filter byte-code,
127 - dumpcap - dumps network traffic to a file,
128 - editcap - edit and/or translate the format of capture files,
129 - mergecap - merges two capture files into one,
130 - randpkt - generates libpcap trace file full of random packets,
131 - rawshark - dumps and analyzes raw libpcap data,
132 - text2cap - generate a capture file from an ASCII hexdump of packets.
133
134 %description common -l es.UTF-8
135 Analizador de tráfico de red.
136
137 %description common -l pl.UTF-8
138 Wireshark jest potężnym, graficznym snifferem, analizatorem ruchu oraz
139 protokołów sieciowych opartym na bibliotekach GTK+ oraz libpcap.
140 Umożliwia on przechwytywanie oraz interaktywną analizę zawartości
141 ramek oraz ponad stu protokołów sieciowych. Wireshark posiada wiele
142 użytecznych cech, takich jak rozbudowany język filtrów wyświetlania,
143 możliwość oglądania przebiegu sesji TCP oraz możliwość dołączania
144 wtyczek (plug-ins).
145
146 Pakiet ten dostarcza także zestaw narzędzi do obróbki plików z
147 przechwyconymi pakietami, obejmujący:
148 - capinfo - do wyświetlania informacji o binarnych plikach zrzutu,
149 - dftest - do pokazywania bajtkodu filtrów wyświetlania,
150 - dumpcap - do zrzucania ruchu sieciowego do pliku,
151 - editcap - do edycji plików i tłumaczenia ich na inne formaty,
152 - mergecap - do łączenia dwóch plików w jeden,
153 - randpkt - do generowania plikow cap z losowymi danymi,
154 - rawshark - do obróbki plików cap,
155 - text2cap - do generowania pliku cap z szesnastkowego zrzutu ASCII
156   pakietów.
157
158 %description common -l pt_BR.UTF-8
159 O Wireshark é um analisador de protocolo de rede baseado no GTK+.
160
161 %description common -l ru.UTF-8
162 Wireshark - это анализатор сетевого траффика для Unix-подобных ОС. Он
163 базируется на GTK+ и libpcap.
164
165 %description common -l uk.UTF-8
166 Wireshark - це аналізатор мережевого трафіку для Unix-подібних ОС. Він
167 базується на GTK+ та libpcap.
168
169 %package -n twireshark
170 Summary:        Text-mode network traffic and protocol analyzer
171 Summary(pl.UTF-8):      Tekstowy analizator ruchu i protokołów sieciowych
172 Summary(pt_BR.UTF-8):   Analisador modo texto de tráfego de rede (sniffer)
173 Group:          Networking
174 Requires:       %{name}-common = %{version}-%{release}
175 Requires:       libpcap >= 0.4
176 Provides:       tethereal
177 Obsoletes:      tethereal
178
179 %description -n twireshark
180 Twireshark is a network protocol analyzer. It lets you capture packet
181 data from a live network, or read packets from a previously saved
182 capture file, either printing a decoded form of those packets to the
183 standard output or writing the packets to a file. Twireshark's native
184 capture file format is libpcap format, which is also the format used
185 by tcpdump and various other tools.
186
187 %description -n twireshark -l pl.UTF-8
188 Twireshark jest analizatorem protokołów sieciowych. Pozwala na
189 przechwytywanie pakietów z sieci lub wczytywanie danych z pliku.
190 Zdekodowany wynik (a twireshark zna ponad 100 rozmaitych protokołów
191 sieciowych!) jest wyświetlony na ekranie. Natywnym formatem plików
192 tetherala jest format libpcap, tak więc jest on kompatybilny z
193 tcpdumpem i innymi podobnymi narzędziami.
194
195 %description -n twireshark -l pt_BR.UTF-8
196 Esta é uma versão para modo texto do analisador de tráfego de rede
197 Wireshark.
198
199 %package -n libwiretap
200 Summary:        Packet capture and analysis library
201 Summary(pl.UTF-8):      Biblioteka do przechwytywania i analizy pakietów
202 Group:          Libraries
203
204 %description -n libwiretap
205 Wiretap is a library that is being developed as a future replacement
206 for libpcap, the current standard Unix library for packet capturing.
207
208 %description -n libwiretap -l pl.UTF-8
209 Biblioteka Wiretap rozwijana jest jako przyszły następca biblioteki
210 libpcap, obecnie standardu przechwytywania pakietów w systemach Unix.
211
212 %package -n libwiretap-devel
213 Summary:        Header files for libwiretap packet capture library
214 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libwiretap do przechwytywania pakietów
215 Group:          Development/Libraries
216 Requires:       gtk+2-devel >= 2.0.0
217 Requires:       libwiretap = %{version}-%{release}
218
219 %description -n libwiretap-devel
220 Header files for libwiretap packet capture library.
221
222 %description -n libwiretap-devel -l pl.UTF-8
223 Pliki nagłówkowe biblioteki libwiretap służącej do przechwytywania
224 pakietów.
225
226 %prep
227 %setup -q
228 %patch0 -p1
229 %patch1 -p1
230 %patch2 -p1
231 %patch3 -p1
232 sed -i -e 's/lua5\.1/lua51/g' acinclude.m4
233 find -name Makefile.am | xargs sed -i -e 's/-Werror//g'
234
235 %build
236 %{__libtoolize}
237 %{__aclocal} -I aclocal-fallback
238 %{__autoconf}
239 %{__automake}
240 %configure \
241         --enable-randpkt \
242         --enable-dftest \
243         --enable-packet-editor \
244 %if %{with kerberos5}
245         --with-krb5 \
246         --with-ssl \
247 %endif
248         %{!?with_snmp:--without-net-snmp --without-ucdsnmp} \
249         --with-lua=/usr
250
251 %{__make}
252
253 %install
254 rm -rf $RPM_BUILD_ROOT
255 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_includedir}/wiretap}
256
257 %{__make} install \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 cp -p image/hi48-app-wireshark.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
261 cp -p wireshark.desktop $RPM_BUILD_ROOT%{_desktopdir}
262
263 cp -a wiretap/*.h $RPM_BUILD_ROOT%{_includedir}/wiretap
264
265 # plugins *.la are useless - *.so are loaded through gmodule
266 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/%{version}*/*.la
267
268 # no headers installed for this library
269 rm -f $RPM_BUILD_ROOT%{_libdir}/libwireshark.{so,la}
270
271 %clean
272 rm -rf $RPM_BUILD_ROOT
273
274 %pre common
275 %groupadd -P %{name}-common -g 104 wireshark
276
277 %post   common
278 /sbin/ldconfig
279 /sbin/setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' %{_bindir}/dumpcap
280 exit 0
281
282 %postun common
283 /sbin/ldconfig
284 if [ "$1" = "0" ]; then
285         %groupremove wireshark
286 fi
287
288 %post   -n libwiretap -p /sbin/ldconfig
289 %postun -n libwiretap -p /sbin/ldconfig
290
291 %files
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_bindir}/wireshark
294 %dir %{_libdir}/%{name}
295 %dir %{_libdir}/%{name}/plugins
296 %dir %{_libdir}/%{name}/plugins/%{version}*
297 %attr(755,root,root) %{_libdir}/%{name}/plugins/%{version}*/*.so
298 %{_datadir}/%{name}
299 %{_desktopdir}/%{name}.desktop
300 %{_pixmapsdir}/*.png
301 %{_mandir}/man1/wireshark.1*
302
303 %files common
304 %defattr(644,root,root,755)
305 %doc AUTHORS* ChangeLog NEWS README{,.[lv]*} doc/{randpkt.txt,README.*}
306 %attr(755,root,root) %{_bindir}/capinfos
307 %attr(755,root,root) %{_bindir}/dftest
308 %attr(750,root,wireshark) %{_bindir}/dumpcap
309 %attr(755,root,root) %{_bindir}/editcap
310 %attr(755,root,root) %{_bindir}/mergecap
311 %attr(755,root,root) %{_bindir}/randpkt
312 %attr(755,root,root) %{_bindir}/rawshark
313 %attr(755,root,root) %{_bindir}/text2pcap
314 %attr(755,root,root) %{_libdir}/libwireshark.so.*.*.*
315 %attr(755,root,root) %ghost %{_libdir}/libwireshark.so.2
316 %attr(755,root,root) %{_libdir}/libwsutil.so.*.*.*
317 %attr(755,root,root) %ghost %{_libdir}/libwsutil.so.2
318 %{_mandir}/man1/capinfos.1*
319 %{_mandir}/man1/dftest.1*
320 %{_mandir}/man1/dumpcap.1*
321 %{_mandir}/man1/editcap.1*
322 %{_mandir}/man1/mergecap.1*
323 %{_mandir}/man1/rawshark.1*
324 %{_mandir}/man1/randpkt.1*
325 %{_mandir}/man1/text2pcap.1*
326 %{_mandir}/man4/wireshark-filter.4*
327
328 %files -n twireshark
329 %defattr(644,root,root,755)
330 %attr(755,root,root) %{_bindir}/tshark
331 %{_mandir}/man1/tshark*.1*
332
333 %files -n libwiretap
334 %defattr(644,root,root,755)
335 %doc wiretap/{README*,AUTHORS}
336 %attr(755,root,root) %{_libdir}/libwiretap.so.*.*.*
337 %attr(755,root,root) %ghost %{_libdir}/libwiretap.so.2
338
339 %files -n libwiretap-devel
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/libwiretap.so
342 %attr(755,root,root) %{_libdir}/libwsutil.so
343 %{_libdir}/libwiretap.la
344 %{_libdir}/libwsutil.la
345 %{_includedir}/wiretap
This page took 0.056798 seconds and 2 git commands to generate.