]> git.pld-linux.org Git - packages/wildmidi.git/blob - wildmidi.spec
a1d708fc88b18002d59bf3561f7d047bec902ca2
[packages/wildmidi.git] / wildmidi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  alsa            # ALSA support (OSS otherwise)
5 #
6 Summary:        MIDI player using pat sound sets
7 Summary(pl.UTF-8):      Odtwarzacz MIDI wykorzystujący zestawy dźwięków pat
8 Name:           wildmidi
9 Version:        0.4.2
10 Release:        1
11 License:        LGPL v3+ (library), GPL v3+ (player)
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/wildmidi/%{name}-%{version}.tar.gz
14 # Source0-md5:  55cf5292def592a496457038de2ed6f5
15 URL:            http://www.mindwerks.net/projects/wildmidi/
16 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 1.0.1}
17 BuildRequires:  cmake >= 2.8
18 # for wildmidi player
19 %{?with_alsa:Requires:  alsa-lib >= 1.0.1}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 WildMidi is a wave table player that uses GUS pat sound sets to play
24 MIDI file. The WildMidi player is the frontend, and is only designed
25 to pass information to the core library and output any audio data the
26 library returns.
27
28 The core of the project, libWildMidi, is the work horse behind the
29 player. It's capable of multithreading and multiprocessing of MIDI
30 files, allowing for the mixing of multiple MIDI file at any one time
31 if someone had a desire to do so. This library is what turns the MIDI
32 files into audio data using the GUS pat sets.
33
34 %description -l pl.UTF-8
35 WildMidi to odtwarzacz plików MIDI wykorzystujący zestawy dźwięków pat
36 z GUS-a. WildMidi to frontend służący tylko do przekazywania
37 informacji do głównej biblioteki i wyprowadzania danych dźwiękowych
38 zwracanych przez bibliotekę.
39
40 Serce projektu, libWildMidi, to silnik stojący za odtwarzaczem. Jest w
41 stanie przetwarzać pliki MIDI wielowątkowo, pozwalając na miksowanie
42 wielu plików MIDI. Biblioteka jest tym, co zamienia pliki MIDI na dane
43 dźwiękowe przy użyciu zestawów pat z GUS-a.
44
45 %package devel
46 Summary:        Header files for WildMidi library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WildMidi
48 License:        LGPL v3+
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for WildMidi library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki WildMidi.
57
58 %package static
59 Summary:        Static WildMidi library
60 Summary(pl.UTF-8):      Statyczna biblioteka WildMidi
61 License:        LGPL v3+
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static WildMidi library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka WildMidi.
70
71 %prep
72 %setup -q -n %{name}-%{name}-%{version}
73
74 %build
75 install -d build
76 cd build
77 %cmake .. \
78         %{?with_alsa:-DWANT_ALSA=ON} \
79         %{!?with_alsa:-DWANT_OSS=ON} \
80         %{?with_static_libs:-DWANT_STATIC=ON} \
81         -DWANT_PLAYERSTATIC=OFF
82         
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} -C build install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README.md
100 %attr(755,root,root) %{_bindir}/wildmidi
101 %attr(755,root,root) %{_libdir}/libWildMidi.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libWildMidi.so.2
103 %{_mandir}/man1/wildmidi.1*
104 %{_mandir}/man5/wildmidi.cfg.5*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libWildMidi.so
109 %{_includedir}/wildmidi_lib.h
110 %{_pkgconfigdir}/wildmidi.pc
111 %{_mandir}/man3/WildMidi_*.3*
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libWildMidi.a
117 %endif
This page took 0.065248 seconds and 2 git commands to generate.