]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
- updated to 1.0.3
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_without  wayland         # wayland (nested) compositor
5 %bcond_without  x11             # X11 compositor
6 %bcond_without  wlaunch         # weston launch
7 %bcond_without  xwayland        # X server launcher
8 %bcond_without  sclients        # simple clients
9 %bcond_without  clients         # non-simple + full GL clients
10 #
11 Summary:        Weston - Wayland demos
12 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
13 Name:           weston
14 Version:        1.0.3
15 Release:        1
16 License:        MIT
17 Group:          Applications
18 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
19 # Source0-md5:  f82ac2e013e6b6a6303ac4ba7b64c7f2
20 URL:            http://wayland.freedesktop.org/
21 BuildRequires:  Mesa-libEGL-devel >= 7.10
22 BuildRequires:  Mesa-libGLES-devel
23 # for wayland and sclients, but also desktop-shell, which is always enabled
24 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
25 BuildRequires:  cairo-devel >= 1.10.0
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libwebp-devel
29 BuildRequires:  pixman-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  tar >= 1:1.22
32 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
33 BuildRequires:  wayland-devel >= 1.0.0
34 BuildRequires:  xorg-lib-libxkbcommon-devel
35 BuildRequires:  xz
36 %if %{with drm}
37 BuildRequires:  Mesa-libgbm-devel
38 BuildRequires:  libdrm-devel >= 2.4.30
39 BuildRequires:  mtdev-devel >= 1.1.0
40 BuildRequires:  udev-devel >= 1:136
41 %endif
42 %if %{with x11}
43 BuildRequires:  libxcb-devel
44 BuildRequires:  xorg-lib-libX11-devel
45 %endif
46 %if %{with wlaunch}
47 BuildRequires:  libdrm-devel
48 BuildRequires:  pam-devel
49 BuildRequires:  systemd-devel
50 %endif
51 %if %{with xwayland}
52 BuildRequires:  libxcb-devel
53 BuildRequires:  pkgconfig(cairo-xcb)
54 BuildRequires:  xorg-lib-libXcursor-devel
55 %endif
56 %if %{with clients}
57 BuildRequires:  cairo-devel >= 1.11.3
58 BuildRequires:  gdk-pixbuf2-devel >= 2.0
59 BuildRequires:  glib2-devel >= 2.0
60 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
61 BuildRequires:  poppler-glib-devel
62 %endif
63 Requires:       Mesa-libwayland-egl >= 9.0-2
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Weston contains a few demo application for the Wayland project.
68 There's a sample compositor that can run on KMS, under X11 or under
69 another Wayland compositor and there's a handful of simple clients
70 that demonstrate various aspects of Wayland.
71
72 %description -l pl.UTF-8
73 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
74 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
75 X11 lub pod innym serwerem składającym Wayland; są także proste
76 programy klienckie demonstrujące różne aspekty protokołu Wayland.
77
78 %prep
79 %setup -q
80
81 %build
82 %configure \
83         %{!?with_clients:--disable-clients} \
84         %{!?with_drm:--disable-drm-compositor} \
85         %{!?with_sclients:--disable-simple-clients} \
86         --disable-setuid-install \
87         --disable-silent-rules \
88         %{!?with_static_libs:--disable-static} \
89         %{!?with_wlaunch:--disable-weston-launch} \
90         %{!?with_x11:--disable-x11-compositor} \
91         %{!?with_xwayland:--disable-xwayland}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README
108 %attr(755,root,root) %{_bindir}/wcap-decode
109 %attr(755,root,root) %{_bindir}/weston-info
110 # composer
111 %attr(755,root,root) %{_bindir}/weston
112 %if %{with wlaunch}
113 %attr(755,root,root) %{_bindir}/weston-launch
114 %endif
115 %if %{with clients}
116 %attr(755,root,root) %{_bindir}/weston-terminal
117 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
118 %attr(755,root,root) %{_libexecdir}/weston-screensaver
119 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
120 %attr(755,root,root) %{_libexecdir}/weston-tablet-shell
121 %endif
122 %dir %{_libdir}/weston
123 %if %{with drm}
124 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
125 %endif
126 %if %{with wayland}
127 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
128 %endif
129 %if %{with x11}
130 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
131 %endif
132 %if %{with xwayland}
133 %attr(755,root,root) %{_libdir}/weston/xwayland.so
134 %endif
135 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
136 %attr(755,root,root) %{_libdir}/weston/tablet-shell.so
137 %{_datadir}/weston
138 %{_mandir}/man1/weston.1*
139 %{_mandir}/man7/weston-drm.7*
140
141 # noinst, too common names - package in %{name}-demos with weston- prefix?
142 # "simple clients"
143 #%attr(755,root,root) %{_bindir}/simple-egl
144 #%attr(755,root,root) %{_bindir}/simple-shm
145 #%attr(755,root,root) %{_bindir}/simple-touch
146 %if %{with clients}
147 #%attr(755,root,root) %{_bindir}/clickdot
148 #%attr(755,root,root) %{_bindir}/dnd
149 #%attr(755,root,root) %{_bindir}/editor
150 #%attr(755,root,root) %{_bindir}/eventdemo
151 #%attr(755,root,root) %{_bindir}/flower
152 #%attr(755,root,root) %{_bindir}/image
153 #%attr(755,root,root) %{_bindir}/keyboard
154 #%attr(755,root,root) %{_bindir}/resizor
155 #%attr(755,root,root) %{_bindir}/smoke
156 # "full GL" clients
157 #%attr(755,root,root) %{_bindir}/gears
158 # poppler
159 #%attr(755,root,root) %{_bindir}/view
160 %endif
This page took 0.044794 seconds and 4 git commands to generate.