]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
- updated to 1.7.0
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_with     rdp             # RDP compositor (needs freerdp 1.1.0)
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  libinput        # libinput backend
8 %bcond_without  vaapi           # vaapi recorder
9 %bcond_without  wlaunch         # weston launch
10 %bcond_without  xwayland        # X server launcher
11 %bcond_without  sclients        # simple clients
12 %bcond_without  clients         # non-simple + full GL clients
13 #
14 Summary:        Weston - Wayland demos
15 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
16 Name:           weston
17 Version:        1.7.0
18 Release:        1
19 License:        MIT
20 Group:          Applications
21 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
22 # Source0-md5:  1fde8a44f48cd177438522850d6ba4be
23 URL:            http://wayland.freedesktop.org/
24 BuildRequires:  Mesa-libEGL-devel >= 7.10
25 # GLESv2
26 BuildRequires:  Mesa-libGLES-devel
27 # for wayland and sclients, but also desktop-shell, which is always enabled
28 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
29 BuildRequires:  autoconf >= 2.64
30 BuildRequires:  automake >= 1:1.11
31 BuildRequires:  cairo-devel >= 1.10.0
32 BuildRequires:  colord-devel >= 0.1.27
33 BuildRequires:  dbus-devel >= 1.6
34 %{?with_rdp:BuildRequires:      freerdp-devel >= 1.1.0}
35 BuildRequires:  lcms2-devel >= 2
36 %{?with_libinput:BuildRequires: libinput-devel >= 0.8.0}
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool >= 2:2.2
40 BuildRequires:  libunwind-devel
41 BuildRequires:  libwebp-devel
42 BuildRequires:  pixman-devel >= 0.26
43 BuildRequires:  pkgconfig
44 BuildRequires:  tar >= 1:1.22
45 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
46 BuildRequires:  wayland-devel >= 1.7.0
47 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
48 BuildRequires:  xz
49 %if %{with drm}
50 BuildRequires:  Mesa-libgbm-devel
51 BuildRequires:  libdrm-devel >= 2.4.30
52 BuildRequires:  mtdev-devel >= 1.1.0
53 BuildRequires:  udev-devel >= 1:136
54 %endif
55 %if %{with vaapi}
56 BuildRequires:  libva-devel >= 1.2.0
57 BuildRequires:  libva-drm-devel >= 1.2.0
58 # API versions
59 BuildRequires:  pkgconfig(libva) >= 0.34.0
60 BuildRequires:  pkgconfig(libva-drm) >= 0.34.0
61 %endif
62 %if %{with x11}
63 BuildRequires:  libxcb-devel
64 BuildRequires:  xorg-lib-libX11-devel
65 %endif
66 %if %{with wlaunch}
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pam-devel
69 # TODO: bump to 1:209 (required at runtime when built with such version)
70 BuildRequires:  systemd-devel >= 1:198
71 %endif
72 %if %{with xwayland}
73 BuildRequires:  libxcb-devel
74 BuildRequires:  pkgconfig(cairo-xcb)
75 BuildRequires:  xorg-lib-libXcursor-devel
76 %endif
77 %if %{with clients}
78 BuildRequires:  OpenGL-GLU-devel
79 BuildRequires:  cairo-devel >= 1.11.3
80 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
81 BuildRequires:  pkgconfig(cairo-gl)
82 %endif
83 Requires:       Mesa-libEGL >= 7.10
84 Requires:       Mesa-libwayland-egl >= 9.0-2
85 Requires:       cairo >= %{?with_clients:1.11.3}%{!?with_clients:1.10.0}
86 Requires:       colord-libs >= 0.1.27
87 Requires:       dbus-libs >= 1.6
88 %{?with_rdp:Requires:   freerdp >= 1.1.0}
89 %{?with_drm:Requires:   libdrm >= 2.4.30}
90 %{?with_libinput:Requires:      libinput >= 0.8.0}
91 %if %{with vaapi}
92 Requires:       libva >= 1.2.0
93 Requires:       libva-drm >= 1.2.0
94 %endif
95 %{?with_drm:Requires:   mtdev >= 1.1.0}
96 Requires:       pixman >= 0.26
97 %{?with_wlaunch:Requires:       systemd-libs >= 1:198}
98 %{?with_drm:Requires:   udev-libs >= 1:136}
99 Requires:       wayland >= 1.7.0
100 Requires:       xorg-lib-libxkbcommon >= 0.3.0
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %description
104 Weston contains a few demo application for the Wayland project.
105 There's a sample compositor that can run on KMS, under X11 or under
106 another Wayland compositor and there's a handful of simple clients
107 that demonstrate various aspects of Wayland.
108
109 %description -l pl.UTF-8
110 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
111 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
112 X11 lub pod innym serwerem składającym Wayland; są także proste
113 programy klienckie demonstrujące różne aspekty protokołu Wayland.
114
115 %package devel
116 Summary:        Header files for Weston plugin development
117 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
118 Group:          Development/Libraries
119 Requires:       Mesa-libEGL-devel >= 7.10
120 # GLESv2
121 Requires:       Mesa-libGLES-devel
122 Requires:       pixman-devel >= 0.26
123 Requires:       wayland-devel >= 1.7.0
124 Requires:       xorg-lib-libxkbcommon-devel >= 0.3.0
125
126 %description devel
127 Header files for Weston plugin development.
128
129 %description devel -l pl.UTF-8
130 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
131
132 %prep
133 %setup -q
134
135 %build
136 %{__libtoolize}
137 %{__aclocal} -I m4
138 %{__autoconf}
139 %{__autoheader}
140 %{__automake}
141 %configure \
142         %{!?with_clients:--disable-clients} \
143         %{!?with_drm:--disable-drm-compositor} \
144         %{?with_libinput:--enable-libinput-backend} \
145         %{?with_rdp:--enable-rdp-compositor} \
146         %{!?with_sclients:--disable-simple-clients} \
147         --disable-setuid-install \
148         --disable-silent-rules \
149         %{!?with_vaapi:--disable-vaapi-recorder} \
150         %{!?with_wlaunch:--disable-weston-launch} \
151         %{!?with_x11:--disable-x11-compositor} \
152         %{!?with_xwayland:--disable-xwayland} \
153         %{?with_clients:--with-cairo=gl}
154 %{__make}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files
168 %defattr(644,root,root,755)
169 %doc README
170 %attr(755,root,root) %{_bindir}/wcap-decode
171 %attr(755,root,root) %{_bindir}/weston-info
172 # composer
173 %attr(755,root,root) %{_bindir}/weston
174 %if %{with wlaunch}
175 %attr(755,root,root) %{_bindir}/weston-launch
176 %endif
177 %if %{with clients}
178 %attr(755,root,root) %{_bindir}/weston-terminal
179 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
180 %attr(755,root,root) %{_libexecdir}/weston-keyboard
181 %attr(755,root,root) %{_libexecdir}/weston-screensaver
182 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
183 %endif
184 %attr(755,root,root) %{_libexecdir}/weston-simple-im
185 %dir %{_libdir}/weston
186 %attr(755,root,root) %{_libdir}/weston/cms-colord.so
187 %attr(755,root,root) %{_libdir}/weston/cms-static.so
188 %if %{with drm}
189 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
190 %endif
191 %attr(755,root,root) %{_libdir}/weston/fbdev-backend.so
192 %attr(755,root,root) %{_libdir}/weston/gl-renderer.so
193 %attr(755,root,root) %{_libdir}/weston/headless-backend.so
194 %if %{with rdp}
195 %attr(755,root,root) %{_libdir}/weston/rdp-backend.so
196 %endif
197 %if %{with wayland}
198 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
199 %endif
200 %if %{with x11}
201 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
202 %endif
203 %if %{with xwayland}
204 %attr(755,root,root) %{_libdir}/weston/xwayland.so
205 %endif
206 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
207 %attr(755,root,root) %{_libdir}/weston/fullscreen-shell.so
208 # ivi shell
209 %attr(755,root,root) %{_libexecdir}/weston-ivi-shell-user-interface
210 %attr(755,root,root) %{_libdir}/weston/hmi-controller.so
211 %attr(755,root,root) %{_libdir}/weston/ivi-shell.so
212 %{_datadir}/weston
213 %dir %{_datadir}/wayland-sessions
214 %{_datadir}/wayland-sessions/weston.desktop
215 %{_mandir}/man1/weston.1*
216 %{_mandir}/man5/weston.ini.5*
217 %{_mandir}/man7/weston-drm.7*
218
219 # noinst by default - --enable-demo-clients and package in %{name}-demos?
220 # "simple clients"
221 #%attr(755,root,root) %{_bindir}/weston-multi-resource
222 #%attr(755,root,root) %{_bindir}/weston-simple-egl
223 #%attr(755,root,root) %{_bindir}/weston-simple-shm
224 #%attr(755,root,root) %{_bindir}/weston-simple-touch
225 %if %{with clients}
226 #%attr(755,root,root) %{_bindir}/weston-calibrator
227 #%attr(755,root,root) %{_bindir}/weston-clickdot
228 #%attr(755,root,root) %{_bindir}/weston-cliptest
229 #%attr(755,root,root) %{_bindir}/weston-dnd
230 #%attr(755,root,root) %{_bindir}/weston-editor
231 #%attr(755,root,root) %{_bindir}/weston-eventdemo
232 #%attr(755,root,root) %{_bindir}/weston-flower
233 #%attr(755,root,root) %{_bindir}/weston-fullscreen
234 #%attr(755,root,root) %{_bindir}/weston-image
235 #%attr(755,root,root) %{_bindir}/weston-resizor
236 #%attr(755,root,root) %{_bindir}/weston-scaler
237 #%attr(755,root,root) %{_bindir}/weston-smoke
238 #%attr(755,root,root) %{_bindir}/weston-stacking
239 #%attr(755,root,root) %{_bindir}/weston-transformed
240 # "full GL" clients
241 #%attr(755,root,root) %{_bindir}/weston-gears
242 %endif
243
244 %files devel
245 %defattr(644,root,root,755)
246 %{_includedir}/weston
247 %{_pkgconfigdir}/weston.pc
This page took 0.046362 seconds and 4 git commands to generate.