]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
- up to 1.6.1
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_with     rdp             # RDP compositor (needs freerdp 1.1.0)
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  libinput        # libinput backend
8 %bcond_without  vaapi           # vaapi recorder
9 %bcond_without  wlaunch         # weston launch
10 %bcond_without  xwayland        # X server launcher
11 %bcond_without  sclients        # simple clients
12 %bcond_without  clients         # non-simple + full GL clients
13 #
14 Summary:        Weston - Wayland demos
15 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
16 Name:           weston
17 Version:        1.6.1
18 Release:        1
19 License:        MIT
20 Group:          Applications
21 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
22 # Source0-md5:  08e857668621c930cab239d11c12cf47
23 URL:            http://wayland.freedesktop.org/
24 BuildRequires:  Mesa-libEGL-devel >= 7.10
25 # GLESv2
26 BuildRequires:  Mesa-libGLES-devel
27 # for wayland and sclients, but also desktop-shell, which is always enabled
28 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
29 BuildRequires:  cairo-devel >= 1.10.0
30 BuildRequires:  colord-devel >= 0.1.27
31 BuildRequires:  dbus-devel >= 1.6
32 %{?with_rdp:BuildRequires:      freerdp-devel >= 1.1.0}
33 BuildRequires:  lcms2-devel >= 2
34 %{?with_libinput:BuildRequires: libinput-devel >= 0.6.0}
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libunwind-devel
38 BuildRequires:  libwebp-devel
39 BuildRequires:  pixman-devel >= 0.26
40 BuildRequires:  pkgconfig
41 BuildRequires:  tar >= 1:1.22
42 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
43 BuildRequires:  wayland-devel >= 1.6.0
44 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
45 BuildRequires:  xz
46 %if %{with drm}
47 BuildRequires:  Mesa-libgbm-devel
48 BuildRequires:  libdrm-devel >= 2.4.30
49 BuildRequires:  mtdev-devel >= 1.1.0
50 BuildRequires:  udev-devel >= 1:136
51 %endif
52 %if %{with vaapi}
53 BuildRequires:  libva-devel >= 1.2.0
54 BuildRequires:  libva-drm-devel >= 1.2.0
55 # API versions
56 BuildRequires:  pkgconfig(libva) >= 0.34.0
57 BuildRequires:  pkgconfig(libva-drm) >= 0.34.0
58 %endif
59 %if %{with x11}
60 BuildRequires:  libxcb-devel
61 BuildRequires:  xorg-lib-libX11-devel
62 %endif
63 %if %{with wlaunch}
64 BuildRequires:  libdrm-devel
65 BuildRequires:  pam-devel
66 # TODO: bump to 1:209 (required at runtime when built with such version)
67 BuildRequires:  systemd-devel >= 1:198
68 %endif
69 %if %{with xwayland}
70 BuildRequires:  libxcb-devel
71 BuildRequires:  pkgconfig(cairo-xcb)
72 BuildRequires:  xorg-lib-libXcursor-devel
73 %endif
74 %if %{with clients}
75 BuildRequires:  OpenGL-GLU-devel
76 BuildRequires:  cairo-devel >= 1.11.3
77 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
78 BuildRequires:  pkgconfig(cairo-gl)
79 %endif
80 Requires:       Mesa-libEGL >= 7.10
81 Requires:       Mesa-libwayland-egl >= 9.0-2
82 Requires:       cairo >= %{?with_clients:1.11.3}%{!?with_clients:1.10.0}
83 Requires:       colord-libs >= 0.1.27
84 Requires:       dbus-libs >= 1.6
85 %{?with_rdp:Requires:   freerdp >= 1.1.0}
86 %{?with_drm:Requires:   libdrm >= 2.4.30}
87 %{?with_libinput:Requires:      libinput >= 0.6.0}
88 %if %{with vaapi}
89 Requires:       libva >= 1.2.0
90 Requires:       libva-drm >= 1.2.0
91 %endif
92 %{?with_drm:Requires:   mtdev >= 1.1.0}
93 Requires:       pixman >= 0.26
94 %{?with_wlaunch:Requires:       systemd-libs >= 1:198}
95 %{?with_drm:Requires:   udev-libs >= 1:136}
96 Requires:       wayland >= 1.6.0
97 Requires:       xorg-lib-libxkbcommon >= 0.3.0
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 Weston contains a few demo application for the Wayland project.
102 There's a sample compositor that can run on KMS, under X11 or under
103 another Wayland compositor and there's a handful of simple clients
104 that demonstrate various aspects of Wayland.
105
106 %description -l pl.UTF-8
107 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
108 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
109 X11 lub pod innym serwerem składającym Wayland; są także proste
110 programy klienckie demonstrujące różne aspekty protokołu Wayland.
111
112 %package devel
113 Summary:        Header files for Weston plugin development
114 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
115 Group:          Development/Libraries
116 Requires:       Mesa-libEGL-devel >= 7.10
117 # GLESv2
118 Requires:       Mesa-libGLES-devel
119 Requires:       pixman-devel >= 0.26
120 Requires:       wayland-devel >= 1.6.0
121 Requires:       xorg-lib-libxkbcommon-devel >= 0.3.0
122
123 %description devel
124 Header files for Weston plugin development.
125
126 %description devel -l pl.UTF-8
127 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
128
129 %prep
130 %setup -q
131
132 %build
133 %configure \
134         %{!?with_clients:--disable-clients} \
135         %{!?with_drm:--disable-drm-compositor} \
136         %{?with_libinput:--enable-libinput-backend} \
137         %{?with_rdp:--enable-rdp-compositor} \
138         %{!?with_sclients:--disable-simple-clients} \
139         --disable-setuid-install \
140         --disable-silent-rules \
141         %{!?with_vaapi:--disable-vaapi-recorder} \
142         %{!?with_wlaunch:--disable-weston-launch} \
143         %{!?with_x11:--disable-x11-compositor} \
144         %{!?with_xwayland:--disable-xwayland} \
145         %{?with_clients:--with-cairo=gl}
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %files
160 %defattr(644,root,root,755)
161 %doc README
162 %attr(755,root,root) %{_bindir}/wcap-decode
163 %attr(755,root,root) %{_bindir}/weston-info
164 # composer
165 %attr(755,root,root) %{_bindir}/weston
166 %if %{with wlaunch}
167 %attr(755,root,root) %{_bindir}/weston-launch
168 %endif
169 %if %{with clients}
170 %attr(755,root,root) %{_bindir}/weston-terminal
171 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
172 %attr(755,root,root) %{_libexecdir}/weston-keyboard
173 %attr(755,root,root) %{_libexecdir}/weston-screensaver
174 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
175 %endif
176 %attr(755,root,root) %{_libexecdir}/weston-simple-im
177 %dir %{_libdir}/weston
178 %attr(755,root,root) %{_libdir}/weston/cms-colord.so
179 %attr(755,root,root) %{_libdir}/weston/cms-static.so
180 %if %{with drm}
181 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
182 %endif
183 %attr(755,root,root) %{_libdir}/weston/fbdev-backend.so
184 %attr(755,root,root) %{_libdir}/weston/gl-renderer.so
185 %attr(755,root,root) %{_libdir}/weston/headless-backend.so
186 %if %{with rdp}
187 %attr(755,root,root) %{_libdir}/weston/rdp-backend.so
188 %endif
189 %if %{with wayland}
190 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
191 %endif
192 %if %{with x11}
193 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
194 %endif
195 %if %{with xwayland}
196 %attr(755,root,root) %{_libdir}/weston/xwayland.so
197 %endif
198 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
199 %attr(755,root,root) %{_libdir}/weston/fullscreen-shell.so
200 %{_datadir}/weston
201 %{_mandir}/man1/weston.1*
202 %{_mandir}/man5/weston.ini.5*
203 %{_mandir}/man7/weston-drm.7*
204
205 # noinst by default - --enable-demo-clients and package in %{name}-demos?
206 # "simple clients"
207 #%attr(755,root,root) %{_bindir}/weston-multi-resource
208 #%attr(755,root,root) %{_bindir}/weston-simple-egl
209 #%attr(755,root,root) %{_bindir}/weston-simple-shm
210 #%attr(755,root,root) %{_bindir}/weston-simple-touch
211 %if %{with clients}
212 #%attr(755,root,root) %{_bindir}/weston-calibrator
213 #%attr(755,root,root) %{_bindir}/weston-clickdot
214 #%attr(755,root,root) %{_bindir}/weston-cliptest
215 #%attr(755,root,root) %{_bindir}/weston-dnd
216 #%attr(755,root,root) %{_bindir}/weston-editor
217 #%attr(755,root,root) %{_bindir}/weston-eventdemo
218 #%attr(755,root,root) %{_bindir}/weston-flower
219 #%attr(755,root,root) %{_bindir}/weston-fullscreen
220 #%attr(755,root,root) %{_bindir}/weston-image
221 #%attr(755,root,root) %{_bindir}/weston-resizor
222 #%attr(755,root,root) %{_bindir}/weston-scaler
223 #%attr(755,root,root) %{_bindir}/weston-smoke
224 #%attr(755,root,root) %{_bindir}/weston-stacking
225 #%attr(755,root,root) %{_bindir}/weston-transformed
226 # "full GL" clients
227 #%attr(755,root,root) %{_bindir}/weston-gears
228 %endif
229
230 %files devel
231 %defattr(644,root,root,755)
232 %{_includedir}/weston
233 %{_pkgconfigdir}/weston.pc
This page took 0.081727 seconds and 4 git commands to generate.