]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
b8592c08a8658e7e16a7beee7b3e1ad6209befc3
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_without  wayland         # wayland (nested) compositor
5 %bcond_without  x11             # X11 compositor
6 %bcond_without  wlaunch         # weston launch
7 %bcond_without  xwayland        # X server launcher
8 %bcond_without  sclients        # simple clients
9 %bcond_without  clients         # non-simple + full GL clients
10 #
11 Summary:        Weston - Wayland demos
12 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
13 Name:           weston
14 Version:        1.0.6
15 Release:        1
16 License:        MIT
17 Group:          Applications
18 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
19 # Source0-md5:  63202129d66d5514e572814da5dfa1f7
20 URL:            http://wayland.freedesktop.org/
21 BuildRequires:  Mesa-libEGL-devel >= 7.10
22 # GLESv2
23 BuildRequires:  Mesa-libGLES-devel
24 # for wayland and sclients, but also desktop-shell, which is always enabled
25 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
26 BuildRequires:  cairo-devel >= 1.10.0
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libwebp-devel
30 BuildRequires:  pixman-devel
31 BuildRequires:  pkgconfig
32 BuildRequires:  tar >= 1:1.22
33 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
34 BuildRequires:  wayland-devel >= 1.0.0
35 BuildRequires:  xorg-lib-libxkbcommon-devel
36 BuildRequires:  xz
37 %if %{with drm}
38 BuildRequires:  Mesa-libgbm-devel
39 BuildRequires:  libdrm-devel >= 2.4.30
40 BuildRequires:  mtdev-devel >= 1.1.0
41 BuildRequires:  udev-devel >= 1:136
42 %endif
43 %if %{with x11}
44 BuildRequires:  libxcb-devel
45 BuildRequires:  xorg-lib-libX11-devel
46 %endif
47 %if %{with wlaunch}
48 BuildRequires:  libdrm-devel
49 BuildRequires:  pam-devel
50 BuildRequires:  systemd-devel
51 %endif
52 %if %{with xwayland}
53 BuildRequires:  libxcb-devel
54 BuildRequires:  pkgconfig(cairo-xcb)
55 BuildRequires:  xorg-lib-libXcursor-devel
56 %endif
57 %if %{with clients}
58 BuildRequires:  OpenGL-GLU-devel
59 BuildRequires:  cairo-devel >= 1.11.3
60 BuildRequires:  gdk-pixbuf2-devel >= 2.0
61 BuildRequires:  glib2-devel >= 2.0
62 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
63 BuildRequires:  poppler-glib-devel
64 %endif
65 Requires:       Mesa-libwayland-egl >= 9.0-2
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Weston contains a few demo application for the Wayland project.
70 There's a sample compositor that can run on KMS, under X11 or under
71 another Wayland compositor and there's a handful of simple clients
72 that demonstrate various aspects of Wayland.
73
74 %description -l pl.UTF-8
75 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
76 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
77 X11 lub pod innym serwerem składającym Wayland; są także proste
78 programy klienckie demonstrujące różne aspekty protokołu Wayland.
79
80 %package devel
81 Summary:        Header files for Weston plugin development
82 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
83 Group:          Development/Libraries
84 Requires:       Mesa-libEGL-devel >= 7.10
85 # GLESv2
86 Requires:       Mesa-libGLES-devel
87 Requires:       pixman-devel
88 Requires:       wayland-devel >= 1.0.0
89 Requires:       xorg-lib-libxkbcommon-devel
90
91 %description devel
92 Header files for Weston plugin development.
93
94 %description devel -l pl.UTF-8
95 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
96
97 %prep
98 %setup -q
99
100 %build
101 %configure \
102         %{!?with_clients:--disable-clients} \
103         %{!?with_drm:--disable-drm-compositor} \
104         %{!?with_sclients:--disable-simple-clients} \
105         --disable-setuid-install \
106         --disable-silent-rules \
107         %{!?with_static_libs:--disable-static} \
108         %{!?with_wlaunch:--disable-weston-launch} \
109         %{!?with_x11:--disable-x11-compositor} \
110         %{!?with_xwayland:--disable-xwayland}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc README
127 %attr(755,root,root) %{_bindir}/wcap-decode
128 %attr(755,root,root) %{_bindir}/weston-info
129 # composer
130 %attr(755,root,root) %{_bindir}/weston
131 %if %{with wlaunch}
132 %attr(755,root,root) %{_bindir}/weston-launch
133 %endif
134 %if %{with clients}
135 %attr(755,root,root) %{_bindir}/weston-terminal
136 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
137 %attr(755,root,root) %{_libexecdir}/weston-screensaver
138 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
139 %attr(755,root,root) %{_libexecdir}/weston-tablet-shell
140 %endif
141 %dir %{_libdir}/weston
142 %if %{with drm}
143 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
144 %endif
145 %if %{with wayland}
146 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
147 %endif
148 %if %{with x11}
149 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
150 %endif
151 %if %{with xwayland}
152 %attr(755,root,root) %{_libdir}/weston/xwayland.so
153 %endif
154 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
155 %attr(755,root,root) %{_libdir}/weston/tablet-shell.so
156 %{_datadir}/weston
157 %{_mandir}/man1/weston.1*
158 %{_mandir}/man5/weston.ini.5*
159 %{_mandir}/man7/weston-drm.7*
160
161 # noinst, too common names - package in %{name}-demos with weston- prefix?
162 # "simple clients"
163 #%attr(755,root,root) %{_bindir}/simple-egl
164 #%attr(755,root,root) %{_bindir}/simple-shm
165 #%attr(755,root,root) %{_bindir}/simple-touch
166 %if %{with clients}
167 #%attr(755,root,root) %{_bindir}/clickdot
168 #%attr(755,root,root) %{_bindir}/dnd
169 #%attr(755,root,root) %{_bindir}/editor
170 #%attr(755,root,root) %{_bindir}/eventdemo
171 #%attr(755,root,root) %{_bindir}/flower
172 #%attr(755,root,root) %{_bindir}/image
173 #%attr(755,root,root) %{_bindir}/keyboard
174 #%attr(755,root,root) %{_bindir}/resizor
175 #%attr(755,root,root) %{_bindir}/smoke
176 # "full GL" clients
177 #%attr(755,root,root) %{_bindir}/gears
178 # poppler
179 #%attr(755,root,root) %{_bindir}/view
180 %endif
181
182 %files devel
183 %defattr(644,root,root,755)
184 %{_includedir}/weston
185 %{_pkgconfigdir}/weston.pc
This page took 0.046321 seconds and 2 git commands to generate.