]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
a66d2ca8a02eebf9689956eff57ef0b437d6e503
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_with     rdp             # RDP compositor (needs freerdp 1.1.0)
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  vaapi           # vaapi recorder
8 %bcond_without  wlaunch         # weston launch
9 %bcond_without  xwayland        # X server launcher
10 %bcond_without  sclients        # simple clients
11 %bcond_without  clients         # non-simple + full GL clients
12 #
13 Summary:        Weston - Wayland demos
14 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
15 Name:           weston
16 Version:        1.4.0
17 Release:        2
18 License:        MIT
19 Group:          Applications
20 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
21 # Source0-md5:  4438d2b1f3c9ba9a4a2b10d89fac6fd0
22 URL:            http://wayland.freedesktop.org/
23 BuildRequires:  Mesa-libEGL-devel >= 7.10
24 # GLESv2
25 BuildRequires:  Mesa-libGLES-devel
26 # for wayland and sclients, but also desktop-shell, which is always enabled
27 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
28 BuildRequires:  cairo-devel >= 1.10.0
29 BuildRequires:  colord-devel >= 0.1.27
30 BuildRequires:  dbus-devel >= 1.6
31 %{?with_rdp:BuildRequires:      freerdp-devel >= 1.1.0}
32 BuildRequires:  lcms2-devel >= 2
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libpng-devel
35 %if %{with vaapi}
36 BuildRequires:  libva-devel >= 0.34.0
37 BuildRequires:  libva-drm-devel >= 0.34.0
38 %endif
39 BuildRequires:  libwebp-devel
40 BuildRequires:  pixman-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  tar >= 1:1.22
43 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
44 BuildRequires:  wayland-devel >= 1.4.0
45 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
46 BuildRequires:  xz
47 %if %{with drm}
48 BuildRequires:  Mesa-libgbm-devel
49 BuildRequires:  libdrm-devel >= 2.4.30
50 BuildRequires:  mtdev-devel >= 1.1.0
51 BuildRequires:  udev-devel >= 1:136
52 %endif
53 %if %{with x11}
54 BuildRequires:  libxcb-devel
55 BuildRequires:  xorg-lib-libX11-devel
56 %endif
57 %if %{with wlaunch}
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pam-devel
60 BuildRequires:  systemd-devel >= 1:198
61 %endif
62 %if %{with xwayland}
63 BuildRequires:  libxcb-devel
64 BuildRequires:  pkgconfig(cairo-xcb)
65 BuildRequires:  xorg-lib-libXcursor-devel
66 %endif
67 %if %{with clients}
68 BuildRequires:  OpenGL-GLU-devel
69 BuildRequires:  cairo-devel >= 1.11.3
70 BuildRequires:  gdk-pixbuf2-devel >= 2.0
71 BuildRequires:  glib2-devel >= 2.0
72 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
73 BuildRequires:  pkgconfig(cairo-gl)
74 BuildRequires:  poppler-glib-devel
75 %endif
76 Requires:       Mesa-libwayland-egl >= 9.0-2
77 Requires:       wayland >= 1.4.0
78 Requires:       xorg-lib-libxkbcommon >= 0.3.0
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Weston contains a few demo application for the Wayland project.
83 There's a sample compositor that can run on KMS, under X11 or under
84 another Wayland compositor and there's a handful of simple clients
85 that demonstrate various aspects of Wayland.
86
87 %description -l pl.UTF-8
88 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
89 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
90 X11 lub pod innym serwerem składającym Wayland; są także proste
91 programy klienckie demonstrujące różne aspekty protokołu Wayland.
92
93 %package devel
94 Summary:        Header files for Weston plugin development
95 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
96 Group:          Development/Libraries
97 Requires:       Mesa-libEGL-devel >= 7.10
98 # GLESv2
99 Requires:       Mesa-libGLES-devel
100 Requires:       pixman-devel
101 Requires:       wayland-devel >= 1.4.0
102 Requires:       xorg-lib-libxkbcommon-devel >= 0.3.0
103
104 %description devel
105 Header files for Weston plugin development.
106
107 %description devel -l pl.UTF-8
108 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
109
110 %prep
111 %setup -q
112
113 %build
114 %configure \
115         %{!?with_clients:--disable-clients} \
116         %{!?with_drm:--disable-drm-compositor} \
117         %{?with_rdp:--enable-rdp-compositor} \
118         %{!?with_sclients:--disable-simple-clients} \
119         --disable-setuid-install \
120         --disable-silent-rules \
121         %{!?with_static_libs:--disable-static} \
122         %{!?with_vaapi:--disable-vaapi-recorder} \
123         %{!?with_wlaunch:--disable-weston-launch} \
124         %{!?with_x11:--disable-x11-compositor} \
125         %{!?with_xwayland:--disable-xwayland} \
126         %{?with_clients:--with-cairo=gl}
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc README
143 %attr(755,root,root) %{_bindir}/wcap-decode
144 %attr(755,root,root) %{_bindir}/weston-info
145 # composer
146 %attr(755,root,root) %{_bindir}/weston
147 %if %{with wlaunch}
148 %attr(755,root,root) %{_bindir}/weston-launch
149 %endif
150 %if %{with clients}
151 %attr(755,root,root) %{_bindir}/weston-terminal
152 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
153 %attr(755,root,root) %{_libexecdir}/weston-keyboard
154 %attr(755,root,root) %{_libexecdir}/weston-screensaver
155 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
156 %endif
157 %attr(755,root,root) %{_libexecdir}/weston-simple-im
158 %dir %{_libdir}/weston
159 %attr(755,root,root) %{_libdir}/weston/cms-colord.so
160 %attr(755,root,root) %{_libdir}/weston/cms-static.so
161 %if %{with drm}
162 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
163 %endif
164 %attr(755,root,root) %{_libdir}/weston/fbdev-backend.so
165 %attr(755,root,root) %{_libdir}/weston/gl-renderer.so
166 %attr(755,root,root) %{_libdir}/weston/headless-backend.so
167 %if %{with rdp}
168 %attr(755,root,root) %{_libdir}/weston/rdp-backend.so
169 %endif
170 %if %{with wayland}
171 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
172 %endif
173 %if %{with x11}
174 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
175 %endif
176 %if %{with xwayland}
177 %attr(755,root,root) %{_libdir}/weston/xwayland.so
178 %endif
179 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
180 %{_datadir}/weston
181 %{_mandir}/man1/weston.1*
182 %{_mandir}/man5/weston.ini.5*
183 %{_mandir}/man7/weston-drm.7*
184
185 # noinst by default - --enable-demo-clients and package in %{name}-demos?
186 # "simple clients"
187 #%attr(755,root,root) %{_bindir}/weston-simple-egl
188 #%attr(755,root,root) %{_bindir}/weston-simple-shm
189 #%attr(755,root,root) %{_bindir}/weston-simple-touch
190 %if %{with clients}
191 #%attr(755,root,root) %{_bindir}/weston-calibrator
192 #%attr(755,root,root) %{_bindir}/weston-clickdot
193 #%attr(755,root,root) %{_bindir}/weston-editor
194 #%attr(755,root,root) %{_bindir}/weston-eventdemo
195 #%attr(755,root,root) %{_bindir}/weston-fullscreen
196 #%attr(755,root,root) %{_bindir}/weston-cliptest
197 #%attr(755,root,root) %{_bindir}/weston-dnd
198 #%attr(755,root,root) %{_bindir}/weston-flower
199 #%attr(755,root,root) %{_bindir}/weston-image
200 #%attr(755,root,root) %{_bindir}/weston-resizor
201 #%attr(755,root,root) %{_bindir}/weston-smoke
202 #%attr(755,root,root) %{_bindir}/weston-transformed
203 # "full GL" clients
204 #%attr(755,root,root) %{_bindir}/weston-gears
205 # poppler
206 #%attr(755,root,root) %{_bindir}/weston-view
207 %endif
208
209 %files devel
210 %defattr(644,root,root,755)
211 %{_includedir}/weston
212 %{_pkgconfigdir}/weston.pc
This page took 0.124138 seconds and 2 git commands to generate.