]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
768bef9ae794981cc1d9a619d473c7970b8d349b
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_with     openwfd         # OpenWF compositor
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  wlaunch         # weston launch
8 %bcond_without  xwayland        # X server launcher
9 %bcond_without  sclients        # simple clients
10 %bcond_without  clients         # non-simple + full GL clients
11 #
12 Summary:        Weston - Wayland demos
13 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
14 Name:           weston
15 Version:        1.0.0
16 Release:        1
17 License:        MIT
18 Group:          Applications
19 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
20 # Source0-md5:  c33a470d9c23d0f0a04b1b9f1a034da4
21 URL:            http://wayland.freedesktop.org/
22 BuildRequires:  Mesa-libEGL-devel >= 7.10
23 BuildRequires:  Mesa-libGLES-devel
24 # for wayland and sclients, but also desktop-shell, which is always enabled
25 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
26 BuildRequires:  cairo-devel >= 1.10.0
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libwebp-devel
30 BuildRequires:  pixman-devel
31 BuildRequires:  pkgconfig
32 BuildRequires:  tar >= 1:1.22
33 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
34 BuildRequires:  wayland-devel = 1.0.0
35 BuildRequires:  xorg-lib-libxkbcommon-devel
36 BuildRequires:  xz
37 %if %{with drm}
38 BuildRequires:  Mesa-libgbm-devel
39 BuildRequires:  libdrm-devel >= 2.4.30
40 BuildRequires:  mtdev-devel >= 1.1.0
41 BuildRequires:  udev-devel >= 1:136
42 %endif
43 %if %{with openwfd}
44 BuildRequires:  Mesa-libgbm-devel
45 # what package?
46 BuildRequires   pkgconfig(openwfd)
47 %endif
48 %if %{with x11}
49 BuildRequires:  libxcb-devel
50 BuildRequires:  xorg-lib-libX11-devel
51 %endif
52 %if %{with wlaunch}
53 BuildRequires:  libdrm-devel
54 BuildRequires:  pam-devel
55 BuildRequires:  systemd-devel
56 %endif
57 %if %{with xwayland}
58 BuildRequires:  libxcb-devel
59 BuildRequires:  pkgconfig(cairo-xcb)
60 BuildRequires:  xorg-lib-libXcursor-devel
61 %endif
62 %if %{with clients}
63 BuildRequires:  cairo-devel >= 1.11.3
64 BuildRequires:  gdk-pixbuf2-devel >= 2.0
65 BuildRequires:  glib2-devel >= 2.0
66 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
67 BuildRequires:  poppler-glib-devel
68 %endif
69 Requires:       Mesa-libwayland-egl >= 9.0-2
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Weston contains a few demo application for the Wayland project.
74 There's a sample compositor that can run on KMS, under X11 or under
75 another Wayland compositor and there's a handful of simple clients
76 that demonstrate various aspects of Wayland.
77
78 %description -l pl.UTF-8
79 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
80 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
81 X11 lub pod innym serwerem składającym Wayland; są także proste
82 programy klienckie demonstrujące różne aspekty protokołu Wayland.
83
84 %prep
85 %setup -q
86
87 %build
88 %configure \
89         %{!?with_clients:--disable-clients} \
90         %{!?with_drm:--disable-drm-compositor} \
91         %{!?with_sclients:--disable-simple-clients} \
92         --disable-setuid-install \
93         --disable-silent-rules \
94         %{!?with_static_libs:--disable-static} \
95         %{!?with_wlaunch:--disable-weston-launch} \
96         %{!?with_x11:--disable-x11-compositor} \
97         %{!?with_xwayland:--disable-xwayland}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc README
114 %attr(755,root,root) %{_bindir}/wcap-decode
115 %attr(755,root,root) %{_bindir}/weston-info
116 # composer
117 %attr(755,root,root) %{_bindir}/weston
118 %if %{with wlaunch}
119 %attr(755,root,root) %{_bindir}/weston-launch
120 %endif
121 %if %{with clients}
122 %attr(755,root,root) %{_bindir}/weston-terminal
123 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
124 %attr(755,root,root) %{_libexecdir}/weston-screensaver
125 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
126 %attr(755,root,root) %{_libexecdir}/weston-tablet-shell
127 %endif
128 %dir %{_libdir}/weston
129 %if %{with drm}
130 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
131 %endif
132 %if %{with openwfd}
133 %attr(755,root,root) %{_libdir}/weston/openwfd-backend.so
134 %endif
135 %if %{with wayland}
136 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
137 %endif
138 %if %{with x11}
139 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
140 %endif
141 %if %{with xwayland}
142 %attr(755,root,root) %{_libdir}/weston/xwayland.so
143 %endif
144 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
145 %attr(755,root,root) %{_libdir}/weston/tablet-shell.so
146 %{_datadir}/weston
147 %{_mandir}/man1/weston.1*
148
149 # noinst, too common names - package in %{name}-demos with weston- prefix?
150 # "simple clients"
151 #%attr(755,root,root) %{_bindir}/simple-egl
152 #%attr(755,root,root) %{_bindir}/simple-shm
153 #%attr(755,root,root) %{_bindir}/simple-touch
154 %if %{with clients}
155 #%attr(755,root,root) %{_bindir}/clickdot
156 #%attr(755,root,root) %{_bindir}/dnd
157 #%attr(755,root,root) %{_bindir}/editor
158 #%attr(755,root,root) %{_bindir}/eventdemo
159 #%attr(755,root,root) %{_bindir}/flower
160 #%attr(755,root,root) %{_bindir}/image
161 #%attr(755,root,root) %{_bindir}/keyboard
162 #%attr(755,root,root) %{_bindir}/resizor
163 #%attr(755,root,root) %{_bindir}/smoke
164 # "full GL" clients
165 #%attr(755,root,root) %{_bindir}/gears
166 # poppler
167 #%attr(755,root,root) %{_bindir}/view
168 %endif
This page took 0.108049 seconds and 2 git commands to generate.