]> git.pld-linux.org Git - packages/weston.git/blob - weston.spec
- updated to 1.5.0
[packages/weston.git] / weston.spec
1 #
2 # Conditional build:
3 %bcond_without  drm             # DRM compositor
4 %bcond_with     rdp             # RDP compositor (needs freerdp 1.1.0)
5 %bcond_without  wayland         # wayland (nested) compositor
6 %bcond_without  x11             # X11 compositor
7 %bcond_without  libinput        # libinput backend
8 %bcond_without  vaapi           # vaapi recorder
9 %bcond_without  wlaunch         # weston launch
10 %bcond_without  xwayland        # X server launcher
11 %bcond_without  sclients        # simple clients
12 %bcond_without  clients         # non-simple + full GL clients
13 #
14 Summary:        Weston - Wayland demos
15 Summary(pl.UTF-8):      Weston - programy demonstracyjne dla protokołu Wayland
16 Name:           weston
17 Version:        1.5.0
18 Release:        1
19 License:        MIT
20 Group:          Applications
21 Source0:        http://wayland.freedesktop.org/releases/%{name}-%{version}.tar.xz
22 # Source0-md5:  8eb40d230efc2411f083c20656534780
23 URL:            http://wayland.freedesktop.org/
24 BuildRequires:  Mesa-libEGL-devel >= 7.10
25 # GLESv2
26 BuildRequires:  Mesa-libGLES-devel
27 # for wayland and sclients, but also desktop-shell, which is always enabled
28 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0-2
29 BuildRequires:  cairo-devel >= 1.10.0
30 BuildRequires:  colord-devel >= 0.1.27
31 BuildRequires:  dbus-devel >= 1.6
32 %{?with_rdp:BuildRequires:      freerdp-devel >= 1.1.0}
33 BuildRequires:  lcms2-devel >= 2
34 %{?with_libinput:BuildRequires: libinput-devel >= 0.1.0}
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel
37 %if %{with vaapi}
38 BuildRequires:  libva-devel >= 0.34.0
39 BuildRequires:  libva-drm-devel >= 0.34.0
40 %endif
41 BuildRequires:  libwebp-devel
42 BuildRequires:  pixman-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  tar >= 1:1.22
45 # wayland-server always; wayland-client if with_wayland || with_sclients || with_clients; wayland-cursor if with_clients
46 BuildRequires:  wayland-devel >= 1.4.0
47 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
48 BuildRequires:  xz
49 %if %{with drm}
50 BuildRequires:  Mesa-libgbm-devel
51 BuildRequires:  libdrm-devel >= 2.4.30
52 BuildRequires:  mtdev-devel >= 1.1.0
53 BuildRequires:  udev-devel >= 1:136
54 %endif
55 %if %{with x11}
56 BuildRequires:  libxcb-devel
57 BuildRequires:  xorg-lib-libX11-devel
58 %endif
59 %if %{with wlaunch}
60 BuildRequires:  libdrm-devel
61 BuildRequires:  pam-devel
62 BuildRequires:  systemd-devel >= 1:198
63 %endif
64 %if %{with xwayland}
65 BuildRequires:  libxcb-devel
66 BuildRequires:  pkgconfig(cairo-xcb)
67 BuildRequires:  xorg-lib-libXcursor-devel
68 %endif
69 %if %{with clients}
70 BuildRequires:  OpenGL-GLU-devel
71 BuildRequires:  cairo-devel >= 1.11.3
72 BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
73 BuildRequires:  pkgconfig(cairo-gl)
74 %endif
75 Requires:       Mesa-libEGL >= 7.10
76 Requires:       Mesa-libwayland-egl >= 9.0-2
77 Requires:       cairo >= %{?with_clients:1.11.3}%{!?with_clients:1.10.0}
78 Requires:       colord-libs >= 0.1.27
79 Requires:       dbus-libs >= 1.6
80 %{?with_rdp:Requires:   freerdp >= 1.1.0}
81 %{?with_drm:Requires:   libdrm >= 2.4.30}
82 %{?with_libinput:Requires:      libinput >= 0.1.0}
83 %{?with_drm:Requires:   mtdev >= 1.1.0}
84 %if %{with vaapi}
85 Requires:       libva >= 0.34.0
86 Requires:       libva-drm >= 0.34.0
87 %endif
88 %{?with_wlaunch:Requires:       systemd-libs >= 1:198}
89 %{?with_drm:Requires:   udev-libs >= 1:136}
90 Requires:       wayland >= 1.4.0
91 Requires:       xorg-lib-libxkbcommon >= 0.3.0
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %description
95 Weston contains a few demo application for the Wayland project.
96 There's a sample compositor that can run on KMS, under X11 or under
97 another Wayland compositor and there's a handful of simple clients
98 that demonstrate various aspects of Wayland.
99
100 %description -l pl.UTF-8
101 Weston zawiera kilka aplikacji demonstracyjnych dla projektu Wayland.
102 Jest przykładowy serwer składający, który można uruchomić pod KMS, pod
103 X11 lub pod innym serwerem składającym Wayland; są także proste
104 programy klienckie demonstrujące różne aspekty protokołu Wayland.
105
106 %package devel
107 Summary:        Header files for Weston plugin development
108 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek dla Westona
109 Group:          Development/Libraries
110 Requires:       Mesa-libEGL-devel >= 7.10
111 # GLESv2
112 Requires:       Mesa-libGLES-devel
113 Requires:       pixman-devel
114 Requires:       wayland-devel >= 1.4.0
115 Requires:       xorg-lib-libxkbcommon-devel >= 0.3.0
116
117 %description devel
118 Header files for Weston plugin development.
119
120 %description devel -l pl.UTF-8
121 Pliki nagłówkowe do tworzenia wtyczek dla Westona.
122
123 %prep
124 %setup -q
125
126 %build
127 %configure \
128         %{!?with_clients:--disable-clients} \
129         %{!?with_drm:--disable-drm-compositor} \
130         %{?with_libinput:--enable-libinput-backend} \
131         %{?with_rdp:--enable-rdp-compositor} \
132         %{!?with_sclients:--disable-simple-clients} \
133         --disable-setuid-install \
134         --disable-silent-rules \
135         %{!?with_vaapi:--disable-vaapi-recorder} \
136         %{!?with_wlaunch:--disable-weston-launch} \
137         %{!?with_x11:--disable-x11-compositor} \
138         %{!?with_xwayland:--disable-xwayland} \
139         %{?with_clients:--with-cairo=gl}
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %{__rm} $RPM_BUILD_ROOT%{_libdir}/weston/*.la
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %doc README
156 %attr(755,root,root) %{_bindir}/wcap-decode
157 %attr(755,root,root) %{_bindir}/weston-info
158 # composer
159 %attr(755,root,root) %{_bindir}/weston
160 %if %{with wlaunch}
161 %attr(755,root,root) %{_bindir}/weston-launch
162 %endif
163 %if %{with clients}
164 %attr(755,root,root) %{_bindir}/weston-terminal
165 %attr(755,root,root) %{_libexecdir}/weston-desktop-shell
166 %attr(755,root,root) %{_libexecdir}/weston-keyboard
167 %attr(755,root,root) %{_libexecdir}/weston-screensaver
168 %attr(755,root,root) %{_libexecdir}/weston-screenshooter
169 %endif
170 %attr(755,root,root) %{_libexecdir}/weston-simple-im
171 %dir %{_libdir}/weston
172 %attr(755,root,root) %{_libdir}/weston/cms-colord.so
173 %attr(755,root,root) %{_libdir}/weston/cms-static.so
174 %if %{with drm}
175 %attr(755,root,root) %{_libdir}/weston/drm-backend.so
176 %endif
177 %attr(755,root,root) %{_libdir}/weston/fbdev-backend.so
178 %attr(755,root,root) %{_libdir}/weston/gl-renderer.so
179 %attr(755,root,root) %{_libdir}/weston/headless-backend.so
180 %if %{with rdp}
181 %attr(755,root,root) %{_libdir}/weston/rdp-backend.so
182 %endif
183 %if %{with wayland}
184 %attr(755,root,root) %{_libdir}/weston/wayland-backend.so
185 %endif
186 %if %{with x11}
187 %attr(755,root,root) %{_libdir}/weston/x11-backend.so
188 %endif
189 %if %{with xwayland}
190 %attr(755,root,root) %{_libdir}/weston/xwayland.so
191 %endif
192 %attr(755,root,root) %{_libdir}/weston/desktop-shell.so
193 %attr(755,root,root) %{_libdir}/weston/fullscreen-shell.so
194 %{_datadir}/weston
195 %{_mandir}/man1/weston.1*
196 %{_mandir}/man5/weston.ini.5*
197 %{_mandir}/man7/weston-drm.7*
198
199 # noinst by default - --enable-demo-clients and package in %{name}-demos?
200 # "simple clients"
201 #%attr(755,root,root) %{_bindir}/weston-multi-resource
202 #%attr(755,root,root) %{_bindir}/weston-simple-egl
203 #%attr(755,root,root) %{_bindir}/weston-simple-shm
204 #%attr(755,root,root) %{_bindir}/weston-simple-touch
205 %if %{with clients}
206 #%attr(755,root,root) %{_bindir}/weston-calibrator
207 #%attr(755,root,root) %{_bindir}/weston-clickdot
208 #%attr(755,root,root) %{_bindir}/weston-cliptest
209 #%attr(755,root,root) %{_bindir}/weston-dnd
210 #%attr(755,root,root) %{_bindir}/weston-editor
211 #%attr(755,root,root) %{_bindir}/weston-eventdemo
212 #%attr(755,root,root) %{_bindir}/weston-flower
213 #%attr(755,root,root) %{_bindir}/weston-fullscreen
214 #%attr(755,root,root) %{_bindir}/weston-image
215 #%attr(755,root,root) %{_bindir}/weston-resizor
216 #%attr(755,root,root) %{_bindir}/weston-scaler
217 #%attr(755,root,root) %{_bindir}/weston-smoke
218 #%attr(755,root,root) %{_bindir}/weston-stacking
219 #%attr(755,root,root) %{_bindir}/weston-transformed
220 # "full GL" clients
221 #%attr(755,root,root) %{_bindir}/weston-gears
222 %endif
223
224 %files devel
225 %defattr(644,root,root,755)
226 %{_includedir}/weston
227 %{_pkgconfigdir}/weston.pc
This page took 0.13528 seconds and 3 git commands to generate.