]> git.pld-linux.org Git - packages/weechat.git/blob - weechat.spec
- build without doc
[packages/weechat.git] / weechat.spec
1 #
2 # TODO:
3 # - consider doing subpackages for all those plugins (which one should be in main package ?)
4 #
5 # Conditional build:
6 %bcond_without  aspell  # don't build aspell support
7 %bcond_without  gtk     # build gtk support
8 %bcond_with     qt      # don't build qt support
9 %bcond_without  ruby    # don't build ruby plugin support
10 %bcond_without  lua     # don't build lua plugin support
11 %bcond_without  perl    # don't build perl plugin support
12 %bcond_without  python  # don't build python plugin support
13 %bcond_without  gnutls  # don't build gnutls support
14
15 %define         skip_post_check_so      ruby.so.0.0.0
16
17 Summary:        WeeChat - fast and light chat environment
18 Summary(pl.UTF-8):      WeeChat - szybkie i lekkie środowisko do rozmów
19 Name:           weechat
20 Version:        0.3.4
21 Release:        1
22 License:        GPL v3+
23 Group:          Applications/Communications
24 Source0:        http://www.weechat.org/files/src/%{name}-%{version}.tar.gz
25 # Source0-md5:  a36a89b6012994dc67c4c0ea36784d1d
26 Patch0:         %{name}-ac.patch
27 Patch1:         %{name}-plugins_header.patch
28 Patch2:         %{name}-curses.patch
29 URL:            http://www.weechat.org/
30 %{?with_aspell:BuildRequires:   aspell-devel}
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  gettext-devel
34 %{?with_gnutls:BuildRequires:   gnutls-devel}
35 %{?with_gtk:BuildRequires:      gtk+2-devel}
36 BuildRequires:  libtool
37 %{?with_lua:BuildRequires:      lua-devel >= 5.0}
38 BuildRequires:  ncurses-devel
39 %{?with_perl:BuildRequires:     perl-devel}
40 BuildRequires:  pkgconfig
41 %if %{with python}
42 BuildRequires:  python-devel
43 BuildRequires:  python-modules
44 %endif
45 %{?with_qt:BuildRequires:       qt-devel}
46 BuildRequires:  rpmbuild(macros) >= 1.129
47 %{?with_ruby:BuildRequires:     ruby-devel}
48 BuildRequires:  tcl-devel
49 Requires:       %{name}-common = %{version}-%{release}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 WeeChat (Wee Enhanced Environment for Chat) is a fast and light chat
54 environment for many operating systems. Everything can be done with a
55 keyboard. It is customizable and extensible with scripts.
56
57 %description -l pl.UTF-8
58 WeeChat (Wee Ehanced Environment for Chat) to szybkie i lekkie
59 środowisko do rozmów dla wielu systemów operacyjnych. Pozwala wszystko
60 zrobić przy pomocy klawiatury. Jest konfigurowalne i rozszerzalne za
61 pomocą skryptów.
62
63 %package gtk
64 Summary:        GTK WeeChat UI
65 Group:          Applications/Communications
66 Requires:       %{name}-common = %{version}-%{release}
67
68 %description gtk
69 GTK WeeChat UI.
70
71 %package common
72 Summary:        WeeChat common files
73 Group:          Applications/Communications
74
75 %description common
76 WeeChat common files.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p0
83 sed -i -e 's#PYTHON_LIB=.*#PYTHON_LIB=%{_libdir}#g' configure.in
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__automake}
90 %configure \
91 %if "%{_lib}" == "lib64"
92         --enable-libsuffix=64 \
93 %endif
94         --enable-threads=posix \
95         --disable-doc \
96         --disable-static \
97         --%{?with_qt:en}%{!?with_qt:dis}able-qt \
98         --enable-ncurses \
99         --%{?with_aspell:en}%{!?with_aspell:dis}able-aspell \
100         --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
101         --%{?with_perl:en}%{!?with_perl:dis}able-perl \
102         --%{?with_python:en}%{!?with_python:dis}able-python \
103         --%{?with_ruby:en}%{!?with_ruby:dis}able-ruby \
104         --%{?with_lua:en}%{!?with_lua:dis}able-lua \
105         --%{?with_gnutls:en}%{!?with_gnutls:dis}able-gnutls
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_mandir}/man1
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 rm -f $RPM_BUILD_ROOT%{_libdir}/weechat/plugins/*.la
116 cp doc/weechat-curses.1 $RPM_BUILD_ROOT%{_mandir}/man1
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/weechat-curses
126 %{_mandir}/man1/weechat-curses.1*
127
128 %if %{with gtk}
129 %files gtk
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/weechat-gtk
132 %endif
133
134 %files common -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog NEWS README UPGRADE_0.3
137 %dir %{_includedir}/weechat
138 %dir %{_libdir}/weechat
139 %dir %{_libdir}/weechat/plugins
140 %{_includedir}/weechat/weechat-plugin.h
141 %attr(755,root,root) %{_libdir}/weechat/plugins/alias.so*
142 %attr(755,root,root) %{_libdir}/weechat/plugins/aspell.so*
143 %attr(755,root,root) %{_libdir}/weechat/plugins/charset.so*
144 %attr(755,root,root) %{_libdir}/weechat/plugins/fifo.so*
145 %attr(755,root,root) %{_libdir}/weechat/plugins/irc.so*
146 %attr(755,root,root) %{_libdir}/weechat/plugins/logger.so*
147 %attr(755,root,root) %{_libdir}/weechat/plugins/lua.so*
148 %attr(755,root,root) %{_libdir}/weechat/plugins/perl.so*
149 %attr(755,root,root) %{_libdir}/weechat/plugins/python.so*
150 %attr(755,root,root) %{_libdir}/weechat/plugins/relay.so*
151 %attr(755,root,root) %{_libdir}/weechat/plugins/rmodifier.so*
152 %attr(755,root,root) %{_libdir}/weechat/plugins/ruby.so*
153 %attr(755,root,root) %{_libdir}/weechat/plugins/tcl.so*
154 %attr(755,root,root) %{_libdir}/weechat/plugins/xfer.so*
155 %{_pkgconfigdir}/weechat.pc
This page took 0.03615 seconds and 4 git commands to generate.