]> git.pld-linux.org Git - packages/weechat.git/blob - weechat.spec
drop needless common subpackage
[packages/weechat.git] / weechat.spec
1 # TODO:
2 # - consider doing subpackages for all those plugins (which one should be in main package ?)
3 # - desktop file (icon exists, but no desktop file?)
4 #
5 # Conditional build:
6 # Features
7 %bcond_without  aspell  # don't build aspell support
8 %bcond_without  gnutls  # don't build gnutls support
9 %bcond_without  doc     # don't build docs
10 # Bindings
11 %bcond_without  guile   # don't enable Scheme (guile) scripting language
12 %bcond_without  lua     # don't enable Lua scripting language
13 %bcond_without  perl    # don't enable Perl scripting language
14 %bcond_without  python  # don't enable Python scripting language
15 %bcond_without  ruby    # don't enable Ruby scripting language
16 %bcond_without  tcl     # don't enable Tcl scripting language
17
18 Summary:        WeeChat - fast and light chat environment
19 Summary(pl.UTF-8):      WeeChat - szybkie i lekkie środowisko do rozmów
20 Name:           weechat
21 Version:        1.2
22 Release:        1
23 License:        GPL v3+
24 Group:          Applications/Communications
25 Source0:        http://www.weechat.org/files/src/%{name}-%{version}.tar.gz
26 # Source0-md5:  7e561d9093af164c2ab32634ece0e0ef
27 Patch2:         %{name}-curses.patch
28 URL:            http://www.weechat.org/
29 %{?with_aspell:BuildRequires:   aspell-devel}
30 BuildRequires:  cmake
31 BuildRequires:  curl-devel
32 BuildRequires:  gettext-tools
33 %{?with_gnutls:BuildRequires:   gnutls-devel}
34 %{?with_guile:BuildRequires:    guile-devel}
35 BuildRequires:  libatomic_ops
36 BuildRequires:  libgcrypt-devel
37 %{?with_lua:BuildRequires:      lua51-devel}
38 BuildRequires:  ncurses-devel
39 %{?with_perl:BuildRequires:     perl-devel}
40 BuildRequires:  pkgconfig
41 BuildRequires:  sed >= 4.0
42 %if %{with python}
43 BuildRequires:  python-devel
44 BuildRequires:  python-modules
45 %endif
46 BuildRequires:  rpmbuild(macros) >= 1.129
47 %{?with_ruby:BuildRequires:     ruby-devel}
48 BuildRequires:  tcl-devel
49 Obsoletes:      weechat-common
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         skip_post_check_so      ruby.so.0.0.0
53
54 %description
55 WeeChat (Wee Enhanced Environment for Chat) is a fast and light chat
56 environment for many operating systems. Everything can be done with a
57 keyboard. It is customizable and extensible with scripts.
58
59 %description -l pl.UTF-8
60 WeeChat (Wee Ehanced Environment for Chat) to szybkie i lekkie
61 środowisko do rozmów dla wielu systemów operacyjnych. Pozwala wszystko
62 zrobić przy pomocy klawiatury. Jest konfigurowalne i rozszerzalne za
63 pomocą skryptów.
64
65 %package doc
66 Summary:        Manual for weechat
67 Group:          Documentation
68
69 %description doc
70 HTML documentation for weechat.
71
72 %prep
73 %setup -q
74 %patch2 -p0
75
76 %{__sed} -i -e 's#PYTHON_LIB=.*#PYTHON_LIB=%{_libdir}#g' configure.ac
77 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
78
79 %build
80 install -d build
81 cd build
82 %cmake \
83         -DPREFIX=%{_prefix} \
84         -DLIBDIR=%{_libdir} \
85         -DENABLE_NCURSES=ON \
86         -DENABLE_ASPELL=%{?with_aspell:ON}%{!?with_aspell:OFF} \
87         -DENABLE_GNUTLS=%{?with_gnutls:ON}%{!?with_gnutls:OFF} \
88         -DENABLE_DOC=%{?with_doc:ON}%{!?with_doc:OFF} \
89         -DENABLE_PERL=%{?with_perl:ON}%{!?with_perl:OFF} \
90         -DENABLE_PYTHON=%{?with_python:ON}%{!?with_python:OFF} \
91         -DENABLE_RUBY=%{?with_ruby:ON}%{!?with_ruby:OFF} \
92         -DENABLE_LUA=%{?with_lua:ON}%{!?with_lua:OFF} \
93         -DENABLE_GUILE=%{?with_guile:ON}%{!?with_guile:OFF} \
94         -DENABLE_TCL=%{?with_tcl:ON}%{!?with_tcl:OFF} \
95         -DENABLE_MAN=ON \
96         -DENABLE_DOC=ON \
97         ..
98
99 %{__make} VERBOSE=1
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 %{__make} -C build install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # symlink to "weechat"
107 %{__rm} $RPM_BUILD_ROOT%{_bindir}/weechat-curses
108
109 # no -devel, drop
110 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/%{name}
111 %{__rm} $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS.asciidoc ChangeLog.asciidoc README.asciidoc ReleaseNotes.asciidoc
121 %attr(755,root,root) %{_bindir}/weechat
122 %{_mandir}/man1/weechat.1*
123 %lang(de) %{_mandir}/de/man1/weechat.1*
124 %lang(fr) %{_mandir}/fr/man1/weechat.1*
125 %lang(it) %{_mandir}/it/man1/weechat.1*
126 %lang(ja) %{_mandir}/ja/man1/weechat.1*
127 %lang(pl) %{_mandir}/pl/man1/weechat.1*
128 %lang(ru) %{_mandir}/ru/man1/weechat.1*
129 %{_iconsdir}/hicolor/*/apps/weechat.png
130
131 %dir %{_libdir}/%{name}
132 %dir %{_libdir}/%{name}/plugins
133 %attr(755,root,root) %{_libdir}/%{name}/plugins/alias.so
134 %attr(755,root,root) %{_libdir}/%{name}/plugins/charset.so
135 %attr(755,root,root) %{_libdir}/%{name}/plugins/exec.so
136 %attr(755,root,root) %{_libdir}/%{name}/plugins/fifo.so
137 %attr(755,root,root) %{_libdir}/%{name}/plugins/irc.so
138 %attr(755,root,root) %{_libdir}/%{name}/plugins/javascript.so
139 %attr(755,root,root) %{_libdir}/%{name}/plugins/logger.so
140 %attr(755,root,root) %{_libdir}/%{name}/plugins/relay.so
141 %attr(755,root,root) %{_libdir}/%{name}/plugins/script.so
142 %attr(755,root,root) %{_libdir}/%{name}/plugins/trigger.so
143 %attr(755,root,root) %{_libdir}/%{name}/plugins/xfer.so
144
145 # addons
146 %{?with_aspell:%attr(755,root,root) %{_libdir}/%{name}/plugins/aspell.so}
147
148 # language bindings
149 %{?with_guile:%attr(755,root,root) %{_libdir}/%{name}/plugins/guile.so}
150 %{?with_lua:%attr(755,root,root) %{_libdir}/%{name}/plugins/lua.so}
151 %{?with_perl:%attr(755,root,root) %{_libdir}/%{name}/plugins/perl.so}
152 %{?with_python:%attr(755,root,root) %{_libdir}/%{name}/plugins/python.so}
153 %{?with_ruby:%attr(755,root,root) %{_libdir}/%{name}/plugins/ruby.so}
154 %{?with_tcl:%attr(755,root,root) %{_libdir}/%{name}/plugins/tcl.so}
155
156 %if %{with doc}
157 %files doc
158 %defattr(644,root,root,755)
159 %dir %{_docdir}/%{name}
160 %lang(de) %{_docdir}/%{name}/*.de.html
161 %lang(en) %{_docdir}/%{name}/*.en.html
162 %lang(es) %{_docdir}/%{name}/*.es.html
163 %lang(fr) %{_docdir}/%{name}/*.fr.html
164 %lang(it) %{_docdir}/%{name}/*.it.html
165 %lang(ja) %{_docdir}/%{name}/*.ja.html
166 %lang(pl) %{_docdir}/%{name}/*.pl.html
167 %lang(ru) %{_docdir}/%{name}/*.ru.html
168 %endif
This page took 0.053214 seconds and 4 git commands to generate.