]> git.pld-linux.org Git - packages/weechat.git/blob - weechat.spec
- add BRs, bconds and functionality
[packages/weechat.git] / weechat.spec
1 %bcond_without  qt      # don't build qt support
2 %bcond_without  ncurses # don't build ncurses support
3 %bcond_without  ruby    # don't build ruby plugin support
4 %bcond_without  lua     # don't build lua plugin support
5 %bcond_without  perl    # don't build perl plugin support
6 %bcond_without  python  # don't build python plugin support
7 %bcond_without  gnutls  # don't build gnutls support
8
9 Summary:        WeeChat
10 Summary(pl.UTF-8):      WeeChat
11 Name:           weechat
12 Version:        0.2.3
13 Release:        0.1
14 License:        GPL
15 Group:          X11/Applications
16 Source0:        http://weechat.flashtux.org/download/%{name}-%{version}.tar.bz2
17 # Source0-md5:  12c39b30988d78e9544acda6e518476f
18 URL:            http://weechat.flashtux.org/
19 %{?with_lgnutls:BuildRequires:  gnutls-devel}
20 %{?with_lua:BuildRequires:      lua-devel}
21 %{?with_ncurses:BuildRequires:  ncurses-devel}
22 %{?with_perl:BuildRequires:     perl-devel}
23 %{?with_python:BuildRequires:   python-devel}
24 %{?with_qt:BuildRequires:       qt-devel}
25 BuildRequires:  rpmbuild(macros) >= 1.129
26 %{?with_ruby:BuildRequires:     ruby-devel}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 WeeChat (Wee Enhanced Environment for Chat) is a fast and light chat
31 environment for many operating systems. Everything can be done with a keyboard.
32 It is customizable and extensible with scripts.
33
34 #%description -l pl.UTF-8
35
36 %prep
37 %setup -q
38
39 %build
40 %configure \
41 %if "%{_lib}" == "lib64"
42         --enable-libsuffix=64 \
43 %endif
44         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
45         --enable-plugins \
46         --with-qt-libraries=%{_libdir} \
47         --%{?with_qt:en}%{!?with_qt:dis}able-qt \
48         --%{?with_ncurses:en}%{!?with_ncurses:dis}able-ncurses \
49         --%{?with_perl:en}%{!?with_perl:dis}able-perl \
50         --%{?with_python:en}%{!?with_python:dis}able-python \
51         --%{?with_ruby:en}%{!?with_ruby:dis}able-ruby \
52         --%{?with_lua:en}%{!?with_lua:dis}able-lua \
53         --%{?with_gnutls:en}%{!?with_gnutls:dis}able-gnutls
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 rm -f $RPM_BUILD_ROOT%{_libdir}/weechat/plugins/*.a
63
64 %find_lang %{name}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files -f %{name}.lang
70 %defattr(644,root,root,755)
71 %doc README FAQ AUTHORS BUGS INSTALL NEWS TODO
72 %attr(755,root,root) %{_bindir}/*
73 %dir %{_libdir}/weechat/plugins
74 %attr(755,root,root) %{_libdir}/weechat/plugins/*.so*
75 %{_libdir}/weechat/plugins/*.la
76 %{_mandir}/man1/*.1.gz
This page took 0.038352 seconds and 4 git commands to generate.