]> git.pld-linux.org Git - packages/weechat.git/blob - weechat.spec
- add -curses.patch
[packages/weechat.git] / weechat.spec
1 #
2 # TODO:
3 # - consider doing subpackages for all those plugins (which one should be in main package ?)
4 #
5 # Conditional build:
6 %bcond_without  aspell  # don't build aspell support
7 %bcond_without  gtk     # build gtk support
8 %bcond_with     qt      # don't build qt support
9 %bcond_without  ruby    # don't build ruby plugin support
10 %bcond_without  lua     # don't build lua plugin support
11 %bcond_without  perl    # don't build perl plugin support
12 %bcond_without  python  # don't build python plugin support
13 %bcond_without  gnutls  # don't build gnutls support
14 #
15 Summary:        WeeChat - fast and light chat environment
16 Summary(pl.UTF-8):      WeeChat - szybkie i lekkie środowisko do rozmów
17 Name:           weechat
18 Version:        0.3.2
19 Release:        3
20 License:        GPL v3+
21 Group:          Applications/Communications
22 Source0:        http://www.weechat.org/files/src/%{name}-%{version}.tar.gz
23 # Source0-md5:  0c4f6e7196703c6eca12217f254612aa
24 Patch0:         %{name}-ac.patch
25 Patch1:         %{name}-plugins_header.patch
26 Patch2:         %{name}-curses.patch
27 URL:            http://www.weechat.org/
28 %{?with_aspell:BuildRequires:   aspell-devel}
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  gettext-devel
32 %{?with_gnutls:BuildRequires:   gnutls-devel}
33 %{?with_gtk:BuildRequires:      gtk+2-devel}
34 BuildRequires:  libtool
35 %{?with_lua:BuildRequires:      lua-devel >= 5.0}
36 BuildRequires:  ncurses-devel
37 %{?with_perl:BuildRequires:     perl-devel}
38 BuildRequires:  pkgconfig
39 %if %{with python}
40 BuildRequires:  python-devel
41 BuildRequires:  python-modules
42 %endif
43 %{?with_qt:BuildRequires:       qt-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.129
45 %{?with_ruby:BuildRequires:     ruby-devel}
46 BuildRequires:  tcl-devel
47 Requires:       %{name}-common = %{version}-%{release}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 WeeChat (Wee Enhanced Environment for Chat) is a fast and light chat
52 environment for many operating systems. Everything can be done with a
53 keyboard. It is customizable and extensible with scripts.
54
55 %description -l pl.UTF-8
56 WeeChat (Wee Ehanced Environment for Chat) to szybkie i lekkie
57 środowisko do rozmów dla wielu systemów operacyjnych. Pozwala wszystko
58 zrobić przy pomocy klawiatury. Jest konfigurowalne i rozszerzalne za
59 pomocą skryptów.
60
61 %package gtk
62 Summary:        GTK WeeChat UI
63 Group:          Applications/Communications
64 Requires:       %{name}-common = %{version}-%{release}
65
66 %description gtk
67 GTK WeeChat UI.
68
69 %package common
70 Summary:        WeeChat common files
71 Group:          Applications/Communications
72
73 %description common
74 WeeChat common files.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80 %patch2 -p0
81 sed -i -e 's#PYTHON_LIB=.*#PYTHON_LIB=%{_libdir}#g' configure.in
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__automake}
88 %configure \
89 %if "%{_lib}" == "lib64"
90         --enable-libsuffix=64 \
91 %endif
92         --enable-threads=posix \
93         --disable-static \
94         --%{?with_qt:en}%{!?with_qt:dis}able-qt \
95         --enable-ncurses \
96         --%{?with_aspell:en}%{!?with_aspell:dis}able-aspell \
97         --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
98         --%{?with_perl:en}%{!?with_perl:dis}able-perl \
99         --%{?with_python:en}%{!?with_python:dis}able-python \
100         --%{?with_ruby:en}%{!?with_ruby:dis}able-ruby \
101         --%{?with_lua:en}%{!?with_lua:dis}able-lua \
102         --%{?with_gnutls:en}%{!?with_gnutls:dis}able-gnutls
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_mandir}/man1
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 rm -f $RPM_BUILD_ROOT%{_libdir}/weechat/plugins/*.la
113 cp doc/weechat-curses.1 $RPM_BUILD_ROOT%{_mandir}/man1
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/weechat-curses
123 %{_mandir}/man1/weechat-curses.1*
124
125 %if %{with gtk}
126 %files gtk
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/weechat-gtk
129 %endif
130
131 %files common -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README UPGRADE_0.3
134 %dir %{_includedir}/weechat
135 %dir %{_libdir}/weechat
136 %dir %{_libdir}/weechat/plugins
137 %{_includedir}/weechat/weechat-plugin.h
138 %attr(755,root,root) %{_libdir}/weechat/plugins/alias.so*
139 %attr(755,root,root) %{_libdir}/weechat/plugins/aspell.so*
140 %attr(755,root,root) %{_libdir}/weechat/plugins/charset.so*
141 %attr(755,root,root) %{_libdir}/weechat/plugins/fifo.so*
142 %attr(755,root,root) %{_libdir}/weechat/plugins/irc.so*
143 %attr(755,root,root) %{_libdir}/weechat/plugins/logger.so*
144 %attr(755,root,root) %{_libdir}/weechat/plugins/lua.so*
145 %attr(755,root,root) %{_libdir}/weechat/plugins/perl.so*
146 %attr(755,root,root) %{_libdir}/weechat/plugins/python.so*
147 %attr(755,root,root) %{_libdir}/weechat/plugins/ruby.so*
148 %attr(755,root,root) %{_libdir}/weechat/plugins/tcl.so*
149 %attr(755,root,root) %{_libdir}/weechat/plugins/xfer.so*
150 %{_pkgconfigdir}/weechat.pc
This page took 0.051733 seconds and 4 git commands to generate.